Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

5 hours ago, dfewsloc said:

my bot just sits there and doesent mine ores at lumby rimi but drops ores if i mine manually?

Seems to be working just fine. Since you don't tell me any specific settings, I cannot properly test whatever settings you are running.

Most likely your Tribot client isn't working correctly. Please check the "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

Share this post


Link to post
Share on other sites
Guest
11 hours ago, polak4_lyfe said:

Dangit another 3 bots got banned :S,
Ill get the hang of it :D

definitely doing something wrong I've got from level 1-73 so far with this.. be smart and sensible..

Share this post


Link to post
Share on other sites

Any known issues with the log-in when world hopping? Sometimes when kicked out to the lobby it runs into errors with inputting the username and password correctly.

Edit2: when the account gets kicked out to the lobby you are displayed 'create new account' and 'existing user.' there is a delay when clicking the latter, which causes the Login Bot to type the password followed by the username in the username input. Obviously, this is not an error caused by you, but I figured it was worth mentioning.

Quote

[16:58:07] TRiBot Release 9.305_12 loaded. (1.8.0_144:/Library/Java/JavaVirtualMachines/jdk1.8.0_144.jdk/Contents/Home/jre)
[16:58:15] Loading human mouse movement data.
[16:58:18] Successfully loaded human mouse data.
[16:58:31] AGENT PATH: /var/folders/9y/xxb4rw417mg7yj4rq8mg46mh0000gp/T/t1_agent_1093051200.jar
[16:58:44] Exception in thread "AWT-EventQueue-1" 
[16:58:44] java.lang.NullPointerException
[16:58:44]     at com.apple.laf.AquaTabbedPaneContrastUI.isPressedAt(AquaTabbedPaneContrastUI.java:96)
[16:58:44]     at com.apple.laf.AquaTabbedPaneContrastUI.paintTitle(AquaTabbedPaneContrastUI.java:63)
[16:58:44]     at com.apple.laf.AquaTabbedPaneUI.paintContents(AquaTabbedPaneUI.java:322)
[16:58:44]     at com.apple.laf.AquaTabbedPaneUI.paintTabNormalFromRect(AquaTabbedPaneUI.java:420)
[16:58:45]     at com.apple.laf.AquaTabbedPaneUI.paintTabNormal(AquaTabbedPaneUI.java:409)
[16:58:45]     at com.apple.laf.AquaTabbedPaneUI.paintAllTabs(AquaTabbedPaneUI.java:168)
[16:58:45]     at com.apple.laf.AquaTabbedPaneUI.paint(AquaTabbedPaneUI.java:151)
[16:58:45]     at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
[16:58:45]     at javax.swing.JComponent.paintComponent(JComponent.java:780)
[16:58:45]     at javax.swing.JComponent.paint(JComponent.java:1056)
[16:58:45]     at javax.swing.JComponent.paintChildren(JComponent.java:889)
[16:58:45]     at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1047)
[16:58:45]     at javax.swing.JComponent.paint(JComponent.java:1065)
[16:58:45]     at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
[16:58:45]     at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1579)
[16:58:45]     at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1502)
[16:58:45]     at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
[16:58:45]     at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
[16:58:45]     at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
[16:58:45]     at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
[16:58:45]     at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
[16:58:45]     at java.security.AccessController.doPrivileged(Native Method)
[16:58:45]     at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
[16:58:45]     at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
[16:58:45]     at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
[16:58:45]     at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
[16:58:45]     at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
[16:58:45]     at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
[16:58:45]     at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
[16:58:45]     at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
[16:58:45]     at java.awt.EventQueue.access$500(EventQueue.java:97)
[16:58:45]     at java.awt.EventQueue$3.run(EventQueue.java:709)
[16:58:45]     at java.awt.EventQueue$3.run(EventQueue.java:703)
[16:58:45]     at java.security.AccessController.doPrivileged(Native Method)
[16:58:45]     at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
[16:58:45]     at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
[16:58:45]     at obf.Ng.dispatchEvent(ho:535)
[16:58:45]     at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
[16:58:45]     at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
[16:58:45]     at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
[16:58:45]     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
[16:58:45]     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
[16:58:45]     at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

 

Edited by FadeRS
add bot debug

Share this post


Link to post
Share on other sites
On 8/18/2017 at 0:23 PM, guywithlsd said:

@Aropupu hey, does aMiner have script arguments? like for bot managers and stuff (:

You can use the argument "last" for the last saved settings or just a setting profile name in the argument to load that profile.

18 hours ago, FadeRS said:

Any known issues with the log-in when world hopping? Sometimes when kicked out to the lobby it runs into errors with inputting the username and password correctly.

Edit2: when the account gets kicked out to the lobby you are displayed 'create new account' and 'existing user.' there is a delay when clicking the latter, which causes the Login Bot to type the password followed by the username in the username input. Obviously, this is not an error caused by you, but I figured it was worth mentioning.

There are plenty of issues with logging back in when using Looking Glass, although everyone doesn't experience all/same issues or any issues. There's nothing I can do about those issues, since logging back in is handled by Tribot. If you are using OSBuddy, make sure you have disabled plugins or settings that could affect it like "remember username" or something like that.

It's also a good idea to keep the runescape client minimized before and after hooking to it with LG. Only interact with it through the Tribot client. Otherwise you can get several issues and there can also be a lot of lag/stuttering.

Edited by Aropupu

Share this post


Link to post
Share on other sites
1 hour ago, Aropupu said:

You can use the argument "last" for the last saved settings or just a setting profile name in the argument to load that profile.

There are plenty of issues with logging back in when using Looking Glass, although everyone doesn't experience all/same issues or any issues. There's nothing I can do about those issues, since logging back in is handled by Tribot. If you are using OSBuddy, make sure you have disabled plugins or settings that could affect it like "remember username" or something like that.

It's also a good idea to keep the runescape client minimized before and after hooking to it with LG. Only interact with it through the Tribot client. Otherwise you can get several issues and there can also be a lot of lag/stuttering.

Thanks for your input. As you mentioned, the error is specific to Looking Glass. I tried it with the regular client and did not experience the Login Bot bugs. 

1 hour ago, Dukat said:

I got two 99's with this, you're correct.

Where were you mining? I haven't had any issues at MLM, what about yourself?

Share this post


Link to post
Share on other sites
19 minutes ago, polak4_lyfe said:

Ive made it past 1 day with one of my bots Im excited to see how far I can go :D

 

Hey can you give me a guide from your experiences on where and how to get to 99 mining w/ decent profits?

Tip one, dont bot 16 hours a day.
dont bot 10 hours a day.
Nobody in the world mines for 10 hours a day.


 

Share this post


Link to post
Share on other sites
Just now, polak4_lyfe said:

How many hours a day you recommend I bot, and is regular game play limited too to prevent red flags?

Playing normally will help make it so not all the clicks are the same.
Tribots and scripts have antiban but human clicks also help throw off red flags.

I bot a max of 3 hours a day mining
and that includes time switching works, taking breaks, and afking.
If you want the accounts to last, you make your bot human.
you do human things, you take human breaks.
time yourself playing runescape for two hours.
see how many times u get up to do something or how often youll randomly log out from AFKING

Share this post


Link to post
Share on other sites
1 hour ago, polak4_lyfe said:

How many hours a day you recommend I bot, and is regular game play limited too to prevent red flags?

On a normal day ill bot one skill, go play minigames legit for 20-45 minutes, go back to botting another skill for under an hour, go pking, go back to original skill for a while.

This is me playing on an account I dont use to gold farm.
Just my noob with multiple 90+ skills.

Share this post


Link to post
Share on other sites
14 hours ago, FadeRS said:

Where were you mining? I haven't had any issues at MLM, what about yourself?

 

6 hours ago, polak4_lyfe said:

Hey can you give me a guide from your experiences on where and how to get to 99 mining w/ decent profits?

1-75 powermining iron in unpopulated locations, then MLM to 99 for 6-8 hours a day breaking randomly for short periods of 5-30 minutes with at least 8-10 hours for sleep.

Share this post


Link to post
Share on other sites
On 6/7/2013 at 4:55 AM, Aropupu said:

Free trial for the script is available in the repository. Please try the script first before buying!

Make sure ROOFS ARE TOGGLED OFF in Runescape's settings.
Make sure you are in FIXED MODE in runescape settings. Tribot doesn't support resizable mode.

If you are worldhopping and not using in-game switcher, please make sure the worlds in the world selection screen are in the default order (worlds 301 and 302 are in the top left of the screen). This will make sure that it won't worldhop to unwanted worlds. (doesn't matter for in-game worldhopping)

There are other payment options too. Monthly, unlimited etc. Check them out in the repository.

MWcmnlH.png

Number of instances = On how many accounts you can use the script at the same time.

Looking for the free version of aMiner? Click this link:
https://tribot.org/forums/index.php?/topic/8598-aminer-aio-13-locations-bankingm1d1/

The premium version can be found from the repository:
Normal: https://tribot.org/repository/index.php?id=142
Runite: https://tribot.org/repository/index.php/script/id/582

Features and location list:

  Hide contents

- Supports all pickaxes
- You can choose to bank or powermine your ore
- Also has the options to use worldhopping
- Prioritizes ores to mine based on spawn time.
- Pickaxe upgrading (needs to be enabled)
- Motherlode mining
- Custom settings: you can choose custom rocks, custom destinations for bank and mine and custom paths.
- Setting profile saving/loading
- Goal bag and gem bag support
- Settings for copper and tin mining
- the ability to start the script without a GUI (using "last" argument)
 > You can also write your setting profile name in the script arguments to start it without a GUI and with that profile.
- You can disable the paint or choose another.

AVAILABLE LOCATIONS:

HEROES' GUILD AND NEITIZNOT ARE ONLY INCLUDED IN THE RUNITE VERSION!

CUSTOM LOCATIONS WILL SUPPORT ALL LOCATIONS WHICH SUPPORT WEBWALKING OR WHERE THERE ARE NO OBSTACLES IN BETWEEN THE MINE AND THE BANK. SOME CUSTOM LOCATIONS MIGHT REQUIRE YOU TO MAKE CUSTOM PATHS OR CHANGE THE DEFAULT WALKING METHOD.

If the location has aggressive NPCs, it's safe to assume that you will need to raise your combat level so they are no longer aggressive.

  • Al Kharid
  • Ardougne East
  • Coal Trucks
  • Crafting Guild (option to use f2p route and the bank chest inside the guild)
  • Dwarven Mines
  • Falador West
  • Grand Tree
  • Jatizso
  • Lumbridge East
  • Lumbridge West
  • Mining Guild
  • Motherlode
  • Piscatoris
  • Rimmington (will use deposit box)
  • Shilo Village (with gem cutting and dropping options)
  • Shilo Underground
  • Tzhaar
  • Varrock East
  • Varrock Essence
  • Varrock West
  • Yanille (with the option of banking at the deposit box/chest)
  • Yanille Essence
  • Quarry Granite

Motherlode mine

  Reveal hidden contents


- Option to use upper level.
  > Includes settings that will only go to areas in the upper level that don't have players in them.

- Option to use agility shortcut
  > It should calculate if it's faster to go through the agility shortcut or via normal route when going back to bank.

- You can now choose how the script handles the hammer:
  > Drop hammer: will get a hammer from a crate and drop it when done fixing (DEFAULT)
  > Keep hammer: Will keep hammer in your inventory once it's looted from a crate

- Will avoid players mining ore veins as long as you don't disable it.

- Settings to make the script deposit 1-6 deposits before banking. Also option for 4 deposits without sack upgrade and 7 deposits with sack upgrade (these require using placeholder items in your inventory).

- You can completely customize where the script goes in the motherlode mine. Just select the correct destination (upper level, northwest etc.) and then go to Custom settings and set your custom destinations. You can input as many custom destinations as you like. You can also choose if you want to let ABC2 select the destination (will select the first few you select most of the time) or if you want it to be completely random.

AFK mode instruction:

  Reveal hidden contents

 

You can find this feature in the antiban options. THIS FEATURE WORKS IN SECONDS.

You can choose how many seconds the script will AFK From A to B. By default it's from 0 to 300.

Common: The most common value. It will randomize the AFK time around this number. By default it's 30 seconds. 
This value needs to be between the min and max value, otherwise the script might crash.

Variation: How much the common value will vary. By default it's 15 so with the default settings it will vary between 15-45 seconds. This doesn't mean it will always be between 15-45, it just means that it will most of the time be between those values. 
THIS NEEDS TO BE IN BETWEEN THE MIN MAN MAX VALUES. THE ENTIRE VARIATION 15-45.

Timeout: How long will the script wait minimum before AFKing again. This time will be randomized with the randomly generated seed from your account's name.

Mouse movement: You can choose if you want the script to move its mouse off-screen sometimes/always/never when being AFK.

Even if you have the exact same AFK settings with two different accounts, they will be randomized differently so it will not be exactly the same. The script generates a seed from you account name and will use that to determine the randomization.

The script will disable the login bot until the AFK sleep time ends. This means it will not attempt to login while it's being AFK.

 

Worldhopping (antiban) mode instruction:

  Reveal hidden contents


You can find this feature in the antiban options. THIS FEATURE WORKS IN MINUTES.

You can choose how often the script will worldhop to another world based on a timer in minutes. This is especially useful in motherlode for example if you want the script to worldhop at random times but don't want to use the player detector for that. Works in the same way as the AFK mode.

From A to B: The script will randomize the value between these numbers so if you want the script to wait at least for an hour until worldhopping, you'll just add 30 - 90, which means from 30 to 90 minutes.

Common: The most common value. It will randomize the worldhop time around this number. By default it's 50 minutes.
This value needs to be between the min and max value, otherwise the script might freeze.

Variation: How much the common value will vary. By default it's 20 so with the default settings it will vary between 30-70 minutes. This doesn't mean it will always be between 30-70, it just means that it will most of the time be between those values.
This value needs to be between the min and max value, otherwise the script might freeze.

Even if you have the exact same worldhopping settings with two different accounts, they will be randomized differently so it will not be exactly the same. The script generates a seed from you account name and will use that to determine the randomization.

 

Progressive Mode [BETA]:

  Reveal hidden contents

 

Are you having problems with the script?

  Reveal hidden contents

You should try the following:
- Make sure your roofs are toggled off in Runescape settings.
- Make sure you are not in RESIZABLE MODE in Runescape settings. Tribot doesn't support resizable mode currently.
- Simply restarting your Tribot client can sometimes help too. Close all windows of Tribot and then restart it. It's recommended to restart a few times to make sure all hooks get updated, especially after Runescape has updated. Let Runescape load after each restart.
- If you are using Looking Glass with the official oldschool runescape client, try it with a normal browser or OSBuddy instead. Official oldschool Runescape client doesn't work well with LG.
- If you are using OSBuddy, try disabling OSBuddy plugins and other extra features. Some of those features can interfere with Tribot's functionality.
- Make sure you have "Restart client on update" DISABLED in Tribot's settings. If it's enabled, it will cause problems after Runescape updates.
 
You can do the following all in one before restarting your client:
- Try clicking on File ---> Delete Cached Clients and restart your Tribot client.
- Try going to litemode in Tribot's settings and restart your Tribot client.
- (You can skip this step if you decide to do the next one) Please try deleting hooks.dat and/or general.ini files from your .tribot folder. After this restart your Tribot. (close all windows)
- If removing hooks.dat/general.ini didn't work. Try reinstalling Tribot by deleting your .tribot folder and then restarting Tribot. Will reset your Tribot settings, consider doing a backup.

if all else fails, please post a proper bug report:

Custom settings instructions:

  Reveal hidden contents

Custom settings are settings that you can use to affect what rocks the script mines, where it walks exactly in the mine or bank and you can even create custom paths if you know how to. You can use custom settings for preset locations too, they are not only for the Custom location. If a location doesn't support some of the custom settings, you will not be able to set the custom settings.

All custom settings will be saved for every location as long as you have started the script at least once with those settings. When you set tiles for the settings, you will see the tiles being added in the GUI. If this shows 0, 0, 0 or -1, -1, 0 or something like that, it means your Tribot client is not working correctly (not getting correct position information). Usually restarting the client fixes it.

Add tile = adds a tile
Undo = removes the last tile you set (unless the settings were loaded from your saved settings)

To reset all tiles simply click undo until they are gone. If the tiles were loaded from saved settings, you can simply add a new tile and the old tiles will be removed.

Custom rock selection:

Enable custom rocks by ticking the box next to it. Click on start selecting rocks. Afterwards you can just click on the rocks to select them. Optionally you can also use CTRL to select the rocks if you hover your mouse over them, just make sure Runescape is active by clicking on your inventory or something else.

You can also deselect rocks by clicking on them again or using CTRL again.

Custom mine and bank destinations:

Custom mine and bank destinations will determine where the script walks. Preset locations have predetermined positions that randomize, but you can set custom destinations for them too if you want the script to walk differently than for other users.

By clicking on Add tile button, you will set the destination as the tile where your character is currently standing. Undo button will undo the last tile you set.

You can set as many destinations as you like. These will be randomized every time the script walks.

Custom destinations don't need to be added for custom location if you start the script near the rocks and use webwalking to bank. Custom location should use webwalking by default.

ADVANCED:

Custom paths:

You can make custom paths that the script will use to travel to the bank and mine. You can choose to make a custom path from bank to mine and mine to bank or you can just reverse the path from mine to bank so that you don't have to make two different paths. It's possible that it's better for antiban purposes to make two slightly different paths. All paths will be randomized for every walk anyway.

To make a path to mine, you should start by adding a tile that is inside the bank near the bank booths. After this you should add tiles that are 3-5 tiles away from each other all the way to the mine. All tiles will be randomized by 0-2 tiles to every direction so keep that in mind when making a path. The last tile should be near the rocks you want to mine.

To make a path to bank, you can either reverse the path to mine or make a custom path. First tile near the rocks, next tiles 3-5 tiles away and the last tile will be inside the bank, near the bank booths.

Walking method override:

You can use this settings to override the walking method of the preset location. Custom location uses webwalking by default so you can choose to use another walking method if webwalking doesn't work well in your location. Preset locations all use different walking method depending on what works best. You can also change their walking methods as long as the walking method you choose is supported by the location.

WebWalking will use predetermined nodes in the world map that it will follow. It sometimes can have weird behavior but usually works very well.

BlindWalk will create a straight randomized path between your mining location and the banking location. The path is randomized for every walk. (needs custom destinations to be added)

aStarWalk will find a path if a straight path doesn't work. Doesn't support obstacles. Only works in locations where the bank is in the same loading area as the mine. (needs custom destinations to be added)

Runite mining: [$12 - ONLY IN THE RUNITE VERSION]

  Reveal hidden contents


Keep in mind that Jagex has implemented a login cap. You can only login a certain amount of times in a minute. This is DDOS protection and it affects runite/hr amounts. Tribot has a failsafe for this and will login as soon as Jagex's servers allow it. There's nothing else I can do about this issue so keep that in mind when you purchase the script. 

Locations:
- Heroes' Guild
- Netiznot

Features:
- Remembers the worlds you have visited and found runite in. Will go back to those worlds when runite should be respawned.
- You can set a world timeout during which the script will not go back to a world it didn't find runite in.
- Drops almost all unnecessary items and gems. (notify me if something isn't being dropped with the ID of the item)
- Has all the features that aMiner (normal version) has.

Netiznot:
- You have to go and check aMiner options before you start it up. You have to input a food ID etc.
- Optional prayer support. You have to choose Protect from Melee or Protect from Missiles. I'd recommend melee, because melee hits for more damage.
  > Uses prayer potions from your bank to recharge prayer.
- You can also choose how much food the script takes with it.

 

How do i setup the settings for motherlode mine?? It doesn't even start the script for me?

Share this post


Link to post
Share on other sites
17 hours ago, Focusedi said:

How do i setup the settings for motherlode mine?? It doesn't even start the script for me?

If the script doesn't start, there's usually something wrong on your end. Please be more specific about what happens. Are you unable to press the start button or the button doesn't do anything? Do you press the start button but the script doesn't do anything afterwards? Please check your client debug and bot debug for any errors.

Also, please check the "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

Edited by Aropupu

Share this post


Link to post
Share on other sites
On 8/20/2017 at 4:42 AM, Dukat said:

 

1-75 powermining iron in unpopulated locations, then MLM to 99 for 6-8 hours a day breaking randomly for short periods of 5-30 minutes with at least 8-10 hours for sleep.

Thanks man! Can your recommend some unpopulated areas to mine iron?
p.s. do you bank the iron? and how much you make yourself a day @ mlm?
Thanks in advance.

Share this post


Link to post
Share on other sites
On 8/22/2017 at 6:38 AM, polak4_lyfe said:

Thanks man! Can your recommend some unpopulated areas to mine iron?
p.s. do you bank the iron? and how much you make yourself a day @ mlm?
Thanks in advance.

no breaks with 85 mining in MLM you can get like..250k/h tops. Idk why yo even ask about iron..google iron rock, check out spots, think with head a bit and bam, you will have your self 75 mining.

Tbh i don't even understand why would @dukat feed ppl with this information...you just dig hole for your self and your "99's mining accounts that get to that level in MLM" lol

Share this post


Link to post
Share on other sites
18 minutes ago, polak4_lyfe said:

This script no longer works after the login screen update :s

Please ensure you've restarted TRiBot twice, allowing it to load to the login screen both times. I am unable to confirm it's broken at the moment but if more people find the same after following these steps @Aropupu will fix it as soon as he is able to if TRiBot doesn't need an update.

Confirmed: 


Please wait for an update.

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Dukat said:

Please ensure you've restarted TRiBot twice, allowing it to load to the login screen both times. I am unable to confirm it's broken at the moment but if more people find the same after following these steps @Aropupu will fix it as soon as he is able to if TRiBot doesn't need an update.

You were right just needed to restart Tribot twice and load the login screen twice.
Thanks Bruv!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...