Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

Guest

Bought script & not happy.

 

  1. Attempted to powermine iron @ fally west - bot broke pickaxe, wasn't intelligent enough to grab another from bank
  2. Attempted to bank iron ore @ fally west - bot got stuck on wall, was trying to run to bank without using the 'low wall' climb. (Makes you look like an obvious bot  when your bot is running up and down a fucking wall.)

Fally west needs work.

Share this post


Link to post
Share on other sites

Bought script & not happy.

 

  1. Attempted to powermine iron @ fally west - bot broke pickaxe, wasn't intelligent enough to grab another from bank
  2. Attempted to bank iron ore @ fally west - bot got stuck on wall, was trying to run to bank without using the 'low wall' climb. (Makes you look like an obvious bot  when your bot is running up and down a fucking wall.)

Fally west needs work.

 

@Simplex

I cannot test each and every location after every update. Especially free locations like Falador West, which unfortunately are of low priority. I have limited time to use. We were forced to implement the client's banking method to each and every premium script and it's not perfect. I can add a failsafe for it. 

 

1. Should be an easy fix. However, I wouldn't recommend using the custom powermining method in Falador West because it uses webwalking and webwalker doesn't walk through the wall. That's the client's fault.

2. Entirely caused by client's method to bank. It takes over and doesn't let the script do its job. I will add a failsafe to fix this.

 

EDIT: Both issues should be fixed now. Just restart the script without using the rerun option. 

Edited by Aropupu

Share this post


Link to post
Share on other sites

Trying to bank iron in East varrock and Ardy. Bot runs to both banks. Sits in the bank and does nothing. Got me to 15 mining  on tin and copper, I guess that counts for something. 

 

@sombra ninja

 

Works just fine in both locations. Since you didn't provide any more information (debug or picture), I cannot know what's causing it. Try restarting/reinstalling tribot and see if that helps.

Edited by Aropupu

Share this post


Link to post
Share on other sites

 Am I suppose to screenshot my character standing in the bank with the bank screen open? I don't see how that is beneficial. But as far as the debug does it says nothing. It is simple "started aminer" . I restarted the bot 3 times and it still continues to do the same thing. Runs from the mine to the bank. and sits doing nothing

 

@sombra ninja

You could have at least told me that it gets stuck in the banking screen instead of inside the bank. That is why a picture tells more than words that can be interpreted differently.

 

You should do a script stack trace when it's stuck in the bank screen. Go to Script --> Print Script Stack Trace and copypaste here what it prints out in the debug. Do this when it's stuck.

Edited by Aropupu

Share this post


Link to post
Share on other sites

ABCL doesn't work for me I guess 

 

@Pepsi69

ABCL is different for each account you are botting with. I unfortunately can't affect how it works. Make sure to add your account information to the account manager and also select the account before starting the script. Last time I tested the ABCL features, I noticed that they don't work if you don't have your account selected before you start the script.

 

@Aropupu would it be possible to add a Stop after so many hours option or a take breaks option onto this script. Other than that it works great. 

 

@sombra ninja

I think you can do that with the break handler in Tribot (at least someone said so some time ago). Check out a guide on how to use the break handler and just set the break so that it breaks forever when you want it to stop mining. 

 

https://tribot.org/forums/topic/37533-breaks/

 

That guide explains how to use the break handler. It should work if you put the duration of the break as some ridiculous number like 999999 hours.

Edited by Aropupu

Share this post


Link to post
Share on other sites

@Bot2stake

Prayer potions

Ok thanks, just wondering...

 

-If it runs out of ppots will it shut off or continue with food only?

-Will it drink any dose?

-Does it support d pick spec?

 

Also how does it handle the golem being as its a small island? Does it bank when a golem appears or just run around on the island until dead?

 

Thanks!!! (working flawless so far)

Edited by Bot2stake

Share this post


Link to post
Share on other sites

Ok thanks, just wondering...

 

-If it runs out of ppots will it shut off or continue with food only?

-Will it drink any dose?

-Does it support d pick spec?

 

Also how does it handle the golem being as its a small island? Does it bank when a golem appears or just run around on the island until dead?

 

Thanks!!! (working flawless so far)

 

@Bot2stake

1. It should stop mining and log out.

2. It should drink any dose.

3. Doesn't support d pick spec. I would need an account which is able to wield a dragon pickaxe to be able to add this function.

4. It will escape through the bridge and once the golem is gone, it will go back to mining.

 

Is this bot able to refill waterskins at Desert Quarry?

 

@Cosimo

Yes, it will refill the waterskins in Pollniveach.

Edited by Aropupu

Share this post


Link to post
Share on other sites

@Bot2stake

1. It should stop mining and log out.

2. It should drink any dose.

3. Doesn't support d pick spec. I would need an account which is able to wield a dragon pickaxe to be able to add this function.

4. It will escape through the bridge and once the golem is gone, it will go back to mining.

 

 

@Cosimo

Yes, it will refill the waterskins in Pollniveach.

THAT IS SO SEXY, I ALREADY BOUGHT IT AND IT'S SEXY AF :D :D :D

Share this post


Link to post
Share on other sites

I'm going to be releasing a BETA version of my motherlode miner as a new location of aMiner Premium and Runite. It's finished. I'm just testing it before releasing it.

 

I will need YOUR help to test it and find out any bugs that might still be there. I will edit this post once it's updated to the script. You will also notice it in the update notes when you start aMiner and in the location list once the script is updated.

 

EDIT: Motherlode Mine is now available as a location in aMiner Premium and Runite. Please understand that it's in BETA and can have more bugs than normal.

 

While I have been using it, I haven't encountered any frequent bugs for a while though.

Edited by Aropupu

Share this post


Link to post
Share on other sites

I'm going to be releasing a BETA version of my motherlode miner as a new location of aMiner Premium and Runite. It's finished. I'm just testing it before releasing it.

 

I will need YOUR help to test it and find out any bugs that might still be there. I will edit this post once it's updated to the script. You will also notice it in the update notes when you start aMiner and in the location list once the script is updated.

 

EDIT: Motherlode Mine is now available as a location in aMiner Premium and Runite. Please understand that it's in BETA and can have more bugs that normal.

 

While I have been using it, I haven't encountered any frequent bugs for a while though.

How much GP/hour is it there? I have 85 mingin

Share this post


Link to post
Share on other sites
Guest

I'm going to be releasing a BETA version of my motherlode miner as a new location of aMiner Premium and Runite. It's finished. I'm just testing it before releasing it.

 

I will need YOUR help to test it and find out any bugs that might still be there. I will edit this post once it's updated to the script. You will also notice it in the update notes when you start aMiner and in the location list once the script is updated.

 

EDIT: Motherlode Mine is now available as a location in aMiner Premium and Runite. Please understand that it's in BETA and can have more bugs than normal.

 

While I have been using it, I haven't encountered any frequent bugs for a while though.

Working flawlessly so far, awesome job. Averaging 22-25k an hour at 84 mining

Edited by jwilliams2
  • Like 1

Share this post


Link to post
Share on other sites

Botted for a good 9 hours at motherlorde~. But ended up in lumbridge dead. I averaged about 23k exp per hour at 72 mining.

 

@lordvblast

Do you have any idea what caused it to end up in Lumbridge? Did you fail a random event? Check your random event videos in your Tribot folder if you have random event recording enabled. You should also check your debug log to see if there are any messages about random events.

 

Also, if you have very low HP and the script happens to be slow during a combat random or your client lags, it could cause you to die too.

Share this post


Link to post
Share on other sites
Guest Infinity

Trying to m1d1 at Varrock East Tin but the bot just stands there.

Share this post


Link to post
Share on other sites
Guest Infinity

Varrock East Iron and Varrock East Tin are both working just fine. Something is wrong on your end. Please answer my PM.

I got it working.

Share this post


Link to post
Share on other sites

@lordvblast

Do you have any idea what caused it to end up in Lumbridge? Did you fail a random event? Check your random event videos in your Tribot folder if you have random event recording enabled. You should also check your debug log to see if there are any messages about random events.

 

Also, if you have very low HP and the script happens to be slow during a combat random or your client lags, it could cause you to die too.

Did another 6 hour proggy at Motherlorde. Just now, I looked at the bot and think I know how it died. A rock golem random appeared and started to attack me. However the bot wasn't running away to safety. Instead it kept spamming right click on the depleted vein. So the rock golem kept on spamming the range attack on me and the bot just kept on spamming right click on the depleted vein. I don't know how to show the logs, but I hope you can visualize what I'm trying to say.

Edited by lordvblast

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...