Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

cbtexan04

[Free][Combat]Texan's Monk Massacre

Recommended Posts

Script is pretty good in that it does work, but it does some very weird, very bot like things.

 

One, it keeps clicking into the moutains, or just generally way the hell out of the monastary, and then clicks back into the area after I'm mostly out. This is odd but isn't too much of a danger, just loss to exp per hour.

 

Whats extremely concerning is it keeps being "stuck" where it is in the middle, and it kills the two middles monks, then it tries to right click the months in the buildings. and it will just keep right clicking in the same spot (I can't see the monk it's trying to click since the roof is on, I can just tell by the mini map it is clicking relatively close to where the monk would be). It does that, right clicking the in the same spot over and over again until another middle monk spawns and it kills that one, and ends up getting out of the stuck spot, eventually moving to the monks inside the long building. It's very very bot like from a player perspective, as you just stand there forever when there are available monks, and even more bot like to jagex, repeatedly mis clicking.

 

Can't complain, as the bot eventually does the job, and it's a free script :D, but if it was a quick fix, could you please tweak it ^.^? Thanks texan, fantastic script!!

Share this post


Link to post
Share on other sites

edit: Script is un usable now :(. It keeps getting stuck permanently, right clicking for the monk next to it inside, but misses over and over. Watched it for 2 minutes each time, and even after the middle monks spawned it wasn't able to move. Easy fix would be, after 5 right click misses, a relocating click (randomized) to roughly the middle of the monk area, and then resume business as usual. that is a pretty simple failsafe logic, and hopefully the code isn't too bad. Please and thank you sir :))) <3

 

here are the pictures, you can see on the mini map i'm in a different position along the wall

16knwhj.png

313lu0z.png

Share this post


Link to post
Share on other sites

@Luke-- disable your roofs, that will fix 90% of your problems.

 

I've updated the code to a newer attack method. Users should notice MUCH better clicking. Let me know how it fairs.

 

I Thought there was a way to do that!! I feel so dumb but, how? I've looked all over and I can't find the option. I thought maybe this was like an older version of rs that didn't allow you to disable them. And sweet about the clicking!

 

edit: I googled it. wow how weird that you have to type something for it!

Edited by Luke L

Share this post


Link to post
Share on other sites

I Thought there was a way to do that!! I feel so dumb but, how? I've looked all over and I can't find the option. I thought maybe this was like an older version of rs that didn't allow you to disable them. And sweet about the clicking!

 

Haha no worries. Just be sure to let me know it's in working order :)

 

::toggleroof

 

http://2007.runescape.wikia.com/wiki/Toggleroof

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...