Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Bradsta

[ABCL 10][Thieving][92 Hour Proggy]BrMasterThieverPro v4.00 [12 Different Options] [Stall Support]

Recommended Posts

@ Gloves of Silence - It should take 3 pairs on a trip with you if you choose that option I believe, I can't exactly use them myself so I haven't ever tested them specifically.

 

@ Food - Yes I'll add that back in, I think the banking issues we were having previously have been resolved, I'll test though to make sure.

 

Glad you're enjoying the script!

Share this post


Link to post
Share on other sites

This script has been running amazing the past couple of days, the only thing i would ask for as an anti-ban would be a fluctuation in the hp that the script eats at, only a fluctuation of around 4-5 hp, just something minor.

I'll do that later today for you guys.

 

@Looks good Luis!  Sorry to hear the bans are heavy :/.  I'm going to add in threaded camera rotation & angle changes possibly also with the next update.

  • Like 1

Share this post


Link to post
Share on other sites

Fantastic script... Really is a shame I'm going to have to stop using it and switch to one on OSB because of a combination of Tribots terrible random solver, but mostly the fact that every time I run it before it even runs for an hour I get the "You are running too many instances of this script, script stoped" bullshit.

Share this post


Link to post
Share on other sites

@Immortal sorry to here those issues.  Are you running on a proxy, or do you have a bad internet connection that might be dropping?  As far as the random solvers they all appear to be working well for me.  Try deleting your dependencies folder in .tribot and make sure you didn't get a corrupt download in one the files during a client update.  Appreciate the nice comment though :)

 

@amduc Thanks for posting the progress report!  Appreciate your feedback!  Looks like you'll get 99 pretty soon if they don't catch up to you.  Those 24/7 proggies are risky :D

Share this post


Link to post
Share on other sites

@Immortal sorry to here those issues.  Are you running on a proxy, or do you have a bad internet connection that might be dropping?  As far as the random solvers they all appear to be working well for me.  Try deleting your dependencies folder in .tribot and make sure you didn't get a corrupt download in one the files during a client update.  Appreciate the nice comment though :)

 

@amduc Thanks for posting the progress report!  Appreciate your feedback!  Looks like you'll get 99 pretty soon if they don't catch up to you.  Those 24/7 proggies are risky :D

Yeah, I think it's my connection... Hopefully when I switch to a VPS soon most of the instance-related issues will dissapear... 

Share this post


Link to post
Share on other sites

@Immortal sorry to here those issues.  Are you running on a proxy, or do you have a bad internet connection that might be dropping?  As far as the random solvers they all appear to be working well for me.  Try deleting your dependencies folder in .tribot and make sure you didn't get a corrupt download in one the files during a client update.  Appreciate the nice comment though :)

 

@amduc Thanks for posting the progress report!  Appreciate your feedback!  Looks like you'll get 99 pretty soon if they don't catch up to you.  Those 24/7 proggies are risky :D

I don't usually 24/7 and I always quest/switch up skills so I should be good ^.^ I'll try to go for a longer proggy over the next couple of days.

  • Like 1

Share this post


Link to post
Share on other sites

Brad, There's a bug I've been getting quite frequently at Draynor MF. When I end up at the tiles (3083,3255) - (3086,3255) and the camera happens to be tilted so that south is the highest point on the compass, and the camera is tilted as close to the ground as possible, it will keep trying to click the MF through the wall of the house where there is a wardrobe on. It isn't able to, so it just sits there trying, and trying, until the MF finally moves elsewhere. It's been there for atleast 10+ minutes so far.

Edited by ImmortalArmyOfOne

Share this post


Link to post
Share on other sites

I'll take care of that.  Will post an update in a few.

 

Update v3.056

  • (-) Fixed getting stuck with wardrobe issue in Draynor. If we are in the small area of that corner it will check your camera settings and adjust them accordingly on a randomized basis.
  • (-) HP to eat at slightly updated. If your hitpoints level is greater than 20 and your hp to eat below is set to 8 or above. It will randomize the hp to eat at +- 2. I plan on doing more with this when GUI is re-done in the foreseeable future.
Edited by Bradsta

Share this post


Link to post
Share on other sites

 

I'll take care of that.  Will post an update in a few.

 

Update v3.056

  • (-) Fixed getting stuck with wardrobe issue in Draynor. If we are in the small area of that corner it will check your camera settings and adjust them accordingly on a randomized basis.
  • (-) HP to eat at slightly updated. If your hitpoints level is greater than 20 and your hp to eat below is set to 8 or above. It will randomize the hp to eat at +- 2. I plan on doing more with this when GUI is re-done in the foreseeable future.

 

Hey, thanks Brad!

Share this post


Link to post
Share on other sites

No problem!  Thanks for making me aware, and providing detailed information.  That helps so much :D.

 

Also forgot to include mouse speed changes for randomization in the update log.

 

I've declared a new variable userSpeed which is double randomized set upon startup.  So speed = General.random(General.random(#,#), General.random(#,#));

 

Then your speed is changed every loop by a randomized number.

Share this post


Link to post
Share on other sites

three instances per purchase right dude? Every time I try to start the third script it tells me maximum amount of instances have been surpassed..

 

EDIT: Closed out of all three clients, reopened them, now after starting one instance, I can run no more without getting the "maximum instance surpassed" error. This is fucking ridiculous.

Edited by ImmortalArmyOfOne

Share this post


Link to post
Share on other sites

three instances per purchase right dude? Every time I try to start the third script it tells me maximum amount of instances have been surpassed..

 

EDIT: Closed out of all three clients, reopened them, now after starting one instance, I can run no more without getting the "maximum instance surpassed" error. This is fucking ridiculous.

I was only running one and this also came up, script didn't stop or anything, just saw it in debug...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
      • 17 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 10 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...