Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Mute

[$9.99][DISCONTINUED][ABCv2 Level 10] ◄Mute's AIO Slayer► [ALL MASTERS]

Recommended Posts

Script has had issues with combat (will be in combat and will click away/try to attack other monsters). This happens at all locations/monsters. Sent 2 gifs, one on August 10th and one this morning. Mute is very busy with coursework atm but he says he's working on a fix. 

 

@benlis 

 

I second this! In one hour I recorded 320 "You are already under attack!" messages

  • Like 1

Share this post


Link to post
Share on other sites
Guest

Yeah I'm aware, as I've stated twice. It's a TRiBot issue, and I cannot fix it manually.

So sad..... wish it was fixed lol

Share this post


Link to post
Share on other sites

So after the trail I deiced to get this. 

 

So while watching attacking black demons, it likes to afk before attacking the next, if it does attack it picks a far one instead of a close one, sometimes it tries and attacks a few. 

 

Walking seems repetitive like it does one giant loop, sometime it will start to walk to a bank then halfway decides it want to double back and take a different path that's faster. 

 

Why when setting up task it teleports to a bank get items etc sometimes banks items, then teleports to a different bank to redo the same thing before heading to the task when it can just teleport to the bank once and just do everything there one time.

 

Overall everything works just these little things I notice.  

Share this post


Link to post
Share on other sites

This is a common issue for pretty much every task where the monsters are aggressive, can you maybe fix it?

 

https://gyazo.com/20e0a4da6fdcb7609d7848ef6a42b2fc

 

(Happens when i attack a monster, and another attacks me, the bot will keep trying to attack the one who already have lowered HP)

Edited by jens4626

Share this post


Link to post
Share on other sites

This is a common issue for pretty much every task where the monsters are aggressive, can you maybe fix it?

 

https://gyazo.com/20e0a4da6fdcb7609d7848ef6a42b2fc

 

(Happens when i attack a monster, and another attacks me, the bot will keep trying to attack the one who already have lowered HP)

has trouble on greater demons, the area is seperated by a step over root which it doesnt recognise constantky trying to click past it

 

Should be fixed.

  • Like 1

Share this post


Link to post
Share on other sites

NPC is working yay!.  :D

 

Issue with attacking is still there when the monster is aggressive / using magic etc still runs back in forth on aggressive monster when already attacking one, it did it today on infernal mages. I'll will get video as soon as I can when it pops up again.

 

Things to look at:

 

Banking method still can be better. Why must it teleport to multiple banks before setting up for a task? Still should just only do it once, then tele out to task etc.

 

Starting the bot next to a bank, it still teleports to a bank when it doesn't need to. Better detection if player already close to bank then don't tele. 

 

Using fast point mode and getting a simple task like wolves there a problem based on locations when low monster count.

EXAMPLE: In the stronghold of security the problem is the there is only 4 wolves and since that is the case the bot restart the thread since we haven't moved in 5 minutes. This cause the both to tele out, head to bank, then head back only to repeat the process, so in the long run tele tabs are wasted and we a get only 4 kills and a very long killing process that's un-human like. A fail safe for a locations that only have small amounts of monster the bot needs to wait it out till the npc respawn or find a better location.

 

Task tele out when I still have reasonable amount of health left and only 1 kill left. The bot should decided to stay and complete the task if the monster is easy then wasting a tele to bank when there is only 1 kill left or tad bit more.   

Edited by User_Error

Share this post


Link to post
Share on other sites

I have problems with setting up tasks, if it doesnt have the right teleport it just turns of? are you able to show what item it needs. 

eg atm trying to "Travel to pollnivnech" loops then closes.

 

It tells you the item you need in the logger or the client debug.

Share this post


Link to post
Share on other sites

What is your issue?: Will not get new task from Turael with npc contact
What happened exactly?: Goes through dialogue with Turael until you say "That's alright. I'll take a task from you", then it checks the slayer helm before Turael can actually give you a task. Is not an issue with Nieve.
What task were you on?: In between.
What was the status on the paint?: Getting a new task...
Who is your slayer master?: Nieve, but set to fast points, so going to Turael.
Bot debug?:
Client debug?:

 

Also, I've been having problems with the special attack. It will pull out the spec weapon, click special attack, and then immediately switch back to the original weapon, without attacking the creature. Then it will cycle back and forth, until a special attack finally occurs due to auto retaliation. This wastes a lot of time, not to mention looks extremely botlike.

 

Great script, though!

Share this post


Link to post
Share on other sites

What is your issue?: Won't get a new task from Chaelder
What happened exactly?: Just teles to lumbridge and stands there
What task were you on?: Happened after two tasks i had to go and get manually
What was the status on the paint?: Getting new task
Who is your slayer master?: Chaelder

Edited by Bulba

Share this post


Link to post
Share on other sites

What is your issue?: Won't get a new task from Chaelder

What happened exactly?: Just teles to lumbridge and stands there

What task were you on?: Happened after two tasks i had to go and get manually

What was the status on the paint?: Getting new task

Who is your slayer master?: Chaelder

 

Got Skype?

Share this post


Link to post
Share on other sites

I just added you, my skype is liam.magwood

 

NPC Contact is for lunar users, and will attempt to get a new task via lunar spells.

 

Q: What is the NPC Contact feature?

A: If you're a lunar user, this is for you. Allows you to get new tasks from slayer masters without having to go to them.

Share this post


Link to post
Share on other sites

NPC Contact is for lunar users, and will attempt to get a new task via lunar spells.

 

Q: What is the NPC Contact feature?

A: If you're a lunar user, this is for you. Allows you to get new tasks from slayer masters without having to go to them.

Thanks for the quick solve, sorry for wasting your time.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 9 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...