Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Aropupu

[ABCL 10] [ABC2] aAgility v2 [ALL ROOFTOPS]

Recommended Posts

Is there any reason why it just keeps right clicking over and over, then eventually clicks the next obstacle. I'm doing Falador Rooftop FYI

 

 

I sent Trilez a message about it and he confirmed that the client is what's causing the right-clicking. He promised to make some changes.

 

Share this post


Link to post
Share on other sites

I started an instance at ardougne rooftops earlier this morning, when I checked on it I found it stuck at the plank walk obstacle, right clicking non stop. Exp tracker was only at 108, so it was doing this for the whole time it was running. 

 

https://imgflip.com/gif/9hlzz

(tried making a gif from it, hope it works)

 

Its right clicking an area just below the plank.

 

I know the right clicking is already a known issue and awaiting a fix from Trilez, but the courses have still worked. In this case the course is unable to be completed.

Edited by danimal

Share this post


Link to post
Share on other sites

I started an instance at ardougne rooftops earlier this morning, when I checked on it I found it stuck at the plank walk obstacle, right clicking non stop. Exp tracker was only at 108, so it was doing this for the whole time it was running. 

 

https://imgflip.com/gif/9hlzz

(tried making a gif from it, hope it works)

 

Its right clicking an area just below the plank.

 

I know the right clicking is already a known issue and awaiting a fix from Trilez, but the courses have still worked. In this case the course is unable to be completed.

Having this right clicking problem too 

Same issue started up the damn thing on Al-kharid rooftop it's been stuck at one obstacle for 15 damn minutes lol :'(

 

Something happened in the newest update to Tribot. Hopefully Trilez will fix it soon.

 

There are several complaints all around Tribot about different objects (mostly stairs and banks) being missclicked / right-clicked.

Edited by Aropupu

Share this post


Link to post
Share on other sites
Guest

No it's not sorted, it still right clicks no where like 2-3 times a lap.

Share this post


Link to post
Share on other sites

No it's not sorted, it still right clicks no where like 2-3 times a lap.

works fine for me :)

Will do it on occasions but it is much better now

 

It's still the client's fault and there's not much I can do about it. Some could think that it's a antiban thing when the player sometimes right-clicks or something but I don't think it really makes a difference if it does it or not.

 

Anyway, it right-clicks very rarely for me so I don't see it as a problem.

 

Some news:

- I'm currently working on optimizing every course a bit more.

- At the same time I'm also implementing the rest of the ABCL-methods and soon the script should be ABCL 10. I have to implement unique things for each course so it's gonna take some time to test and implement everything.

Edited by Aropupu

Share this post


Link to post
Share on other sites

does Drynor and Al kharid rooft tops work atm? as i remember, month ago or less, non of those low lvl rooftops was working

 

I would be surprised if they are broken because of the script. If you tried them when there were any problems with the Tribot client, they probably didn't work because of that. I'll be checking them thoroughly when I optimize them and implement ABCL methods.

Share this post


Link to post
Share on other sites

Id say one thing to add to the script would possibly be more camera movement but nothing to much just on obstacles you could see manually moving it for to see better. Other then that the script runs pretty dam great. Not sure all what can be added to a agility script to make it more human like other then camera angles and xp checks once in a while

Edited by Pocketsandd

Share this post


Link to post
Share on other sites
Guest

Seers/Camelot agility course runs pretty dang well compared to most of the other courses. Relleka is kinda disappointing and is obvious to catch if you were to run it for hours a day. It kind of sucks that I have to run the Camelot course at level 80

Share this post


Link to post
Share on other sites

Seers/Camelot agility course runs pretty dang well compared to most of the other courses. Relleka is kinda disappointing and is obvious to catch if you were to run it for hours a day. It kind of sucks that I have to run the Camelot course at level 80

 

You are not telling me what is wrong so I cannot fix it. I'm currently working on optimizing the courses and only Rellekka and Ardougne are left. Check it out when I have updated the script or tell me now so I can maybe take care of the issues you are having.

Share this post


Link to post
Share on other sites

I have released an update to the script today:

 

- A lot more ABCL implementation. The script is probably something like ABCL 9,9/10. I'm still implementing some stuff and testing. I will write some explanation about the ABCL feature when it's completely ready.

- Added some more antiban options. You can now disable hovering and object examining which are enabled by default and both use ABCL.

- Some courses work better now and might have faster xp rates.

- Also added a bug fix to falador.

- Made some changes to when the script clicks the minimap. It used to click the minimap even when it didn't need to.

 

If you find certain parts of courses that are still handled in a weird way, please tell me about it and I can hopefully do something about it. Right-clicking and missclicking issues are due to the client and I cannot do much about them.

Share this post


Link to post
Share on other sites

I had an issue today, No bug report info but it says it completed a Miles random as its last random and i found my character at white wolf mountain..Dunno how long it actually sat there the break handler had about 5 hours between each instance. Not sure if its the client but it fails Miles and Frogs every single time and i find myself with a noted inventory of stuff and god knows how long it was logged in or not

Share this post


Link to post
Share on other sites

I had an issue today, No bug report info but it says it completed a Miles random as its last random and i found my character at white wolf mountain..Dunno how long it actually sat there the break handler had about 5 hours between each instance. Not sure if its the client but it fails Miles and Frogs every single time and i find myself with a noted inventory of stuff and god knows how long it was logged in or not

 

If you have random event video recording enabled, you can find random event videos in your Tribot folder. If you send the videos in question to me, I can see if it's the client or my script that is causing problems. Without seeing what happens, I unfortunately can't do anything about it.

Share this post


Link to post
Share on other sites

If you have random event video recording enabled, you can find random event videos in your Tribot folder. If you send the videos in question to me, I can see if it's the client or my script that is causing problems. Without seeing what happens, I unfortunately can't do anything about it.

I looked at the video of todays issue with it, and it just shows him talking while i got ported to lumby. the other videos i watched the script just keeps running and doesn't acknowledge the random event. I had one video where it did solve it but i have 4 that got me ported away. It happens at the Pollivnieach course. Id share a video but the character name is in them. But contact me and maybe we can figure something out. 

 

But like i said client or script, it just ignores it and keeps running

 

Edit: just watched it ignore a genie aswell..I also own USA's bot and his seems to handle randoms fine, so not sure if its a bug or not but the bot just keeps trucking through Random or not and it will say in client debug it passsed it while the random is still there getting ready to port me away again

Edited by Pocketsandd

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 14 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...