Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Aropupu

[ABCL 10] [ABC2] aAgility v2 [ALL ROOFTOPS]

Recommended Posts

Is there a way to make the script a bit faster?

It does an obstacle, waits a bit then continues. Looks botlike and is slow.

 

The delays between obstacles are determined by Tribot's antiban (Antiban compliance). They are different for each account and I cannot control it in any way. I'm also not allowed to disable them.

 

It gets stuck at Rellekka course and thus cannot be used there, will post a screenshot later.

 

I need a screenshot of the exact position it gets stuck in, otherwise I cannot fix it. It seems to work fine whenever I'm testing it.

Share this post


Link to post
Share on other sites

can u please take a look at ape atoll. it's looks very glitchy/bot-like

 

@Cosimo

I can take a look at it after christmas is over. I won't be able to update any of my scripts until 26th or 27th.

 

Could you please tell me what problems you have detected with the Ape Atoll course? This will make it easier for me to check it out when I do so. If you can, please private message me to avoid cluttering the thread.

Share this post


Link to post
Share on other sites

agility1.png

 

Working pretty good for seers village.

 

I do have a couple recommendations though. It would be nice to support stamina potions, and an option to withdraw X number of potions.

 

EDIT: Also a Marks per hour and total feature would be cool.

Edited by RSMarine

Share this post


Link to post
Share on other sites

Script keeps getting stuck on the Canifis rooftop agility course

 

@anorexikchimp

Could you please send me a screenshot of exactly where it gets stuck? I'd appreciate it if you could private message me. Last time I checked Canifis, there were no problems so either the problem is rare, caused by an update to runescape or I was just lucky.

 

Also, is there anything in Client debug?

Edited by Aropupu

Share this post


Link to post
Share on other sites

a844e88f90313d0cc23655cc94d083b7.png

 

@lionsfan90

That seems to be an issue with walking method of Tribot. Could you get me a script stack trace when this happens? How often does it happen anyway? Please send me a private message to avoid cluttering the thread.

 

You can get a script stack trace by going to Script ---> Print Script Stack Trace and copypasting/screenshotting what it prints out in the client debug. You have to do this when it's stuck like that for it to be of any help.

 

Also, have you tried restarting tribot completely? That sometimes fixes some issues.

Edited by Aropupu

Share this post


Link to post
Share on other sites
Guest

i have been getting the same issue as the above poster with the seers course. I'll try to post a screenshot if youd like.

Share this post


Link to post
Share on other sites
Guest Kilahvi

Haha got banned too :D Started the script and after 30mins got banned. Course: pollnivneach

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...