Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Mute

[$1.99][ABCv2 Level 10]◄Mute's Crab Killer►[East & West Rellekka, East & West Sand Crabs, and Waterbirth]

Recommended Posts

Hello. I have been running the bot in waterbirth. It doesn't seem to hop when there is some one in my spot. Also it doesn't reset the crabs once I no longer generate their aggression. Also, whenever it teles it always uses 2 tabs not one.

Edited by Ryan17l

Share this post


Link to post
Share on other sites

Hello. I have been running the bot in waterbirth. It doesn't seem to hop when there is some one in my spot. Also it doesn't reset the crabs once I no longer generate their aggression. Also, whenever it teles it always uses 2 tabs not one.

 

Please use relleka for now, I will be rewriting waterbirth over springbreak.

Share this post


Link to post
Share on other sites
Guest

Lemme just tell you bro. I accidentally ran this script for 23 hours straight (no breaks), and didn't get banned hahah. It didnt run into a single problem. I was 100% expecting to be banned. I totally forgot it was on, came back and it got me from 70-77 strength in a day. Incredible script my friend 

  • Like 1

Share this post


Link to post
Share on other sites
Guest

One thing I would love is a Special attack function. I can see how this might be tricky to code though, just a suggestion! Love it either way

Share this post


Link to post
Share on other sites
Guest

wtf, the bot is logging in into pvp worlds, happened twice now and i shut down "teleportation for canon", srsly fix this problem. died twice cuz of this

Share this post


Link to post
Share on other sites
Guest

wtf, the bot is logging in into pvp worlds, happened twice now and i shut down "teleportation for canon", srsly fix this problem. died twice cuz of this

This actually just happened to me. I just lost 24,000 iron knives >...<  Only problem i've run into so far

Share this post


Link to post
Share on other sites

This script is working nicely after the update thanks! I have just have a couple of suggestions. 

 

If you could make it so the character only attacks crabs that are attacking him when the "attack all crabs" box is unchecked. It is kind of suspicious when theres only two people in a world and I'm on one side and then i run all the way over to their side just to attack the crab he isn't attacking. It also seems to attack other player's crabs constantly with the box unchecked, even if they are attacking them. If that affects exp/hr too much maybe a radius could be implemented. Where if there are loose crabs within a certain distance from the character they, will be attacked. Outside the radius they are ignored.

 

Also the method you are using for water birth, while currently functional, is suspicious. Everyone who does water birth legitimately stands in-between the 3 spawns for the north side and lets the crabs attack them. The way this script does it is by running to each different spawn and standing on it, which is a lot of unnecessary movement. 

 

A lesser issue would be how the script determines when the crabs aren't aggressive. I've seen it happen a lot of times where the bot would run to a crab at the same time as someone else did, it would start attacking the other person and the bot would run south thinking they were no longer aggressive. Maybe have it check twice each time before reseting the crabs.

Edited by danimal

Share this post


Link to post
Share on other sites

I've also noticed all of the above points that danimal has posted. The script works and there have been no bans so far but its really suspicious and legitimate players get really angry when they stack up crabs and you attack and kill them all.

Is there a way to attack crabs that are roaming but are not leashed onto a player already?

Share this post


Link to post
Share on other sites

Good script.

 

Issues: west crabs it has been spazzing out with the mouse for whatever reason. Keeps trying to right click in the same spot that the crab just died?

 

East crabs it keeps renewing the crabs.... Even when it doesn't need to be renewed and it's super annoying.

Share this post


Link to post
Share on other sites
Guest green64

Pretty good script, thanks.

 

Some bugs, and some possible improvements:

-It gets stuck quite often at this point, walking from camelot bank and clicking either side of the fence before the bridge which causes it to go back and forth. See image: http://puu.sh/8nVHB

-Renews crabs if there is someone else in the same spot and the crab attacks them first.

-Not sure if its an antiban simulating player boredom, but the cursor often zigzags rapidly for a few seconds when waiting/looking for crabs to attack/appear.

-It moves to the same square whenever it waits to be attacked, therefore doing the same as every other person using this bot.

-It only counts total xp gained and doesn't split between different levels (e.g. range and hp xp gained)

Share this post


Link to post
Share on other sites

Pretty good script, thanks.

 

Some bugs, and some possible improvements:

-It gets stuck quite often at this point, walking from camelot bank and clicking either side of the fence before the bridge which causes it to go back and forth. See image: http://puu.sh/8nVHB

-Renews crabs if there is someone else in the same spot and the crab attacks them first.

-Not sure if its an antiban simulating player boredom, but the cursor often zigzags rapidly for a few seconds when waiting/looking for crabs to attack/appear.

-It moves to the same square whenever it waits to be attacked, therefore doing the same as every other person using this bot.

-It only counts total xp gained and doesn't split between different levels (e.g. range and hp xp gained)

 

I'll check these out, and try to prevent bans. Just a reminder, ban discussion goes on the official banned thread.

 

https://tribot.org/forums/topic/34851-the-official-banned-thread-all-ban-discussion-goes-here/

 

Thanks.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...