Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

karlrais

WarriorGuildDefender [$10][85K XP/HR][100HR proggie][UPDATED FOR DRAGON DEFENDERS]

Recommended Posts

Guest

Found a problem:

 

Left it to run and it seems to be doing fine until the legs degrade - Then it must go to the bank, Withdraw the legs, Drop them all and then logout as it says cannot find any legs? Happened twice now? Using steel, Going to try Mit now - Will let you know if same result

 

      Edit - Just watched it with Mith and found the legs no problem? So working fine now, 

 

Thanks a bunch

Edited by Chaz163

Share this post


Link to post
Share on other sites

banned using this script on my staking account. Vouch for this script it got me 88 88 88 with 1 pray and almost 1k defenders. For you guys that still aren't banned, try to not bot for more then 12 hours. I ran it 14 straight which im kinda regreting now. Its all good tho what ever

Share this post


Link to post
Share on other sites
  • [17:17:56] We are attempting to solve the Strange Plant random.
  • [17:17:57] We are in combat and a random event has spawned. Waiting 4-6 seconds to leave combat.
  • [17:18:02] We are still in combat. Attempting to run away.
  • [17:18:02] We failed to run away from combat.
  • [17:18:06] We successfully solved the Strange Plant random.
  • [17:21:47] Script Ended: WarriorGuildDefender. 

 

umm so i died?

Share this post


Link to post
Share on other sites

Only been using for 10minutes but it works great :)

 

Only thing I'd like is for the not to be all added up.  Or at least take out HP exp out of the total exp.

 

Glad you like it. Let me know if you find any problems.

 

Total exp is total exp. HP will remain in there. HP is 20% of total exp. You can just deduce it.

Share this post


Link to post
Share on other sites

I found a bug that causes it to lose its armor. While it was fighting the animated armor it got a random and when it came back it didn't know that was my animated armor to fight.  So it went and grabbed another set and was trying to make another. Not sure if u can add a fix, not too pressed about it.  Mith sets are pretty cheap.

Share this post


Link to post
Share on other sites

I found a bug that causes it to lose its armor. While it was fighting the animated armor it got a random and when it came back it didn't know that was my animated armor to fight.  So it went and grabbed another set and was trying to make another. Not sure if u can add a fix, not too pressed about it.  Mith sets are pretty cheap.

 

What random was it?

Share this post


Link to post
Share on other sites
Guest

Hey, just paid for script. Working well at the moment, but just a question, is it possible to add support for a secondary weapon special attack? Eg, im using a dragon scimitar, but would love to use a dds to spec. Cheers!

Share this post


Link to post
Share on other sites

Hey, just paid for script. Working well at the moment, but just a question, is it possible to add support for a secondary weapon special attack? Eg, im using a dragon scimitar, but would love to use a dds to spec. Cheers!

 

I could yes, however, I am missing a few ingredients. My new account is at 40 attack, I am super busy IRL, I would hate to do the quest reqs for dragon weapon.

 

Lend me an account with drag weapon sometime around next Sunday and i'll do it :P

Share this post


Link to post
Share on other sites

2nd time losing armour not sure why but heres log if it helps lol
 

  • [21:40:58] We successfully solved the Jekyll random.
  • [22:04:58] Random at cyclopes!
  • [22:04:58] We are attempting to solve the Rick Turpentine random.
  • [22:05:02] We successfully solved the Rick Turpentine random.
  • [22:31:59] We are attempting to solve the Mordaut random.
  • [22:32:01] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:06] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:12] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:13] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:16] Mordaut: Solve next
  • [22:32:16] Mordaut: A13
  • [22:32:21] Mordaut: Solve next
  • [22:32:21] Mordaut: A14
  • [22:32:26] Mordaut: Solve next
  • [22:32:26] Mordaut: A12
  • [22:32:32] Mordaut: We have completed the exam. The door is: purple.
  • [22:32:45] We successfully solved the Mordaut random.
  • [22:32:50] We are attempting to solve the Skill XP Item random.
  • [22:32:57] We successfully solved the Skill XP Item random.
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:15] Black full helm not found in bank! Trying again!
  • [22:33:15] Black full helm not found in bank. Terminating the script!
  • [22:33:15] Runtime: 2h 47min
  • [22:33:15] Total defenders looted: 5
  • [22:33:15] Rune defenders looted: 5
  • [22:33:15] Total exp gained: 151551
  • [22:33:15] Exp per hour: >54k
  • [22:33:15] Script Ended: WarriorGuildDefender. 

Share this post


Link to post
Share on other sites

 

2nd time losing armour not sure why but heres log if it helps lol

 

  • [21:40:58] We successfully solved the Jekyll random.
  • [22:04:58] Random at cyclopes!
  • [22:04:58] We are attempting to solve the Rick Turpentine random.
  • [22:05:02] We successfully solved the Rick Turpentine random.
  • [22:31:59] We are attempting to solve the Mordaut random.
  • [22:32:01] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:06] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:12] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:13] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:16] Mordaut: Solve next
  • [22:32:16] Mordaut: A13
  • [22:32:21] Mordaut: Solve next
  • [22:32:21] Mordaut: A14
  • [22:32:26] Mordaut: Solve next
  • [22:32:26] Mordaut: A12
  • [22:32:32] Mordaut: We have completed the exam. The door is: purple.
  • [22:32:45] We successfully solved the Mordaut random.
  • [22:32:50] We are attempting to solve the Skill XP Item random.
  • [22:32:57] We successfully solved the Skill XP Item random.
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:15] Black full helm not found in bank! Trying again!
  • [22:33:15] Black full helm not found in bank. Terminating the script!
  • [22:33:15] Runtime: 2h 47min
  • [22:33:15] Total defenders looted: 5
  • [22:33:15] Rune defenders looted: 5
  • [22:33:15] Total exp gained: 151551
  • [22:33:15] Exp per hour: >54k
  • [22:33:15] Script Ended: WarriorGuildDefender. 

Armour degrades, go with black +

Share this post


Link to post
Share on other sites
Guest

Bit of a problem when leaving this script on its own. Nothing too major i guess, but if you're quite unlucky then it happens:

In the middle of killing the armour > runs out of food > goes to bank while armour is still there > picks out a new backup armour set and goes back to the room > 1st armour is inactive walking around and it keeps trying to use the newly-taken armour on the animator and just keeps doing that all over again instead of detecting old armour being animated and walking around. Pretty obvious if someone walks in on you.

 

EDIT: Using the armour while old one is animated and walking around does not let you spawn a new one thus making you just stand at the animator doing nothing.

Edited by Silverr

Share this post


Link to post
Share on other sites
Guest

 

2nd time losing armour not sure why but heres log if it helps lol

 

  • [21:40:58] We successfully solved the Jekyll random.
  • [22:04:58] Random at cyclopes!
  • [22:04:58] We are attempting to solve the Rick Turpentine random.
  • [22:05:02] We successfully solved the Rick Turpentine random.
  • [22:31:59] We are attempting to solve the Mordaut random.
  • [22:32:01] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:06] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:12] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:13] Mordaut: Attempting to talk to Mr.Mordaut.
  • [22:32:16] Mordaut: Solve next
  • [22:32:16] Mordaut: A13
  • [22:32:21] Mordaut: Solve next
  • [22:32:21] Mordaut: A14
  • [22:32:26] Mordaut: Solve next
  • [22:32:26] Mordaut: A12
  • [22:32:32] Mordaut: We have completed the exam. The door is: purple.
  • [22:32:45] We successfully solved the Mordaut random.
  • [22:32:50] We are attempting to solve the Skill XP Item random.
  • [22:32:57] We successfully solved the Skill XP Item random.
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:14] Black full helm not found in bank! Trying again!
  • [22:33:15] Black full helm not found in bank! Trying again!
  • [22:33:15] Black full helm not found in bank. Terminating the script!
  • [22:33:15] Runtime: 2h 47min
  • [22:33:15] Total defenders looted: 5
  • [22:33:15] Rune defenders looted: 5
  • [22:33:15] Total exp gained: 151551
  • [22:33:15] Exp per hour: >54k
  • [22:33:15] Script Ended: WarriorGuildDefender.

    Could be because the armor was up while you got teleported away and when you came back it didnt continue instead went to the bank and tried to find a new set.

Share this post


Link to post
Share on other sites

Bit of a problem when leaving this script on its own. Nothing too major i guess, but if you're quite unlucky then it happens:

In the middle of killing the armour > runs out of food > goes to bank while armour is still there > picks out a new backup armour set and goes back to the room > 1st armour is inactive walking around and it keeps trying to use the newly-taken armour on the animator and just keeps doing that all over again instead of detecting old armour being animated and walking around. Pretty obvious if someone walks in on you.

 

EDIT: Using the armour while old one is animated and walking around does not let you spawn a new one thus making you just stand at the animator doing nothing.

 

I see.. It's probably a bug and my fault. I'll look into it.

Share this post


Link to post
Share on other sites
Guest

Made the script get 20k tokens, earned 75k xp/h at cyclops. Cant think of an easier training place right now..

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...