Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

karlrais

WarriorGuildDefender [$10][85K XP/HR][100HR proggie][UPDATED FOR DRAGON DEFENDERS]

Recommended Posts

it went to bank, between looting last lot of tokens and walking to bank it equips mith plate, both times iv missed it equip it but seen it at bank deposit plates i was training with and as iv only got mith plate im using to gain tokens it cant see any and ends script ill keep an eye on it and see if i can grab a small vid of it 

Share this post


Link to post
Share on other sites

it went to bank, between looting last lot of tokens and walking to bank it equips mith plate, both times iv missed it equip it but seen it at bank deposit plates i was training with and as iv only got mith plate im using to gain tokens it cant see any and ends script ill keep an eye on it and see if i can grab a small vid of it 

 

 I don't see how it could equip during walking... That video would be awesome

  • Like 1

Share this post


Link to post
Share on other sites

Hello, bought this yesterday and so far absolutely loving the script. Just a few problems i have encountered. When i originally ran the script i had all the reqs at the bottom of my bank, the bot would click the scroll bar too far up. even if the bank opened with the items on screen it would move up and stop. it continuously clicked  side bar. i fixed this by moving everything to the top of my bank just wanted to let you know. The equiping the mith plate has already been reported. and i encountered a problem where i got a genie random as i finished tokens so i went to bank and continuously clicked the lamp trying to solve it. either way great script :)

Share this post


Link to post
Share on other sites

This could only happen if some Inventory or Equipment API method is broken. This happens quite frequently after RS update, but it also gets fixed in matter of hours, usually.

 

Let me know how your test went. 

 

I figured it out. Works fine thanks a lot karlrais

Share this post


Link to post
Share on other sites

Hello, bought this yesterday and so far absolutely loving the script. Just a few problems i have encountered. When i originally ran the script i had all the reqs at the bottom of my bank, the bot would click the scroll bar too far up. even if the bank opened with the items on screen it would move up and stop. it continuously clicked  side bar. i fixed this by moving everything to the top of my bank just wanted to let you know. The equiping the mith plate has already been reported. and i encountered a problem where i got a genie random as i finished tokens so i went to bank and continuously clicked the lamp trying to solve it. either way great script :)

 

Did you encounter the mithril plate equipping too?

Share this post


Link to post
Share on other sites

Did you encounter the mithril plate equipping too?

Yes i have encountered the mith plate problem as well. although it seems to be very erratic. I baby sat the bot all yesterday and the mith plate problem only happened in the 10 minutes while i was away. although it appears it happened while i was gathering warrior guild tokens. it also appeared to happen once before on the way to the bank. either way i just did a 15 hour session with no mith plate problem. i will continue to try and get a video of it for you.

Share this post


Link to post
Share on other sites

meauxxxx, always use shop bought food it is ALOT cheaper, 2x att,str,def potions and iinvent of food = 1.5k gp roughly.

 

karlrais i have been trying to get vid but ofcourse it doesnt happen when im at pc but it did over night :( i will keep trying to replicate it once i get a hour or 2 to sit playing with it

Share this post


Link to post
Share on other sites

would it be easier to make option to input helm,body and leg ids we are using and have bot equip those ids if they are in invent at all? still cant get it to repeat bug and iv spent last hour wasting food to make it bank more often but it still hasnt done it again while im watching :(

Share this post


Link to post
Share on other sites

I have figureed the mith plate issue it equips it when not near the magical animator... (When the animated armour is walking away it and end up around the southern area of the west animator) once the armour is dead and armour and token picked up it tried to use it on the eastern animator but sometimes missclicks forcing it to wear a mithril platebody. Hope this helps this is how it occurred for me. Thanks Sahi

  • Like 1

Share this post


Link to post
Share on other sites

I have figureed the mith plate issue it equips it when not near the magical animator... (When the animated armour is walking away it and end up around the southern area of the west animator) once the armour is dead and armour and token picked up it tried to use it on the eastern animator but sometimes missclicks forcing it to wear a mithril platebody. Hope this helps this is how it occurred for me. Thanks Sahi

 

Awesome, makes perfect sense now.

 

Thank you, will fix soon.

Edited by karlrais
  • Like 2

Share this post


Link to post
Share on other sites
Guest

 

Updated the script v1.52!

  • Probably fixed the "equipping mith plate bug". I didn't implement re-equipping your old gear, so let me know if this works.

 

 

Ran it overnight ended up equipting mith plate. Doesn't bother me though since I'm a 20 def pure and was wearing initiate plate

Edited by Jesse On Ice

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...