Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

karlrais

WarriorGuildDefender [$10][85K XP/HR][100HR proggie][UPDATED FOR DRAGON DEFENDERS]

Recommended Posts

Guest

I bought this script, and im very dissapointed.. i have to babysit it after i die and lose like 5m ....

Share this post


Link to post
Share on other sites

Sometimes the bot looses the armour and just sits behind the door. It doesnt bother going back to the bank to find a new armour set to use.

 

I just tried it with bronze armor (breaks almost every time) it worked every single time flawless... 

EDIT3: Tried another 10 sets. Worked flawless every single time.

 

Ran overnight, the bot seems to log in and out in the middle of things for no reason for a couple of hours.

http://puu.sh/6tjPo.png

 

I should be getting ~50k exp per hour.

 

Where did this happen?

 

I bought this script, and im very dissapointed.. i have to babysit it after i die and lose like 5m ....

 

No you don't. I just woke up and my bot is going for 15hours. Got me 92 to almost 94 strength.

ngu6ZFj.png

 

EDIT: I guess I have to totally rewrite something if 3 ppl have problems. Must be my fault.

 

EDIT2: Fixed addy armor - it didn't work. whops. 

 

EDIT3: Tried another 10 armorsets. Worked flawless every single time the armor broke.

Edited by karlrais

Share this post


Link to post
Share on other sites

e301906f0482c0f0d06fc01888933a98.png

Purchased yesterday and i't's been great.  Only a slight issue in that I sometimes come back to check on the bot and it's in the middle of nowhere, are all randoms not fully supported as of currently? 

 

Thanks for the proggy :) 

 

Yeah some randoms are broken, and they keep breaking after every rs update. Currently grave digger is definitely broke, maze has always had issues. My script walks to safespot for every random that takes longer than 1-2 clicks to solve or you can't run away from. Sometimes I have seen from recordings that after it's in the safe area it doesn't detect the random event again so it just sits there and waits. I'm constantly bugging Trilez with those issues. 

Share this post


Link to post
Share on other sites

After run this script for 4 hours it ran out of tokens. It still hasn't ran out of food yet, it had 1 food left. So what it did it clocked on door, clicked back in (wasted 10 warrior tokens), and did this 10+ times...... NO WHERE NEAR FLAWLESS.......

Share this post


Link to post
Share on other sites

After run this script for 4 hours it ran out of tokens. It still hasn't ran out of food yet, it had 1 food left. So what it did it clocked on door, clicked back in (wasted 10 warrior tokens), and did this 10+ times...... NO WHERE NEAR FLAWLESS.......

 

Whops lol. I changed this in the latest update but forgot one thing :s I'll upload a fix any minute now.

Share this post


Link to post
Share on other sites

i dont know what it is but sometimes when im coming home from work/school, i just find the bot staring at the bank :s and doing nothing.

you might know what it is? i got everything at the bottum of the bank

 

Can you post here or PM me your settings you use in the gui and picture of your inventory or list of items in inventory when this happens, please?

I looked over the code didn't catch any way for it to get stuck. 

Share this post


Link to post
Share on other sites

Updated the script v1.36

  • Fix to a bug from previous update causing you to clock with 1 food between cyclopes and stairs
  • Changed to dynamic clicking from custom clciking method for cyclopes. Let's see how it works.
  • Improved camera movement during combat, cyclopes health bar should now always be visible.

Share this post


Link to post
Share on other sites

Love the script just bought it and has worked flawlessly for now :) will report any bugs here if i catch any. And also I'm getting 70k+/h while in cyclops and 45-55ish /h when killing mithril armors, my str is 85. Will post proggy later on :)

 

Thankyou :)

Share this post


Link to post
Share on other sites

Had this error today

 

  • [07:17:23] Combat Random: Walking method 1 successful
  • [07:17:36] We successfully solved the Combat Random random.
  • [08:01:08] java.lang.NullPointerException
  • [08:01:08] at scripts.defender.WarriorGuildDefender.M(WarriorGuildDefender.java:2068)
  • [08:01:08] at scripts.defender.WarriorGuildDefender.m(WarriorGuildDefender.java:1361)
  • [08:01:08] at scripts.defender.WarriorGuildDefender.run(WarriorGuildDefender.java:231)
  • [08:01:08] at java.lang.Thread.run(Unknown Source)
  • [08:01:08] Script Ended: WarriorGuildDefender. 
  • Like 1

Share this post


Link to post
Share on other sites

 

Had this error today

 

  • [07:17:23] Combat Random: Walking method 1 successful
  • [07:17:36] We successfully solved the Combat Random random.
  • [08:01:08] java.lang.NullPointerException
  • [08:01:08] at scripts.defender.WarriorGuildDefender.M(WarriorGuildDefender.java:2068)
  • [08:01:08] at scripts.defender.WarriorGuildDefender.m(WarriorGuildDefender.java:1361)
  • [08:01:08] at scripts.defender.WarriorGuildDefender.run(WarriorGuildDefender.java:231)
  • [08:01:08] at java.lang.Thread.run(Unknown Source)
  • [08:01:08] Script Ended: WarriorGuildDefender.

 

Hmm seems like GroundItem.getPosition returned null. Even though the item itself is not null. I've added a null check for position.

Share this post


Link to post
Share on other sites

Love the script just bought it and has worked flawlessly for now :) will report any bugs here if i catch any. And also I'm getting 70k+/h while in cyclops and 45-55ish /h when killing mithril armors, my str is 85. Will post proggy later on :)

 

Thankyou :)

Settings?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...