Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

erickho123

[ABCL 10] ExRunecrafter - Fastest AIO Runecrafter [ABYSS, NORMAL] [ANTI PK] [Pouch Pickup] [ALL RUNES/METHODS] [DEATHWALK]

Recommended Posts

Verison # (Required): 1.999T?

Using Looking glass (if you don't know what this is, awnser no): No

Picture of setup of GUI (Required) :

(Like old one)

Client debug (Required, paste it in http://www.pastebin.com) :

http://pastebin.com/EGxLj9sj

Bug that occurred (Please be detailed) (Required) :

 

Tries to walk to Wildy (Cause inventory is full) Teleported out cause of some reason? Maybe Ring of Life idk.

 

http://puu.sh/j1Htk/14f8a2c567.jpg

I already told you, the minimap bug is not associated with the script.

 

https://tribot.org/forums/topic/51078-walkingclicktilemm-sometimes-clicking-outside-minimap/

Share this post


Link to post
Share on other sites

Just bought this script for lava runecrafting. I noticed that when it enters the altar the bot always runs to the same spot (side of the altar) before it starts to craft. Also, when it uses NPC contact to repair the pouches, it selects the mage and just enters my bank again to retrieve another set of NPC contact runes, fix please.

Share this post


Link to post
Share on other sites

Oh okay I guess that feature that tries to click within the minimap isn't associated with your script either?

I don't think you understand, even though I told you 2 times now that the script is not at fault.

Clearly, you know more than me about the script that I wrote or for some reason, not listening to what I'm trying to tell you.

 

The script calls methods provided by the client (such as clicking the minimap). To be exact, Walking#clickTileMM is the exact method I call, this method is provided the client, the scripter does not make this method. If I had to guess about how many scripts use this method for walking, i'd have to say 99.99% (not even joking). 

 

If you can't keep up with that simple explanation (I tried to make it as simple as I can), then you are in no position to tell me whether your problem is a client issue or a script issue.

I have already addressed your issue, stop posting on my thread about it otherwise I will report it to the moderators to handle.

 

Go to this client bug section and post your concern, or visit the thread that I have linked you already, twice about it: https://tribot.org/forums/topic/51078-walkingclicktilemm-sometimes-clicking-outside-minimap/

 

  • The Scripter is not responsible for downtime of the client. Client downtime is not considered a sound reason to charge-back."

taken from:

https://tribot.org/forums/topic/26570-premium-script-requirements-all-premium-scripters-read/

Edited by erickho123

Share this post


Link to post
Share on other sites

Verison # (Required):current
Using Looking glass (if you don't know what this is, awnser no):yes
Picture of setup of GUI (Required) : http://www.pastebin.com) :http://pastebin.com/9j8jJf7g
Bug that occurred (Please be detailed) (Required) :Randomly (like once per hour max) during banking the bot seems to pause and wait, it idles till the auto log out then logs back in and continues as normal

Edited by Pyker

Share this post


Link to post
Share on other sites

Verison # (Required):current

Using Looking glass (if you don't know what this is, awnser no):yes

Picture of setup of GUI (Required) : http://www.pastebin.com) :http://pastebin.com/9j8jJf7g

Bug that occurred (Please be detailed) (Required) :Randomly (like once per hour max) during banking the bot seems to pause and wait, it idles till the auto log out then logs back in and continues as normal

That script stack trace shows me nothing, but your description of the bug does not seem like a script issue. My guess is that bank items aren't being loaded properly (not a script issue), and this is due to LG or something.

 

With that being said, I could give you better information if you could print the script stack trace MULTIPLE times when it's "idling" at the bank, please do it multiple times. Though, since it doesn't seem like a script issue, and LG is in "beta", I'm afraid there's not much to be done here.

Share this post


Link to post
Share on other sites

That script stack trace shows me nothing, but your description of the bug does not seem like a script issue. My guess is that bank items aren't being loaded properly (not a script issue), and this is due to LG or something.

 

With that being said, I could give you better information if you could print the script stack trace MULTIPLE times when it's "idling" at the bank, please do it multiple times. Though, since it doesn't seem like a script issue, and LG is in "beta", I'm afraid there's not much to be done here.

ok will do that when I observe it again, it doesn't happen very often though so its not a big deal.

Edited by Pyker

Share this post


Link to post
Share on other sites

ok will do that when I observe it again, it doesn't happen very often though so its not a big deal.

No problem look forward to it.

 

 

Would say this is the #1 script on TRiBot. There is literally no bugs.

Thanks, glad you enjoy the script!

 

 

@Peshmerga

The client bug regarding the minimap will be fixed according to trilez on next tribot's update as shown here:

https://tribot.org/forums/topic/51078-walkingclicktilemm-sometimes-clicking-outside-minimap/?p=609351

Share this post


Link to post
Share on other sites


 

Verison # (Required): v1.999T

Using Looking glass (if you don't know what this is, awnser no): no

Picture of setup of GUI (Required) :   http://www.pastebin.com) : didn't get that.

Bug that occurred (Please be detailed) (Required) : The bot randomly stops and stays still for minutes. Does nothing. (I'm not laggy) Good script overall, but it's just that it 'freezes' and stands still for ages. For example here, multiple of my bots have died because it gets stuck like this. (They get pked quite often) http://gyazo.com/c0660e3a809ab887a181525d387d29b5

Share this post


Link to post
Share on other sites

 

 
Verison # (Required): v1.999T
Using Looking glass (if you don't know what this is, awnser no): no
Picture of setup of GUI (Required) :   http://www.pastebin.com) : didn't get that.
Bug that occurred (Please be detailed) (Required) : The bot randomly stops and stays still for minutes. Does nothing. (I'm not laggy) Good script overall, but it's just that it 'freezes' and stands still for ages. For example here, multiple of my bots have died because it gets stuck like this. (They get pked quite often) http://gyazo.com/c0660e3a809ab887a181525d387d29b5

 

It doesn't look like a script issue, actually I might know the reason why it's occuring, but I can't be certain until you get the stack trace. Please fill out the form again once you get the stack trace.

 

The bug you are talking about is a client bug that is posted in the scripter discussion chat (Mouse#click pauses randomly). There's not much I can do about that, but I can raise your concern to trilez some more if we can confirm the issue. (By providing the chat)

 

P.S, please only contact me one way next time, adding me on skype and posting on the thread just delays your questions / concerns. 

Share this post


Link to post
Share on other sites

Just bought this script for lava runecrafting. I noticed that when it enters the altar the bot always runs to the same spot (side of the altar) before it starts to craft. Also, when it uses NPC contact to repair the pouches, it selects the mage and just enters my bank again to retrieve another set of NPC contact runes, fix please.

@Rockerariel, sorry I somehow missed your message. Could you add me on skype, it's: support.erickho123? I as well, don't believe it's a script issue (NPCCHat#clickContinue doesn't wait for the next chat)

@Rockerariel

Share this post


Link to post
Share on other sites
Guest Cold995

Not sure why this is happening but, whenever the script goes to heal up and withdraw food it keeps spamming the noted/items buttons at the bottom of the bank screen. Then with draws food/pure ess and keeps banking them then withdrawing then over and over. Any help?

Share this post


Link to post
Share on other sites

Not sure why this is happening but, whenever the script goes to heal up and withdraw food it keeps spamming the noted/items buttons at the bottom of the bank screen. Then with draws food/pure ess and keeps banking them then withdrawing then over and over. Any help?

Use the proper bug report, get the stack trace when it spams the "noted" item button and when it withdraw/deposit constantly, this is not intended and I don't even believe I have code for it to click "note".

Share this post


Link to post
Share on other sites

@erickho123

 

Got the banking bug again:http://pastebin.com/kdfe6Rmf

 

IDK if this helps

I can confirm it's not a script issue, this is due to LG / slow computer (at the time) / runescape. The problem is that your bank items aren't loading fully (meaning not all your items are shown in your bank).

 

My guess it's due to LG since it's my first time hearing this occur.

Share this post


Link to post
Share on other sites

I can confirm it's not a script issue, this is due to LG / slow computer (at the time) / runescape. The problem is that your bank items aren't loading fully (meaning not all your items are shown in your bank).

 

My guess it's due to LG since it's my first time hearing this occur.

Closing the bank window fixes it, can you add a failsafe in if it's been open for a certain amount of time?

Share this post


Link to post
Share on other sites

Probably a dumb suggestion, but, for the people using house tabs/mounted glory.

 

Say if they had an altar in their house, maybe a feature where each time it runs through the house it would recharge prayer and have protect from melee on to avoid getting hit in the abyss? Probably a dumb suggestion but figured I would ask my dumb question for the day! :)

If you enter the abyss tunnel you get 0 prayer points automatically

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Worthy
      Accessible now through the script's GUI!
      Just click "READ ME!"

      If you are botting on a remote machine and have difficulties browsing the web (and thus the documentation), pressing the "READ ME" button will also print your link and access token in the Client Debug. You may view this link in any web browser for 5 minutes to view the documentation on any computer.
      So, once pressing the "READ ME" button, the following link to view the documentation is generated in the Client Debug: http://worthy.rs/ZulrahSlayer/documentation.php?user=worthy
      (except it will show your TRiBot name).
    • By Starfox
      Sigma Herbalist
       
      Features:
      -> Identifies all herbs at a badass speed
      -> Mixes potions like a badass
      -> Grinds ingredients with badassery
      -> Makes potions from scratch just like a badass would
       
      Log:
       
      FAQ:
      Q: Why does this script not support decanting?
      A: You can instantly decant all of your potions via Zahur in the city of Nardah
       
      Q: How do I use the Scan Inventory feature?
      A: Have the game window open with your player logged in, and press the Scan Inventory button. The list above will then list all of the items in your inventory with their names and id's so you can then enter the desired id's into the fields.
       
      Q: When mixing potions, the script won't start!
      A: If you want to only mix unfinished or finished potions and not make potions from scratch, you need to enter a negative number into the id3 and id4 fields.
  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...