Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

erickho123

[ABCL 10] ExRunecrafter - Fastest AIO Runecrafter [ABYSS, NORMAL] [ANTI PK] [Pouch Pickup] [ALL RUNES/METHODS] [DEATHWALK]

Recommended Posts

Guest

Ive been crafting some fire runes to get to lvl 44 and noticed that the bot just spins the camera for like 10-15 secs every so often.  Is there a reason for this?  Cause that isn't very humanlike.

Share this post


Link to post
Share on other sites
Guest

78QQ997.png

Edited by Wolfeh123

Share this post


Link to post
Share on other sites

Ive been crafting some fire runes to get to lvl 44 and noticed that the bot just spins the camera for like 10-15 secs every so often.  Is there a reason for this?  Cause that isn't very humanlike.

Are you lagging by any chance? If you lag for just a little bit, Camera#turnToTile won't release your key until the next rotation or something similiar to that? Where is it happening exactly?

 

 

78QQ997.png

 

78QQ997.png

Nice proggy! Whats your rc lvl if you don't mind telling (give us a range)

Share this post


Link to post
Share on other sites

Verison #: Latest
Altar: Nature
Mode(Master/Slave/Abyss/Solo): Abyss Solo
Obstacles selected (Abyss only): Chop, Squeeze
Teleportation / Walking method: house runes - mounted glory
Abyss debug: 0
Pause (true/false?) (abyss only): false:Squeeze-through
Eat at and Emergency teleport % (Abyss only) eat 60, tele 50
Picture of setup of GUI :
Anything the script printed that told you to post on the thread? I.E: Error #1 please post this on thread: Nothing
Script stack trace (image of how to print stack trace here: 

  • [20:42:24] java.lang.Thread.sleep(Native Method)
  • [20:42:24] org.tribot.api.General.sleep(ek:18)
  • [20:42:24] org.tribot.script.Script.sleep(ji:77)
  • [20:42:24] scripts.exrunecrafter.ExRunecraft.run(ExRunecraft.java:200)
  • [20:42:24] java.lang.Thread.run(Thread.java:744) 

Bug that occurred (Please be detailed)

 

Don't know if any of the above applies to my issue but, I've been experiencing deaths every 5 hours or so of running. After some thinking I'm pretty sure it's caused by the Tribot break system. I believe that when the break is initiated the bot is inside the abyss, since it is being attacked logging out won't work. And obviously the script has went to sleep so it won't emergency tele. I can't find any fix for this other than not using the break handler for this script, but that reduces my profits as I try to bot safe. 

 

Maybe if there was a re-gear option that we could set so if the bot dies it will still appear human to other players. I know if I was abyss crafting legitimately and I saw someone doing the abyss with no gear and just a pickaxe, I'd report them haha, especially if I saw them before with gear on.

 

 

 

Unrelated:

n181f6.png

 

Am I missing part of the gui? I'm on a mac and it won't extend the interior gui window when I maximize the whole thing. You can see where the death walk box gets cut off.

Edited by danimal

Share this post


Link to post
Share on other sites
Guest

Are you lagging by any chance? If you lag for just a little bit, Camera#turnToTile won't release your key until the next rotation or something similiar to that? Where is it happening exactly?

 

 

 

Nice proggy! Whats your rc lvl if you don't mind telling (give us a range)

 

 

In the 50s.

Edited by Wolfeh123

Share this post


Link to post
Share on other sites

In the 50s.

1.4k+ runes at 50 rc, very nice!

 

 

Verison #: Latest

Altar: Nature

Mode(Master/Slave/Abyss/Solo): Abyss Solo

Obstacles selected (Abyss only): Chop, Squeeze

Teleportation / Walking method: house runes - mounted glory

Abyss debug: 0

Pause (true/false?) (abyss only): false:Squeeze-through

Eat at and Emergency teleport % (Abyss only) eat 60, tele 50

Picture of setup of GUI :

Anything the script printed that told you to post on the thread? I.E: Error #1 please post this on thread: Nothing

Script stack trace (image of how to print stack trace here:

  • [20:42:24] java.lang.Thread.sleep(Native Method)
  • [20:42:24] org.tribot.api.General.sleep(ek:18)
  • [20:42:24] org.tribot.script.Script.sleep(ji:77)
  • [20:42:24] scripts.exrunecrafter.ExRunecraft.run(ExRunecraft.java:200)
  • [20:42:24] java.lang.Thread.run(Thread.java:744) 

Bug that occurred (Please be detailed)

 

Don't know if any of the above applies to my issue but, I've been experiencing deaths every 5 hours or so of running. After some thinking I'm pretty sure it's caused by the Tribot break system. I believe that when the break is initiated the bot is inside the abyss, since it is being attacked logging out won't work. And obviously the script has went to sleep so it won't emergency tele. I can't find any fix for this other than not using the break handler for this script, but that reduces my profits as I try to bot safe. 

 

Maybe if there was a re-gear option that we could set so if the bot dies it will still appear human to other players. I know if I was abyss crafting legitimately and I saw someone doing the abyss with no gear and just a pickaxe, I'd report them haha, especially if I saw them before with gear on.

 

 

 

Unrelated:

n181f6.png

 

Am I missing part of the gui? I'm on a mac and it won't extend the interior gui window when I maximize the whole thing. You can see where the death walk box gets cut off.

No, you're not missing anything. It should teleport away in the abyss as long as it detects the obstacle. I'll change the check to check if the abyssal monsters are there instead. Although, it should teleport perfectly fine away before breaking, can you confirm this is the actual cause before futher investigation?

Share this post


Link to post
Share on other sites

1.4k+ runes at 50 rc, very nice!

 

 

No, you're not missing anything. It should teleport away in the abyss as long as it detects the obstacle. I'll change the check to check if the abyssal monsters are there instead. Although, it should teleport perfectly fine away before breaking, can you confirm this is the actual cause before futher investigation?

I was planning on buying this script today and I was wondering if you are considering implementing a re-gear option or a glory recharge option? Those are the 2 features that I feel it is missing out on a bit.

I will buy it today no matter what answer you give me I just asked out of curiosity :P

Share this post


Link to post
Share on other sites
Guest

I was planning on buying this script today and I was wondering if you are considering implementing a re-gear option or a glory recharge option? Those are the 2 features that I feel it is missing out on a bit.

I will buy it today no matter what answer you give me I just asked out of curiosity :P

Just invest in getting 47 construction. It's way more worth than buying glories.

 

 

Also, just curious, what do you think I could expect once I get 75 and get a giant pouch? Maybe around 1700/1800 an hour?

Edited by Wolfeh123

Share this post


Link to post
Share on other sites

Just invest in getting 47 construction. It's way more worth than buying glories.

 

 

Also, just curious, what do you think I could expect once I get 75 and get a giant pouch? Maybe around 1700/1800 an hour?

Using mouse keys? I'm not too sure but around there sounds about right, maybe more.

 

 

I was planning on buying this script today and I was wondering if you are considering implementing a re-gear option or a glory recharge option? Those are the 2 features that I feel it is missing out on a bit.

I will buy it today no matter what answer you give me I just asked out of curiosity :P

Well.. i won't be adding glory recharge option.. It's not really runecrafting...

Re-gearing is a planned feature

Share this post


Link to post
Share on other sites

Verison #:Latest verson from 09/05/14 (taodays post)
Altar:Nature Solo
Mode(Master/Slave/Abyss/Solo): Solo abyss
Obstacles selected (Abyss only):MINE/AGILITY/Theiv.
Teleportation / Walking method:Housetablets Super energy 4.
Abyss debug: Na bot stopped so couldent see
Pause (true/false?) (abyss only): unsure
Eat at and Emergency teleport % (Abyss only) eat 50% tele 25%
Picture of setup of GUI : All pouches, Super Enrgy Do not bank any doses, pouchpickup Deathrun Housetabs Basic setup Nat Solo Abyys
Anything the script printed that told you to post on the thread?:

  • [07:46:46] new feature, didn't get to test but script thinks we're lost!
  • [07:46:46] java.lang.RuntimeException: Stopping script, you must be missing an item
  • [07:46:46] at scripts.exrunecrafter.ExRunecraft.run(ExRunecraft.java:147)
  • [07:46:46] at java.lang.Thread.run(Unknown Source)
  • [07:46:47] Script Ended: ExRuneCrafter Monthly.

    Could be a client issue im unsure but i gave it a miss i've ran my bot for around 4 hours, thats 3 restarts kinda around 1 hour mark it will Break Log out with that Message in the log, Also prior to that it will say (not sure if this is normal) evry 2 mins Disabling all randoms Enabling all randoms to mins apart

    3 Occurences since happening:
    im Guessing from logging in... i found im outside my house portal (logged out inside my house) with 44 nats crafted and pure ess left over meaning it had teleported without crafting runes after emptying a pouch twice in the space of 3 hours and broke the third time on the way to the ditch

Share this post


Link to post
Share on other sites

No, you're not missing anything. It should teleport away in the abyss as long as it detects the obstacle. I'll change the check to check if the abyssal monsters are there instead. Although, it should teleport perfectly fine away before breaking, can you confirm this is the actual cause before futher investigation?

 

I can't be 100% certain about my conclusion as I am never watching it when it happens. I have however seen the break initiate while the bot has just entered abyss, meaning: I saw the break message show up in the client debug and then the bot tried to log out while being attacked by abyss monsters. I didn't let things play out to see if it would continually try to log out until it teled/died so I manually went through an obstacle and then logged out. 

 

Is my understanding of the break system correct? That it pretty much overrides all actions of the script until said break is over, then it resumes the script? i.e. script is supposed to emergency tele at #hp level, but break is active so script won't take action and teleport away.

 

If it is then thats what I think is causing my deaths. 

Share this post


Link to post
Share on other sites

I can't be 100% certain about my conclusion as I am never watching it when it happens. I have however seen the break initiate while the bot has just entered abyss, meaning: I saw the break message show up in the client debug and then the bot tried to log out while being attacked by abyss monsters. I didn't let things play out to see if it would continually try to log out until it teled/died so I manually went through an obstacle and then logged out. 

 

Is my understanding of the break system correct? That it pretty much overrides all actions of the script until said break is over, then it resumes the script? i.e. script is supposed to emergency tele at #hp level, but break is active so script won't take action and teleport away.

 

If it is then thats what I think is causing my deaths. 

So the break initated when it was still not inside the abyss? If so, that makes more sense. Yes it overrides everything until the break is over and resume the script. However, i can make it do an action before the break starts which is already added.

Share this post


Link to post
Share on other sites

So the break initated when it was still not inside the abyss? If so, that makes more sense. Yes it overrides everything until the break is over and resume the script. However, i can make it do an action before the break starts which is already added.

 

Is the abyss the inner ring with the different rune rifts or the area right when the zamorak mage teleports you? The break begins while inside the area after the mage teleports you. How would the action know when a break is coming? Unless breaks are able to be denied by the script. All of this is over my head haha  :D

Share this post


Link to post
Share on other sites

Verison #: Latest one
Altar: Abyss (nature runes)
Mode(Master/Slave/Abyss/Solo):abyss, solo
Obstacles selected (Abyss only): mine,passage,eyes,gap
Teleportation / Walking method:teletab,mounted glory
Abyss debug: didnt see as script stopped before i could check
Pause (true/false?) (abyss only): as above
Eat at and Emergency teleport % (Abyss only): 85%
Picture of setup of GUI : 828XB.png
Anything the script printed that told you to post on the thread? I.E: Error #1 please post this on thread: this was all i got - 8293A.png
Script stack trace (image of how to print stack trace here: http://gyazo.com/6a34c15dabaec56761596344fcaa8815) : 8293A.png
Bug that occurred (Please be detailed): script just stopped right here,not sure why but it did. i know it is not detailed.

829ba.png

Share this post


Link to post
Share on other sites

Verison #: Latest one
Altar: Abyss (nature runes)
Mode(Master/Slave/Abyss/Solo):abyss, solo
Obstacles selected (Abyss only): mine,passage,eyes,gap
Teleportation / Walking method:teletab,mounted glory
Abyss debug: didnt see as script stopped before i could check
Pause (true/false?) (abyss only): as above
Eat at and Emergency teleport % (Abyss only): 85%
Picture of setup of GUI : 828XB.png
Anything the script printed that told you to post on the thread? I.E: Error #1 no, nothing
Script stack trace (image of how to print stack trace here: http://gyazo.com/6a34c15dabaec56761596344fcaa8815) : 82avs.png
Bug that occurred (Please be detailed): script stopped in the inner ring of the abyss very near the rift for some reason.

82aGg.png

Share this post


Link to post
Share on other sites

some aspects to think about:

 

>>Spamming the destination on the minimap should be changed, this isnt very human-like. This occurs when walking to the rift, walking the edge bank, walking to mounted glory and is quite bot-like.

 

>>checking xp would be a good addition (only check runecrafting though).

 

thanks alot! it is great just would be even better if these were added! thanks :D

  • Like 1

Share this post


Link to post
Share on other sites

Verison #: Latest one

Altar: Abyss (nature runes)

Mode(Master/Slave/Abyss/Solo):abyss, solo

Obstacles selected (Abyss only): mine,passage,eyes,gap

Teleportation / Walking method:teletab,mounted glory

Abyss debug: didnt see as script stopped before i could check

Pause (true/false?) (abyss only): as above

Eat at and Emergency teleport % (Abyss only): 85%

Picture of setup of GUI : 828XB.png

Anything the script printed that told you to post on the thread? I.E: Error #1 no, nothing

Script stack trace (image of how to print stack trace here: http://gyazo.com/6a34c15dabaec56761596344fcaa8815) : 82avs.png

Bug that occurred (Please be detailed): script stopped in the inner ring of the abyss very near the rift for some reason.

 

 

 

This isn't a script error, it sounds to me your instance ended (check in bot debug).

 

 

 

if abc was implemented y doesn't it even check for xp? great bot at all but some crucial things I think are missing which might make it detectable.

It does, it just doesn't do it every time you stare at the pc..

 

 

 

 

 

some aspects to think about:

 

>>Spamming the destination on the minimap should be changed, this isnt very human-like. This occurs when walking to the rift, walking the edge bank, walking to mounted glory and is quite bot-like.

 

>>checking xp would be a good addition (only check runecrafting though).

 

thanks alot! it is great just would be even better if these were added! thanks :D

i'll increase the walking timeout to slightly higher

Edited by erickho123

Share this post


Link to post
Share on other sites

Looking to get Another account 91 rc? anyone ever used this script for Exp on low rcing? because i've alsways used a main and i personally Legitly did Astrals/fire to 91

if i get another rcer past 91 well ill be on 80k nats a day will track progress any answers will be apreciated

I can add astrals after an my pouch support addition that should be coming this weekend

Share this post


Link to post
Share on other sites

Up to you mate, If you have the spare time and dont mind and can make it as flawless as rest are, without being to botlike id say astrals are probs less bannable tbh so it would be amazing :)
Solo fire crafting mate (duel teleportation using 0 pouches) will not drink super energies 4 it withdraws them evry time it banks right clicks so i knows its there and wont drink. if i manually drink a dose myself it then banks super energy (3) and i have it set to dont bank any doses would fill out bug report if its a must let me know also normal energies dont work

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Worthy
      Accessible now through the script's GUI!
      Just click "READ ME!"

      If you are botting on a remote machine and have difficulties browsing the web (and thus the documentation), pressing the "READ ME" button will also print your link and access token in the Client Debug. You may view this link in any web browser for 5 minutes to view the documentation on any computer.
      So, once pressing the "READ ME" button, the following link to view the documentation is generated in the Client Debug: http://worthy.rs/ZulrahSlayer/documentation.php?user=worthy
      (except it will show your TRiBot name).
    • By Starfox
      Sigma Herbalist
       
      Features:
      -> Identifies all herbs at a badass speed
      -> Mixes potions like a badass
      -> Grinds ingredients with badassery
      -> Makes potions from scratch just like a badass would
       
      Log:
       
      FAQ:
      Q: Why does this script not support decanting?
      A: You can instantly decant all of your potions via Zahur in the city of Nardah
       
      Q: How do I use the Scan Inventory feature?
      A: Have the game window open with your player logged in, and press the Scan Inventory button. The list above will then list all of the items in your inventory with their names and id's so you can then enter the desired id's into the fields.
       
      Q: When mixing potions, the script won't start!
      A: If you want to only mix unfinished or finished potions and not make potions from scratch, you need to enter a negative number into the id3 and id4 fields.
  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...