Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

erickho123

[ABCL 10] ExRunecrafter - Fastest AIO Runecrafter [ABYSS, NORMAL] [ANTI PK] [Pouch Pickup] [ALL RUNES/METHODS] [DEATHWALK]

Recommended Posts

Sorry to ask again, but sometimes the script pauses randomly when running?

 

for example when emptying pouches it just hovers the mouse over the pouch for around 20 - 30 seconds, looks suss as fuck just standing there at altar..

 

  • [19:06:51] java.lang.Thread.sleep(Native Method)
  • [19:06:51] obf.Cf.m(pg:379)
  • [19:06:51] org.tribot.api.General.sleep_definite(kf:76)
  • [19:06:51] obf.aj.m(ml:774)
  • [19:06:51] org.tribot.api.input.Mouse.click(ni:155)
  • [19:06:51] scripts.exrunecrafter.vb.L(Methods.java:756)
  • [19:06:51] scripts.exrunecrafter.a.in.m(Abyss.java:1012)
  • [19:06:51] scripts.exrunecrafter.ExRunecraft.run(ExRunecraft.java:556)
  • [19:06:51] java.lang.Thread.run(Thread.java:745) 

Share this post


Link to post
Share on other sites

 

Sorry to ask again, but sometimes the script pauses randomly when running?

 

for example when emptying pouches it just hovers the mouse over the pouch for around 20 - 30 seconds, looks suss as fuck just standing there at altar..

 

  • [19:06:51] java.lang.Thread.sleep(Native Method)
  • [19:06:51] obf.Cf.m(pg:379)
  • [19:06:51] org.tribot.api.General.sleep_definite(kf:76)
  • [19:06:51] obf.aj.m(ml:774)
  • [19:06:51] org.tribot.api.input.Mouse.click(ni:155)
  • [19:06:51] scripts.exrunecrafter.vb.L(Methods.java:756)
  • [19:06:51] scripts.exrunecrafter.a.in.m(Abyss.java:1012)
  • [19:06:51] scripts.exrunecrafter.ExRunecraft.run(ExRunecraft.java:556)
  • [19:06:51] java.lang.Thread.run(Thread.java:745) 

 

It's not a script issue, i'm not sure what causes it. I'll speak to TRiLeZ about it, although.

 

 

i just have a suggestion, the bot should avoid going to densly populated worlds i have gotten pked in world 305 witch the wild is very active

Good idea, thanks.

 

 

 

 

 

 

 

 

A TRiBot update is coming sometime today to fix various bugs that you may have experienced since the latest runescape update.

Edited by erickho123

Share this post


Link to post
Share on other sites

I found the reason why my bots are teleporting so often without any reason. i made screenshots of it.

 

Left side = the bot (me)                   Right side = Air orb crafter (me, for the following example)

 

Album Screenshots: http://imgur.com/a/8x4p1  

 

The person at the air orb obelisk CANT attack any runecrafters from up there.

can this be fixed? this is slowing my gp/h down and this is happening all the time (80% of all antipk teleports)

 

@erickho123

Share this post


Link to post
Share on other sites

I found the reason why my bots are teleporting so often without any reason. i made screenshots of it.

 

Left side = the bot (me)                   Right side = Air orb crafter (me, for the following example)

 

Album Screenshots: http://imgur.com/a/8x4p1  

 

The person at the air orb obelisk CANT attack any runecrafters from up there.

can this be fixed? this is slowing my gp/h down and this is happening all the time (80% of all antipk teleports)

 

@erickho123

Sure, i'll add a check for non reachable users today, good find thanks!

Edited by erickho123

Share this post


Link to post
Share on other sites

I'm having a hard time with mine, keeps messing up at the bank, withdraws random items and then puts them back in the bank over and over and over, also banks my armour. Any ideas if its just me or does the bot require some tweaking. 

 

Edited/ Fixed the withdrawing bank problem by putting ess, glories and monkfish at the top of the bank in bank slot 1 2 3. Now the bot is just running slow and still removing armour. Probably need to wait for another update.

Edited by sizor

Share this post


Link to post
Share on other sites

I'm having a hard time with mine, keeps messing up at the bank, withdraws random items and then puts them back in the bank over and over and over, also banks my armour. Any ideas if its just me or does the bot require some tweaking. 

 

Edited/ Fixed the withdrawing bank problem by putting ess, glories and monkfish at the top of the bank in bank slot 1 2 3. Now the bot is just running slow and still removing armour. Probably need to wait for another update.

i think thats not a script issue, are you using human mouse ? bcs this could be the reason. had the same problem few times as i turnd human mouse on

Share this post


Link to post
Share on other sites

i think thats not a script issue, are you using human mouse ? bcs this could be the reason. had the same problem few times as i turnd human mouse on

How does one turn off human mouse? lol

 

Edited/ Disreguard figured it out lol

Edited by sizor

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Worthy
      Accessible now through the script's GUI!
      Just click "READ ME!"

      If you are botting on a remote machine and have difficulties browsing the web (and thus the documentation), pressing the "READ ME" button will also print your link and access token in the Client Debug. You may view this link in any web browser for 5 minutes to view the documentation on any computer.
      So, once pressing the "READ ME" button, the following link to view the documentation is generated in the Client Debug: http://worthy.rs/ZulrahSlayer/documentation.php?user=worthy
      (except it will show your TRiBot name).
    • By Starfox
      Sigma Herbalist
       
      Features:
      -> Identifies all herbs at a badass speed
      -> Mixes potions like a badass
      -> Grinds ingredients with badassery
      -> Makes potions from scratch just like a badass would
       
      Log:
       
      FAQ:
      Q: Why does this script not support decanting?
      A: You can instantly decant all of your potions via Zahur in the city of Nardah
       
      Q: How do I use the Scan Inventory feature?
      A: Have the game window open with your player logged in, and press the Scan Inventory button. The list above will then list all of the items in your inventory with their names and id's so you can then enter the desired id's into the fields.
       
      Q: When mixing potions, the script won't start!
      A: If you want to only mix unfinished or finished potions and not make potions from scratch, you need to enter a negative number into the id3 and id4 fields.
  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 9 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...