Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

adamhumphries5

Xtreme Essence Miner(CUSTOM ABCL ANTIBAN SYSTEM, Completly different characteristics for each runescape account!))

Recommended Posts

@adamhumphries5

 

Still doesn't work.

Ill try to fix the vps issue, I didn't try fixing that. I'll let you know when the fix is up.

 

OH I KNOWW WHAT IT IS. You must start the script already logged in! @God Pks

 

(The first time you run the script that is, after opening a new client, because it has to grab your rs username to generate a seed. After that you can start it from the login screen.

Edited by adamhumphries5

Share this post


Link to post
Share on other sites

Ill try to fix the vps issue, I didn't try fixing that. I'll let you know when the fix is up.

 

OH I KNOWW WHAT IT IS. You must start the script already logged in! @God Pks

 

(The first time you run the script that is, after opening a new client, because it has to grab your rs username to generate a seed. After that you can start it from the login screen.

 

That did it. Was kinda thinking that's what it might be.

 

However, its first trip into the essence, it teleported right next to the mine. It didn't like it, though, and walked to another one on the other side of the map.

 

@adamhumphries5

Share this post


Link to post
Share on other sites

That did it. Was kinda thinking that's what it might be.

 

However, its first trip into the essence, it teleported right next to the mine. It didn't like it, though, and walked to another one on the other side of the map.

 

@adamhumphries5

Ill see what I can do. give me 10 mins and a fix will be up

 

@God Pks

 

Uploaded fix to sdn, should fix it as I found a small silly bug in my code. Hope it helps!

Edited by adamhumphries5

Share this post


Link to post
Share on other sites
Guest

I'm getting this error:

[14:04:34] Downloading script 'Xtreme Essence Miner'.[14:04:36] Script Started: Xtreme Essence Miner.[14:04:36] Your seed delay is: 1093 due to your username of: ***********[14:04:36] File found[14:04:36] java.util.NoSuchElementException[14:04:36] 	at java.util.Scanner.throwFor(Unknown Source)[14:04:36] 	at java.util.Scanner.next(Unknown Source)[14:04:36] 	at java.util.Scanner.nextInt(Unknown Source)[14:04:36] 	at java.util.Scanner.nextInt(Unknown Source)[14:04:36] 	at scripts.XtremeEssenceMiner.Core.f(Core.java:262)[14:04:36] 	at scripts.XtremeEssenceMiner.Core.run(Core.java:80)[14:04:36] 	at java.lang.Thread.run(Unknown Source)[14:04:36] Script Ended: Xtreme Essence Miner.
Edited by _Mikk

Share this post


Link to post
Share on other sites

 

I'm getting this error:

[14:04:34] Downloading script 'Xtreme Essence Miner'.[14:04:36] Script Started: Xtreme Essence Miner.[14:04:36] Your seed delay is: 1093 due to your username of: ***********[14:04:36] File found[14:04:36] java.util.NoSuchElementException[14:04:36] 	at java.util.Scanner.throwFor(Unknown Source)[14:04:36] 	at java.util.Scanner.next(Unknown Source)[14:04:36] 	at java.util.Scanner.nextInt(Unknown Source)[14:04:36] 	at java.util.Scanner.nextInt(Unknown Source)[14:04:36] 	at scripts.XtremeEssenceMiner.Core.f(Core.java:262)[14:04:36] 	at scripts.XtremeEssenceMiner.Core.run(Core.java:80)[14:04:36] 	at java.lang.Thread.run(Unknown Source)[14:04:36] Script Ended: Xtreme Essence Miner.

If you're getting that error you need to delete your Xtreme folder in your .tribot folder. Once I did this, the error dissappeared and the script ran fine :)

Share this post


Link to post
Share on other sites

Now I do get this error:

[19:17:52] Taking a lunch break!(Eating)[19:38:08] Restarting client.[19:38:31] Hunger: 59 and Thirst: 28 and lastly tiredness: 7[19:38:31] java.lang.NullPointerException[19:38:31] 	at scripts.XtremeEssenceMiner.Core.A(Core.java:301)[19:38:31] 	at scripts.XtremeEssenceMiner.Core.run(Core.java:93)[19:38:31] 	at java.lang.Thread.run(Unknown Source)[19:38:31] Script Ended: Xtreme Essence Miner.

Share this post


Link to post
Share on other sites

Still the same error:

[19:30:25] Hunger: 114 and Thirst: 28 and lastly tiredness: 39[19:30:26] Taking a lunch break!(Eating)[19:56:34] Restarting client.[19:56:51] Hunger: 51 and Thirst: 28 and lastly tiredness: 39[19:56:51] java.lang.NullPointerException[19:56:51] 	at scripts.XtremeEssenceMiner.Core.C(Core.java:288)[19:56:51] 	at scripts.XtremeEssenceMiner.Core.run(Core.java:80)[19:56:51] 	at java.lang.Thread.run(Unknown Source)[19:56:51] Script Ended: Xtreme Essence Miner.

EDIT: Also it seems like the client restart also resets the chosen world so it may mess things up if the bot tries to sign in to p2p world.

Edited by Mikeey

Share this post


Link to post
Share on other sites

Still the same error:

[19:30:25] Hunger: 114 and Thirst: 28 and lastly tiredness: 39[19:30:26] Taking a lunch break!(Eating)[19:56:34] Restarting client.[19:56:51] Hunger: 51 and Thirst: 28 and lastly tiredness: 39[19:56:51] java.lang.NullPointerException[19:56:51] 	at scripts.XtremeEssenceMiner.Core.C(Core.java:288)[19:56:51] 	at scripts.XtremeEssenceMiner.Core.run(Core.java:80)[19:56:51] 	at java.lang.Thread.run(Unknown Source)[19:56:51] Script Ended: Xtreme Essence Miner.

EDIT: Also it seems like the client restart also resets the chosen world so it may mess things up if the bot tries to sign in to p2p world.

Thanks for the stacktrace, uploading a fix.

Share this post


Link to post
Share on other sites

Error again, I believe I am using your latest version (atleast the line numbers have changed)

[03:10:34] Walking to aubury[03:10:44] Hunger: 113 and Thirst: 23 and lastly tiredness: 10[03:10:45] Hunger: 115 and Thirst: 23 and lastly tiredness: 10[03:10:46] Taking a lunch break!(Eating)[03:23:24] Restarting client.[03:23:41] Hunger: 65 and Thirst: 23 and lastly tiredness: 10[03:23:41] java.lang.NullPointerException[03:23:41] 	at scripts.XtremeEssenceMiner.Core.a(Core.java:289)[03:23:41] 	at scripts.XtremeEssenceMiner.Core.run(Core.java:80)[03:23:41] 	at java.lang.Thread.run(Unknown Source)[03:23:41] Script Ended: Xtreme Essence Miner.

Share this post


Link to post
Share on other sites

 

Error again, I believe I am using your latest version (atleast the line numbers have changed)

[03:10:34] Walking to aubury[03:10:44] Hunger: 113 and Thirst: 23 and lastly tiredness: 10[03:10:45] Hunger: 115 and Thirst: 23 and lastly tiredness: 10[03:10:46] Taking a lunch break!(Eating)[03:23:24] Restarting client.[03:23:41] Hunger: 65 and Thirst: 23 and lastly tiredness: 10[03:23:41] java.lang.NullPointerException[03:23:41] 	at scripts.XtremeEssenceMiner.Core.a(Core.java:289)[03:23:41] 	at scripts.XtremeEssenceMiner.Core.run(Core.java:80)[03:23:41] 	at java.lang.Thread.run(Unknown Source)[03:23:41] Script Ended: Xtreme Essence Miner.

Uploaded a fix that I believe will finnaly get rid of the error. Made a silly mistake. Enjoy!

Share this post


Link to post
Share on other sites

Sadly I believe that is a client issue. Notice how the script isn't making debug, that shows that the client wasn't re-enabling the script after completing the random. Ask TRiLeZ. I have it so if my script is running at ALL, it will make debug. So I can confirm that's not my script. My apologies that this happend though.

Share this post


Link to post
Share on other sites

Bot didn't login after this client restart.

[10:13:27] Hunger: 113 and Thirst: 20 and lastly tiredness: 59[10:13:27] 712 and 424 and 1233[10:13:28] Taking a lunch break!(Eating)[10:25:24] Restarting client.[10:26:35] Your seed delay is: 2118 due to your username of: *******[10:26:35] File found[10:26:35] Path to bank is:2 and path to aubury is: 2

Share this post


Link to post
Share on other sites

 

Bot didn't login after this client restart.

[10:13:27] Hunger: 113 and Thirst: 20 and lastly tiredness: 59[10:13:27] 712 and 424 and 1233[10:13:28] Taking a lunch break!(Eating)[10:25:24] Restarting client.[10:26:35] Your seed delay is: 2118 due to your username of: *******[10:26:35] File found[10:26:35] Path to bank is:2 and path to aubury is: 2

Adding a fix, thanks for posting!

 

Edit: UPLOADING TO SDN NOW. @Mikeey

Edited by adamhumphries5

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...