Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

modulusfrank12

All-in-one Green Dragon Killer - Supreme Green Dragons[Goldfarming][ABCL 10][Looting bag][Multi threaded Combat System][Multi Threaded Anti-PK System]

Recommended Posts

death walk not working once killed it doesnt seem to equip items and goes back it banks the items and then logs out and ends the script its self would class this as flawless if the deathwalk worked properly

Can you please report the deathwalk errors in the bug report format found at the front page of this topic?

Share this post


Link to post
Share on other sites

Flawless script - except whenever the bot dies, it just keeps running north until it gets stuck in Lumbridges cow field. Then it walk south and north repeatedly...

 

This looked so great...

Can you please please give me the bug report format when its deathwalking? I can't seem to be able to recreate the bug. Sorry for the inconvenience

Share this post


Link to post
Share on other sites

Seriously fuck this bot, it's gonna get me banned bigtime. I left this on overnight, and woke up to find both accounts logged out, standing at a bank. The log said something like "can not find food tunanot found" (tunanot was one word). It had collected about 400 dbones and hides during the night, but logged out at like 2AM, so it ran like 5 hours before crashing.

 

My other account was also standing in the bank with the same problem, "can not find food tunanot found". This one had collected like 200 bones and hides.

 

The food (tuna) is in the FIRST slot of an unscrollable bank!!

 

I did the mistake by running this bot AGAIN while I was out. I come home now and find one logged out, saying food wasn't found, and the other standing idle in wild? 

Stay away from this bot guys until OP has fixed it, it has major difficulties.

 

31JBRTE.png

Share this post


Link to post
Share on other sites

@jssjfb

 

Bug report format:

Did you delete hooks.dat? (Y/N)
Using looking glass? (Y/N) :
Are RuneScape servers currently experiencing DDoS attacks? (Y/N) :
Screenshot of client debug :
Screenshot of script stack trace ( Do Script>Print Script Stack Trace 4 times) :
Time ran, if available :
Problem description :

 

Follow that format

Edited by modulusfrank12

Share this post


Link to post
Share on other sites

Did you delete hooks.dat?: Yes
Using looking glass?: No
Are RuneScape servers currently experiencing DDoS attacks?: No
Screenshot of client debug: ^
Screenshot of script stack trace ( Do Script>Print Script Stack Trace 4 times) :

[17:09:07] In combat[17:09:56] Looting[17:09:56] Looting in combat[17:09:56] Finding items[17:09:56] In combat pick up loot[17:09:56] Lootingx.5[17:09:56] Inventory is full[17:09:56] Using looting bag[17:10:04] Using looting bag[17:10:08] Fail safe close loot bag[17:10:16] Fail safe close loot bag[17:10:16] Lootingx2[17:10:17] Lootingx.5[17:10:17] Loot not onscreen[17:10:17] Walking to loot[17:10:22] Lootingx2[17:10:24] Looting[17:10:24] Looting in combat[17:10:24] Finding items[17:10:24] In combat pick up loot[17:10:24] Lootingx.5[17:10:24] Inventory is full[17:10:24] Using looting bag[17:10:29] FoundSaradomin staff[17:10:29] FoundSaradomin staff[17:10:29] Enemy player detected! Entered DEFCON 1, getting out of danger[17:10:29] FoundSaradomin staff[17:10:29] Attemtping to teleport with ROD AND GAMES[17:10:29] Walking to level twenty tile[17:10:32] Using looting bag[17:10:38] Fail safe close loot bag[17:12:10] Disabled all randoms.[17:13:42] Script Stack Trace:[17:13:42]  org.tribot.api2007.NPCs.getAll(tl:108)[17:13:42]  org.tribot.api2007.NPCs.find(tl:137)[17:13:42]  scripts.sbf.combat.a.l.F(Loot.java:173)[17:13:42]  scripts.sbf.combat.a.l.H(Loot.java:261)[17:13:42]  scripts.sbf.combat.a.l.a(Loot.java:395)[17:13:42]  scripts.sbf.combat.a.l.i(Loot.java:415)[17:13:42]  scripts.sbf.a.d.i(ActionExecutionHandler.java:17)[17:13:42]  scripts.sbf.c.v.i(State.java:23)[17:13:42]  scripts.sbf.a.u.i(StateExecutionHandler.java:27)[17:13:42]  scripts.sbf.e.g.i(Init.java:72)[17:13:42]  scripts.sbf.e.d.i(Manager.java:331)[17:13:42]  scripts.GDK.run(GDK.java:119)[17:13:42]  java.lang.Thread.run(Thread.java:745)[17:13:47] Script Stack Trace:[17:13:47]  org.tribot.api2007.NPCs.getAll(tl:108)[17:13:47]  org.tribot.api2007.NPCs.find(tl:137)[17:13:47]  scripts.sbf.combat.a.l.F(Loot.java:173)[17:13:47]  scripts.sbf.combat.a.l.H(Loot.java:261)[17:13:47]  scripts.sbf.combat.a.l.a(Loot.java:395)[17:13:47]  scripts.sbf.combat.a.l.i(Loot.java:415)[17:13:47]  scripts.sbf.a.d.i(ActionExecutionHandler.java:17)[17:13:47]  scripts.sbf.c.v.i(State.java:23)[17:13:47]  scripts.sbf.a.u.i(StateExecutionHandler.java:27)[17:13:47]  scripts.sbf.e.g.i(Init.java:72)[17:13:47]  scripts.sbf.e.d.i(Manager.java:331)[17:13:47]  scripts.GDK.run(GDK.java:119)[17:13:47]  java.lang.Thread.run(Thread.java:745)[17:13:49] Script Stack Trace:[17:13:49]  org.tribot.api2007.NPCs.getAll(tl:108)[17:13:49]  org.tribot.api2007.NPCs.find(tl:137)[17:13:49]  scripts.sbf.combat.a.l.F(Loot.java:173)[17:13:49]  scripts.sbf.combat.a.l.H(Loot.java:261)[17:13:49]  scripts.sbf.combat.a.l.a(Loot.java:395)[17:13:49]  scripts.sbf.combat.a.l.i(Loot.java:415)[17:13:49]  scripts.sbf.a.d.i(ActionExecutionHandler.java:17)[17:13:49]  scripts.sbf.c.v.i(State.java:23)[17:13:49]  scripts.sbf.a.u.i(StateExecutionHandler.java:27)[17:13:49]  scripts.sbf.e.g.i(Init.java:72)[17:13:49]  scripts.sbf.e.d.i(Manager.java:331)[17:13:49]  scripts.GDK.run(GDK.java:119)[17:13:49]  java.lang.Thread.run(Thread.java:745)[17:13:51] Script Stack Trace:[17:13:51]  org.tribot.api2007.NPCs.getAll(tl:108)[17:13:51]  org.tribot.api2007.NPCs.find(tl:137)[17:13:51]  scripts.sbf.combat.a.l.F(Loot.java:173)[17:13:51]  scripts.sbf.combat.a.l.H(Loot.java:261)[17:13:51]  scripts.sbf.combat.a.l.a(Loot.java:395)[17:13:51]  scripts.sbf.combat.a.l.i(Loot.java:415)[17:13:51]  scripts.sbf.a.d.i(ActionExecutionHandler.java:17)[17:13:51]  scripts.sbf.c.v.i(State.java:23)[17:13:51]  scripts.sbf.a.u.i(StateExecutionHandler.java:27)[17:13:51]  scripts.sbf.e.g.i(Init.java:72)[17:13:51]  scripts.sbf.e.d.i(Manager.java:331)[17:13:51]  scripts.GDK.run(GDK.java:119)[17:13:51]  java.lang.Thread.run(Thread.java:745)

Time ran, if available : ~3 hours
Problem description : The bot dies, then walks to nowhereland (Lumbridge cowfarm if spawn point is in lumbridge, or varrock west bank if spawn point is in falador), then regears, then says food was not found and stops the script. I think there's something wrong in your "Custom" food option. If I enter "Tuna", then the debug will tell me ""tunanot" found". Why is it saying "tunanot" instead of "tuna not" ? It's like the user input get combined with something else, and that's what causing the problem.

Share this post


Link to post
Share on other sites

Update is pending, repo must be down

Already got all my bots banned and I think it's because of the bugs you had. I don't blame you, no scripts are perfect and botting is always risky. I'm working on more accounts though and will use this script when update is complete.

 

(I've made probably 15m on 3 accs with your script so I'm not sad!)

Edited by jssjfb

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 14 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...