Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Usa

[ABC2] USA Lava Dragons [Multiple Spots][Anti-PK][Trident]

Recommended Posts

5 hours ago, delsolhbc said:

Just bought the script. Can't get it to run at all. just sits there. Doesn't even say anything in the debug.

 

Says "When traveling to level 30 wilderness we will use free_to_play worlds" and then does nothing.

Are you running on LG?

Do you have the required items? Did you set your equipment tab? What are your GUI settings?

Share this post


Link to post
Share on other sites
1 hour ago, delsolhbc said:

I got the script to run. However, upon returning to the bank from the wilderness it gets stuck at like 28 wilderness for some reason. Not sure why. But my guess is sometimes it misclicks the glory and then just sits there in the wilderness with a full inventory

It will also on occasion get stuck while hopping worlds. I havnt been able to run the script for more then 2 hours without it bugging out.

I dont use looking glass.

Share this post


Link to post
Share on other sites
Guest

How is this bot working? I'm looking to run this on my account, can it be left alone for hours or will it be stuck doing nothing? Please let me know.

Share this post


Link to post
Share on other sites

Hi, I just purchased this script to use, it isn't working for me at all, I firstly ran into a issue with it failing banking, i then realised the items it needed had to be in the bank, Problem sorted I thought... time for it ot make me some money. But nope, it teleports me into the wildy, and then theirs a player, it logs out to evade the player, switches world, logs in, logs out switches world, and continues to do this  for 3 minutes, the GUI then says banking, and it isn't doing anything at all.  I help it out by teleporting to edgeville, it opens the bank up, and all of a sudden.. Failed banking repeatidly till it crashed.

Share this post


Link to post
Share on other sites
20 hours ago, IdleGamer said:

@Usa

Do you have any idea on how i can resolve my issues? 

It should tell you what it is missing from the bank?

Did you set your equipment equipment tab in the GUI, it should include an anti-dragon shield

Share this post


Link to post
Share on other sites
9 minutes ago, Usa said:

It should tell you what it is missing from the bank?

Did you set your equipment equipment tab in the GUI, it should include an anti-dragon shield

I had sorted the issue in regards to it collecting items out the bank to go on the trip, however, it fails to even make it to lava dragons, it either gets stuck in a evading loop in which it evades by world hopping continiously, before then rebanking and running into the same issue, until elm's hit me, it then doesn't eat my chosen food despite taking them out the bank, and just dies. Haven't even managed to get it to get to the lava dragons as of yet

Share this post


Link to post
Share on other sites

Just like to say a big shout out to USA for updating the script, It has ran incredibly well for me, i've had the odd death, but think that's from evading pvper's whilst looting, logging into a new world getting hit by a dragon and then a pvp'er logging in and killing me, not much can be done about this, but ran over 10 hours straight, its completely stable, is insanely good at evading! and decent money, the magic xp adds up quite nicely too. Just crossing my fingers for those visages to come rolling in.

Share this post


Link to post
Share on other sites
Guest

Hi,

I just started using the USA Lava Dragon Bot script, and worked for a couple days. However, when I use it now the total time is in the months/years, and the script never moves past the action "GUI". Any help? Is this just because it hasn't been updated yet? Thanks!

Share this post


Link to post
Share on other sites

few qualms I had with the bot:

1. I think it should have an option to save x amount of food for the trip back, so that it can deal with mainly monsters for low levels and potential pkers (gives a slight chance).

2.  since you can track the kills and since you can limit your trip by the number of mind runes you have, why not be able to limit the trip by the number of kills too? 

3. burning amulet support 

4. does this support recharging trident?

5. the log-out thing it does at lava drags is amazing, I wish it could do that for the trip there and back, as that's my main cause for deaths. I know there's the option to go to non-membs worlds for lowered risk, but I carry an occult and smoke battlestaff which makes it risky if I die.

6. stamina potion support 

7. A smoother break mode? Is that possible, as in like detecting the breaks setup, and making the break system smoother, by logging out after a kill instead of just after a set time. So like if you get to the part where the bot is told to log out, check whether or not the character is in combat. If it is, wait until the condition of picking up a lava shard, because that'll mean you've picked up everything else and that you've gotten the kill.

8. Correct me if I'm wrong but because of the spawn point of the burning amulet, the bot logs out too frequently at certain locations for the dragon killing, because it thinks there's people about to come but they're just trying to go to revenant caves

9. Preferred world(s) support

10. antifire support so there's no chance of dying from lava drags when you're running there maybe

11. I wanted to check out your statistics page but it loaded data starting from 2016 and there was a lot of data, causing my computer to slow down. I just wanted to see the recent stats and usage 

12. maybe since it can detect the equipment people are wearing, use it so that only teleport if the other player has ______ (ancient staff, rune crossbow, etc), as i noticed sometimes I'd hop even though the player had nothing on them.

 

Otherwise, this script is pretty great! Nice job. I made it sound like there were a lot of issues, but they're mostly just small potential improvements

edit: #5, the battlestaff and occult protect over still, so nvm 

edit: it glitches on world select when hopping sometimes, it just hovers over and keeps trying to select a world, which sucks since you need to babysit it.

Edited by ic3blitz

Share this post


Link to post
Share on other sites

@Usa

[07:31:17] java.lang.ClassCastException: java.lang.Long cannot be cast to java.lang.Integer
[07:31:17] 	at org.tribot.api2007.types.RSObject.getAllTiles(mh:633)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.h.l(PathObjectHandler.java:369)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.h.accept(PathObjectHandler.java:352)
[07:31:17] 	at org.tribot.api2007.Objects.Co(al:359)
[07:31:17] 	at org.tribot.api2007.Objects.getAllIn(al:26)
[07:31:17] 	at org.tribot.api2007.Objects.getAll(al:713)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.f.l(PathObjectHandler.java:305)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.f.l(PathObjectHandler.java:172)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.z.l(WalkerEngine.java:144)
[07:31:17] 	at scripts.webwalker_logic.c.l(WebWalker.java:178)
[07:31:17] 	at scripts.webwalker_logic.c.a(WebWalker.java:158)
[07:31:17] 	at scripts.usa.api2007.s.l(Walking.java:45)
[07:31:17] 	at scripts.usa.api2007.xa.I(Banking.java:40)
[07:31:17] 	at scripts.Lava.UsaLavaDragons.A(UsaLavaDragons.java:1013)
[07:31:17] 	at scripts.Lava.UsaLavaDragons.run(UsaLavaDragons.java:362)
[07:31:17] 	at java.lang.Thread.run(Thread.java:748)

This happens when it tried to interact with lumbridge stairs after dying.

Share this post


Link to post
Share on other sites
3 hours ago, kristjanit said:

@Usa

[07:31:17] java.lang.ClassCastException: java.lang.Long cannot be cast to java.lang.Integer
[07:31:17] 	at org.tribot.api2007.types.RSObject.getAllTiles(mh:633)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.h.l(PathObjectHandler.java:369)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.h.accept(PathObjectHandler.java:352)
[07:31:17] 	at org.tribot.api2007.Objects.Co(al:359)
[07:31:17] 	at org.tribot.api2007.Objects.getAllIn(al:26)
[07:31:17] 	at org.tribot.api2007.Objects.getAll(al:713)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.f.l(PathObjectHandler.java:305)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.interaction_handling.f.l(PathObjectHandler.java:172)
[07:31:17] 	at scripts.webwalker_logic.local.walker_engine.z.l(WalkerEngine.java:144)
[07:31:17] 	at scripts.webwalker_logic.c.l(WebWalker.java:178)
[07:31:17] 	at scripts.webwalker_logic.c.a(WebWalker.java:158)
[07:31:17] 	at scripts.usa.api2007.s.l(Walking.java:45)
[07:31:17] 	at scripts.usa.api2007.xa.I(Banking.java:40)
[07:31:17] 	at scripts.Lava.UsaLavaDragons.A(UsaLavaDragons.java:1013)
[07:31:17] 	at scripts.Lava.UsaLavaDragons.run(UsaLavaDragons.java:362)
[07:31:17] 	at java.lang.Thread.run(Thread.java:748)

This happens when it tried to interact with lumbridge stairs after dying.

yup, this happens to me too, and script then ends.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 14 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...