Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Aropupu

[ABCL 10] [ABC2] aSmither [CANNONBALLS/HYBRID] [COAL BAG] [RING OF FORGING]

Recommended Posts

On 2/25/2016 at 11:41 AM, Aropupu said:
 

- Smithing also has an automatic mode that will smith the best possible items all the time and it will also use all the bars in your inventory. 

 

 

automatic? yes it smiths thru the different items but it doesnt smith to next bar type. am i missing something??

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/7/2020 at 1:03 AM, Sferics said:

Smelts gold bars instead of steel when asked to smelt steel

Seems to be working without any issues. I do have an idea what could be causing your issue so I updated a failsafe that hopefully resolves it. Restart script without using the rerun button to update it. Also added additional debug information (if script detects something is wrong) when smelting bars so if you do encounter issues in the future, please do provide full client debug information. With limited information I can only guess what's wrong.

Edited by Aropupu

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Jonazun said:

smelting options kindoff messed up just clicking the wrong bar

Seems to be working without any issues. Please do give more information. What are you smelting?

Also send me full client debug and bot debug information after the issue happens. You can copypaste both by right-clicking on their tab and clicking Copy to Clipboard:
  > If you don't see debug loggers in Tribot 11, you have to open them first. There's a button to open them in the upper right corner.
DzdslQF.png

Edited by Aropupu

Share this post


Link to post
Share on other sites
3 hours ago, Aropupu said:

Seems to be working without any issues. Please do give more information. What are you smelting?

Also send me full client debug and bot debug information after the issue happens. You can copypaste both by right-clicking on their tab and clicking Copy to Clipboard:
  > If you don't see debug loggers in Tribot 11, you have to open them first. There's a button to open them in the upper right corner.
DzdslQF.png

So it is when it's trying to smelt silver bars it goes to make steel bars, see below:

 

[2020-07-20 07:17:52] Downloading script 'aSmither'.
[2020-07-20 07:17:54] Script Started: aSmither.
[2020-07-20 07:17:58] Login bot started.
[2020-07-20 07:17:58] Login Bot: Login...
[2020-07-20 07:18:21] Login bot succeeded.
[2020-07-20 07:18:22] Login bot started.
[2020-07-20 07:18:22] Login Bot: Login...
[2020-07-20 07:18:23] Login bot succeeded.
[2020-07-20 07:18:46] ff Silver bar - <col=ff9040>Steel bar</col>

Share this post


Link to post
Share on other sites
Posted (edited)
52 minutes ago, Jonazun said:

So it is when it's trying to smelt silver bars it goes to make steel bars, see below:

Thank you for providing more information. Was able to reproduce the issue with silver bars. I updated a fix in the latest version of the script.

In Tribot 11 to update a script you need to use the refresh button or just restart tribot completely.

Edited by Aropupu

Share this post


Link to post
Share on other sites
3 minutes ago, Aropupu said:

Thank you for providing more information. Was able to reproduce the issue with silver bars. I updated a fix in the latest version of the script.

In Tribot 11 to update a script you need to use the refresh button or just restart tribot completely.

Thanks for the quick fix - also where is the restore button i have been clsoing a restarting tribot 11 which can be annoying and was looking for a way around this?

Share this post


Link to post
Share on other sites
Just now, Jonazun said:

Thanks for the quick fix - also where is the restore button i have been clsoing a restarting tribot 11 which can be annoying and was looking for a way around this?

I believe you need to enable Developer mode in Tribot settings for it to appear.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...