Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

montreal176

Monts Tiara Crafter

Recommended Posts

Hey, Thanks for checking out of my third release for tribot, In the requests section, I saw a request for a Tiara Crafter and decided to make one!

If any bugs are noticed, or there are things that the script can improve on, don't hesitate to post on this thread.

 

Features

- Create all elemental Tiaras

- Basic gui and paint

- Some antiban

- Custom mouse speeds

 

Source

https://github.com/jroy8/TribotScripting/tree/master/src/scripts/MontsTiaraCrafter

- As always, comments on code are appreciated.

 

Repository link

 

 

 

Edited by montreal176

Share this post


Link to post
Share on other sites
On 6/4/2016 at 4:37 PM, rofldogs123 said:

Something i noticed, it will accidentally double click a talisman and not use it on the altar. Worked fine, could be a little faster (adjustable mouse speed) and im not sure if you have any anti ban implemented.

Working on the talisman fix now, And when you say it could be faster, you mean in creating the Tiaras?

Share this post


Link to post
Share on other sites
On 6/6/2016 at 4:49 PM, montreal176 said:

Update v 1.1 - 

 Updated the gui to include an adjustable mouse speed, Default is 110, Min is 70 and Max is 150, if requested values can change.

Also i went ahead and added some Antiban for now, will add more as time goes on.

Cool beans, will try it out

EDIT: After testing it again, still sometimes double clicks and fails crafting. I would add a little bit better camera rotation, only moves if it needs it to and it begins to click on things that the camera can't see, ex. exit portal. I would fix GUI placement, its right on top of private messages and hard to see because of it

Edited by rofldogs123
added input

Share this post


Link to post
Share on other sites
7 hours ago, rofldogs123 said:

Cool beans, will try it out

EDIT: After testing it again, still sometimes double clicks and fails crafting. I would add a little bit better camera rotation, only moves if it needs it to and it begins to click on things that the camera can't see, ex. exit portal. I would fix GUI placement, its right on top of private messages and hard to see because of it

Hm, it shouldn't ever double-click and fail, are you using a quick machine? or quite a slow one? As i crafted over 700 tiaras with no double click, as for the camera rotation, i will see what i can do about that, And when you say GUI placement, do you mean the paint?

 

Edited by montreal176

Share this post


Link to post
Share on other sites
7 hours ago, rofldogs123 said:

Cool beans, will try it out

EDIT: After testing it again, still sometimes double clicks and fails crafting. I would add a little bit better camera rotation, only moves if it needs it to and it begins to click on things that the camera can't see, ex. exit portal. I would fix GUI placement, its right on top of private messages and hard to see because of it

I have updated the script to include better camera movement when crafting tiaras, and exiting the portal. Also i tried to address the double click issue, but i was unsuccessful in re-producing the issue, However i only tested my new fixed with the water and air altar, if you find a problem with them, please post and let me know which altar you are currently using so i can try to re-produce the issue.

 

Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Proggie: b5e4e5def0.jpg

 

Script stopped saying that it ran out materials while I still had some.

 

EDIT: Script freaked out when dealing with random, it would go to a random's previous location and then later start walking to look for it. Had to manually dismiss it

Edited by rofldogs123

Share this post


Link to post
Share on other sites
 

Proggie: b5e4e5def0.jpg

 

Script stopped saying that it ran out materials while I still had some.

 

EDIT: Script freaked out when dealing with random, it would go to a random's previous location and then later start walking to look for it. Had to manually dismiss it

I noticed the random thing in another script yesterday, Afaik scripts don't deal with random's client does. You have probably done this, but make sure you have "Dismiss randoms" checked in File -> Settings.

As for the banking error, I just fixed that. My bad, The problem was the script wasn't waiting until bank items were loaded, shouldn't happen again.

Edited by montreal176

Share this post


Link to post
Share on other sites
Posted (edited)

running earth atm seems to be working fine except it doesnt pull out normal tiaras it just restocks on earth talismans. i wish it was fully updated bit worried about the antiban but ill just have to keep stopping and starting or pausing at the bank and doing part of it manually.

 

EDIT

seems to have fixed itself on that withdrawl issue and is now running pretty good but now has walked off behind the training area and got stuck inbetween that and the musem.

Edited by reidy1234

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...