Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sign in to follow this  
Guest

TRiBot crashes while loading an OldSchool client on Ubuntu

Recommended Posts

Guest

I'm using a VPS and am having trouble getting TRiBot to work on it. TRiBot will start up fine and I'll log in and wait for the main program to appear. When I hit New Client it'll try to start up a new client, but somewhere in the loading process it'll stop entirely. The program shuts down and there is no error message. This is not a fixed point. Sometimes it'll crash while downloading the runescape.jar, sometimes it'll crash while loading classes. Once it even managed to start a runescape client but it crashed before it finished loading.

I've since tried running with a heap size of 256MB which seemed to have no effect. Other versions of Java didn't seem to work at all.

Considering that it doesn't crash at a specific point but rather just 'after a while' it seems like it's being shutdown by the OS itself for eating too many resources. Then again, this is a gut feeling and I've never worked with Linux before, so feel free to disregard.

Operating system: Ubuntu 16.04.2 x64

VPS: DigitalOcean, 512MB RAM, Single CPU core

Java version: http://i.imgur.com/ZAxZDaO.png

 

I've tried googling the issue but couldn't find anyone with the same problems. Does anyone have any suggestions on how to fix it?

Share this post


Link to post
Share on other sites
Guest

Running in console mode doesn't seem to work or show any additional information.

Share this post


Link to post
Share on other sites
Guest

The loader window disappears the moment TRiBot is started up. It does seem to show some extra information but it's finished before I can read anything.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Failed4life
      Stock: Message for info - Restocks every few days
      Accepted Payment: Crypto Only - Preferably **Coinbase** (Preferred coin is USD Coin, but will accept most)
      Non-Coinbase payments will require confirmations to pass
      I will not go first
      Bulk Incentives available:
      $0.01/m off per 100m starting at 200m
      Max discount reached at 500m = $0.04/m off
      Example: 
      200m = $0.01/m off
      300m = $0.02/m off
      Discord: Failed4life#3370
      Unique ID: 162656616380891136
      Comment your Discord name after adding my Discord!
    • By jerrycan314
      when i open a tribot client it crashes and i get this error :c

      #
      # A fatal error has been detected by the Java Runtime Environment:
      #
      #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x7a0e3d9d, pid=1608, tid=0x00000e54
      #
      # JRE version: Java(TM) SE Runtime Environment (8.0_251-b08) (build 1.8.0_251-b08)
      # Java VM: Java HotSpot(TM) Client VM (25.251-b08 mixed mode windows-x86 )
      # Problematic frame:
      # C  [atiglpxx.dll+0x3d9d]
      #
    • By Fluffee
      Fluffee's Server Setup 3.0
      As some of you may know, I released an automated server setup script a little over a year ago. Albeit that script worked well, I was never fully satisfied with it, as I found it to be kind of messy to use. As a result, I rewrote the script, and restructured it, to add more, and stronger support for the different versions of Debian, the different versions of CentOS and the different versions of Ubuntu. However, with so many different Operating Systems being supported, and many different server providers having different setups, it's hard for me to test every possible scenario on my own. Which is why I've been privately handing this script out, and am now publicly looking for help.

      What does the script do?
      Similar to my previous setup script, this script changes the SSH port and creates a new user for connecting and using the server and disables root SSH connections; it installs the latest version of TightVNC Server (1.3.10) and sets that up with the desired port and password. It installs JDK 102 (32 or 64 bit depending on the OS), and installs TRiBot and OSBuddy and sets up the appropriate .jar file associations.
      What operating systems does it support?
      - CentOS (6.x and 7.x) (32 and 64 bit)
      - Debian (7.x and 8.x) (32 and 64 bit)
      - Ubuntu (12.x, 14.x and 16.x) (32 and 64 bit)
      Does it work?
      As far as I know, yes it does in fact work, and it works well if I might add. However, given that I can't test every possible setup, there is the potential for differences and issues
      How do I run the script?
      Login as root to a fresh VPS/dedi running one of the supported operating systems. From there run the commands listed below and follow the onscreen instructions. For those who would like to see the script's code, it can be found on my bitbucket here. The commands to run are as follows:
      wget --no-check-cert https://bitbucket.org/teamfluffee/fluffees-server-setup/raw/add-shared-functions/fluffees-server-setup.sh && chmod +x fluffees-server-setup.sh && bash fluffees-server-setup.sh -v Version History
       
    • By Depaul
      So I recently let my brother use my tribot account, I had to hand hold him through everything.
      he bots for what he says is like 5 hours based on levels closer I would say more like 10 hours over 2 days. Banned.

      I've botted for a fair bit on self made scripts. recently using the same one he was using a (premium),  I suicide botted a fresh account 12 hours day one nothing.
    • By odealo
      ODEALO IS AN EU-BASED COMPANY OPERATING SINCE 2017   IT SECURES HUNDREDS OF TRANSACTIONS EVERY DAY MAKING IT ONE OF THE SAFEST MARKETPLACES FOR MMO CURRENCIES, ITEMS, AND SERVICES   CHECK OUR RUNESCAPE OLDSCHOOL MARKETPLACE FOR THE MOST UP-TO-DATE OFFER AND PRICING ON OSRS GOLD     OR ADD US ON DISCORD: ODEALO#0611   INTERESTED IN SELLING ON ODEALO? WE OFFER: ☑ THE LOWEST PER TRANSACTION FEES ☑ WITHDRAWALS VIA PAYPAL, SKRILL, WEBMONEY ☑ FULL CHARGEBACK PROTECTION ☑ INTUITIVE OFFER MANAGEMENT TOOLS ☑ SPECIAL TREATS FOR SUPERSELLERS
    • By Dakers011
      Over 10,000 RuneScapers Have Used MMOearn Since 2016
       

       
      Our Goal Is To Save You Money!
      Buy RuneScape Gold From MMOearn Now!
      No One Can Beat Our Price, Free!
       
       
    • By RSGM Sales
      *WE HAVE NO HIDDEN CHECKOUT FEES WHEN U PURCHASE GOLD!* MANY OTHER SITES WILL CHARGE YOU UP TO 5% EXTRA BUT WILL ONLY DISPLAY THIS WHEN YOU ARE PAYING. WITH RUNESCAPEGOLDMARKT YOU PAY THE PRICE YOU SEE. NOT A CENT MORE!   Moderator Partnered with Montreal
    • By Fluffee
      How to Run Most Applications Through a Proxy on both Windows and Linux
      Windows Instructions
      Note: Chrome and Firefox portable do not work with WideCap.
      1. Download WideCap from here (http://widecap.ru/en/download/)
      2. Run through the installer, and launch WideCap, you should see this screen.

      3.Go ahead and click on Settings (First option under the Widecap section on the left hand side). Then uncheck the box that says Run with system startup.

      4. Now go ahead and click on New proxy (First option under the proxies section on the left hand side).
      5.You should see this screen, in the top field enter the IP address and port (IP:Port format). Confirm that the protocol is set to SOCKS v5 (which is the default), and tick the box for Authentication if necessary. If using an authenticated proxy, enter your username in the login field, and obviously your password in the password field. Then hit the Create New button, next to Chain, and type in a name for your Proxy, then Hit OK

      6. Now that you're back to the main screen, click on the Proxy List section (Second option under the proxies section on the left hand side). Right click on your newly added proxy, and click check selected, to make sure you entered all the information correctly. If the status field rolls over to OK, you're good to go, and can move on to the next step

      7. Find WideCap in your System tray, right click, and uncheck the box that says Enable Widecap.

      8. Click on View Programs (Second option under the Programs section on the left hand side). Then drag and drop the icon for the application you want to proxify (run behind a proxy) into WideCap. WideCap supports the proxifying of both .exe and .jar files!

      9. Right Click on your newly added program, and click on Modify Application, you should see a similar screen depending on what you added. Then click on Create New... (to create a new rule)

      10. In the Chain tab, select the Proxy Chain you created earlier, then under the Main tab, give your new rule a name and hit OK. Then Hit OK again on the modify Application screen.

      11. Hit Apply and OK in the main window of WideCap, and then find it in your System Tray again, but this time click the box to Enable Widecap
      12.Open your Proxified application, and check to see if the proxy worked! If your IP is changed, congrats, you've got WideCap working!
      Linux Instructions (Based off of a Debian Installation)
      1. Open a new terminal and run this command
      sudo apt-get update && sudo apt-get install -y proxychains 2. Now that proxychains is installed, we're going to go ahead and create a user specific configuration file. To do this, we'll make a directory, then copy the standard proxychains configuration file to it and change the ownership of the configuration file to your user. Run the command below as your user.
      mkdir ~/.proxychains/ && cp /etc/proxychains.conf ~/.proxychains/proxychains.conf && sudo chown ${USER:=$(/usr/bin/id -run)} $HOME/.proxychains/proxychains.conf && sudo chgrp ${USER:=$(/usr/bin/id -run)} $HOME/.proxychains/proxychains.confroxychains.conf 3. Once the command is finished, open the proxychains config file in your favorite Linux text editor, for ease of use, I'm going to use nano. To install nano run this command
      sudo apt-get install -y nano To edit the proxychains config file, with nano, run this command
      nano ~/.proxychains/proxychains.conf 4. Now, what you'll want to do is scroll all the way down to the bottom, and you should see something like this

      That last line that says
      socks4    127.0.0.1    9050
      That's the line we'll be editing. Firstly, we'll go ahead and erase everything on that line, don't worry we'll put it back. The format for the configuration file is
      Proxy Type(lowercase) (tab) IP address (tab) Port (tab) Username (tab) Password
      Therefore if your proxy was a Socks5 proxy, with an IP of 192.168.1.1, a port of 1080, a username of Fluffee and a password of TRiBot, your final line would look like this:
      socks5    192.168.1.1    1080    Fluffee    TRiBot
      So, go ahead and modify your last line to fit your own proxy and then hit Control+X to exit, and then hit Y to save (instructions are based off of using nano to edit the file).
      5. Proxychains is now setup, but how do you use it? Go ahead and VNC into your Server and open a terminal, or open a Terminal inside your Desktop Environment (if using Linux installed on a PC). From there run the command proxychains followed by the application you would like to run, or the path to the application. For example, try running, if you have Firefox installed:
      proxychains firefox Then navigate to an IP checking website, and see if your proxy worked!
      That concludes the tutorial on how to use a proxy with Oldschool or any browser, on both Linux and Windows. If you have any questions feel free to post in the comments!
    • By Fishies
      I'm having an issue on my linux server where I connect with VNC, startup the client and script and everything works fine. Even when I close out of the VNC my bot continues to run fine, but when I log back into the VNC (to checkup or whatever) it crashes the client and logs the bot out. I have all power management settings turned off, and have no idea why this is happening or how to fix it. It dosn't disable my farm, but is extremely annoying having to restart the client every time I want to check up on the bot. Thanks!
    • Guest
      By Guest
      I've nearly got TRiBot running on an Ubuntu machine but have run into an error with the loader.  When I run the loader for the first time and it populates the dependencies folder, the file togl.dll get's downloaded instead of libTOGL.so which TRiBot.jar eventually looks for.  Error looks like this:
      Loading TOGL Loading: /home/<user>/.tribot/dependancies/libTOGL.so Exception in thread "AWT-EventQueue-1" java.lang.UnsatisfiedLinkError: Can't load library /home/<user>/.tribot/dependancies/ibTOGL.so Inside my dependencies folder there's a file called togl.dll.  The bug report forum says I need to post here before I can post there.
  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...