Jump to content

When I try to use LG I get a message saying "Must run tribute using Java JDK in order to use Looking Glass"


Recommended Posts

When I try to use LG I get a message saying "Must run tribute using Java JDK in order to use Looking Glass". I just downloaded the most up to date version of java so I'm not sure why I'm getting this error message. I also have the oars client up in the background. Can someone please help me solve this so I can start botting a bit more safely?

 

@iFluffee Maybe you can help me out for the 100th time? haha)

Edited by pktilldeath
Link to post
Share on other sites
  • Similar Content

    • By jh1n3s
      Has anyone been able to fix this? I keep getting told to go use OSBuddy. But I have all the good plugins on OpenOSRS.
      I am using the open-osrs shaded jar like it said to.
      It would totally change the game for me if I was able to use that client w/tribot without crashing every single time.
      Paying top dollar for whoever can assist and fix.
    • By lau1992
      Hi!
      I was playing around with a VM as it is easier to manage multiple instances for me personally on my local machine (I do not use proxies, but use a vpn). But I can't get LG to work... On my local machine everything runs smooth, but on the VM it always says "looking for OSRS client" (you know the message). I have the same configuration as on my local machine.
      Is there a configuration property to be set on VM level or something? 
      All suggestions are welcome!
      --------Specs of the VM:
      - Clean install with VMware Workstation 15 Player running Windows 7 Ultimate (also tested with Windows 10 with VirtualBox)
      - Java JDK 8u251
      - OSBuddy.jar
      - Tribot loader 4.0.4

    • By ah12ims1
      as the title suggests, it works, but my issue is that for me it only works with OSbuddy. 
      this is what i have installed for java  
       
      however when i try and open the runelite (or open osrs) jar file i get this error 
      so, i inquired about what i should do to get RL or OPRS working, i installed JDK 11 (also 13 after to check if there was any diff, but none).
      this lead to RL working, but then my Tribot loader AND my OSB wouldnt load.
      my tribot loader didnt even give an error, it just didnt open, and my OSB gave this error 
       
      can someone please help me out, i just want to use tribot looking glass witrh runelite instead of OSB
    • By briareos2285
      Just got a new Windows 10 Home x64 Laptop. Going through my usual install method and finding that I cant get looking glass to work. I have followed a few "old" guides, because I cant find any that are more recent. I am installing Java SE Development Kit 8u251, I am choosing the x86 version since the only OSbuddy cross platform .jar  file is 32bit. Its worked fine in the past. I then open Osbuddy, and then Open Tribot. I leave it on the default Tribot Version of 10.24.1. I select the java version for Tribot to use to be the JDK and not the jre. I changed the Heap Size to 1024 MB and login. I minimize Osbuddy, then I click New Client(Looking Glass). The Screen goes to black and says " Waiting for a Runescape client.... currently waiting for a valid client. List of detected java applications below." and there is nothing Below. I also tried a backup method that used to work as well, which was to instead click New Client (Osbuddy) and then manually select the Osbuddy .jar file which would open up Osbuddy and Create a Looking Glass Tab that mirrored Osbuddy. This no longer happens either. Ive also deleted the Hooks and Caches using Naton's Java Executable. I have also defined the correct Paths in my Computers Environment Variables.
      Im at a loss for what to do. Any help greatly appreciated
    • By TRiLeZ
      This update includes:
      Fix OSBuddy LG input bug Fix updater exception Added error loading profile message to login-bot (Thanks @Todd) Prevent auto-relog from being typed in the client (Thanks @Todd) Comment out a pause in the clicking method (Thanks @Todd) Fix Prayer API (Thanks @Todd) To compensate VIP-E users for the downtime, all current VIP-E users (as of the time of extension) will be given an extension of 2 weeks. The extension will be applied sometime between 24 to 48 hours from now.
      A fix for RuneLite support is still in the works.
    • Guest
    • Guest
      By Guest
      could someone reply with all the steps to be able to use looking glass. i use to have a link to a forums with all the steps; however, it's saying i don't have permission to see it.
    • Guest
      By Guest
      I've setup a SOCKS5 proxy with tribot, and I want to bot on that IP address.
      Can I use the Looking Glass with the osbuddy client?
      I have noticed before using the looking glass feature, you have to wait for osbuddy to load to the login screen. Now I'm 100% sure while osbuddy is 'loading' its using my 'Main' IP address. Then I proceed to login with my bot user/pass and I suspect my main ip is linked with the bot account.

      So is there a way of using Looking Glass with a proxy? or do I have to use the build in Client supported by tribot?
       
       
    • By jermbywermby
      Is LG up yet?
    • By runescapeprodigy
      After finally getting LG to work after much trouble, I have had huge trouble getting any scripts to work. They keep gltiching and bugging out, i.e keep moving mosue forward and back, or will walk around and around rather than speaking to the tutorial guide the merely walk ontop of them than talking tothem. i did tutorial island myself but in the quests i.e the cooks assistant it keeps picking more and more pots or won´t fight chickens etc.
       
      I thought it may be some problem with how resolution was or something but nothing works. Anyone knows what scripts works? Paid or free, or what can be done to resolve this? 
       
      All i did is having the OSRS client open in the back ground windowed - and then the LG tribot client open, nothing else - and NO scripts works for me. Any way to resolve this? 
  • Our picks

    • Support for the gradle launcher is being dropped. Read more about the new launcher here.
      • 1 reply
    • What to expect from TRiBot moving forward.
      • 11 replies
    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
      • 40 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 13 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...