Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Einstein

Universal Woodcutter [Free]

Recommended Posts

YJfhXwp.jpg

 

Cuts (almost) any tree, (almost) anywhere.

 

Universal Woodcutter is a free woodcutting script with minimalist design and basic functionality.

It's very easy to use and the GUI can be configured within seconds.
 

Features:

  • Anti-Ban Compliance v2 fully implemented
  • Support for different types of trees
  • Bank or Drop the logs
  • Custom area: constructed around the player at start-up
  • Run-time information displayed in the paint

 

How to use:

  • Have axe in inventory
  • Start the script in the desired woodcutting area

 

Activate

 

dCzHL3Q.png

 

tZntnGl.png

 

 

 

 

Enjoy!

Activate

 

 

 

Edited by Einstein
  • Like 2

Share this post


Link to post
Share on other sites

Hey sir really liking the script, ran it for a few hours and absolutely awesome. I was just thinking though it could be really great if it just had a few more features. Is there any chance you could add some things like auto-muling, changing the axe when leveling up, maybe a progressive mode, some options for commonly cut areas to go to and the ability to save and load the gui settings? Also would it be possible to add a charity mode where I give all the logs I cut to some poor noob? Cool paint btw Onestone

  • Like 1

Share this post


Link to post
Share on other sites

Updated.

 

Summary:

  • Most common settings are auto-selected by default. You can start the script faster.

 

  • Paint overlay while the abc2 sleep is performed.

0pVU1Hs.png

 

  • Visual aid has been added to the woodcutting area. It's active during the GUI setup and when the player is moving.

bX75KQd.gif

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, ibanez0 said:

why does the bot just click and walk around everywhere.

I select the type of tree which is normal

banking

birdnests on

and select the radius..

it just walks all over the place randomly clicking

Make sure that the trees are contained within the highlighted area.

Share this post


Link to post
Share on other sites

been using this script for a couple days now I like its great havnt have an issue, the only thing tho when i check pick up bird nest and powerchop the bot drop bird nests as well and it would be nice to have progressif level option where I cut my trees to get 61 theres all 3 type of trees close to each other thanks great work :)

Share this post


Link to post
Share on other sites
7 hours ago, EasyMoneyCx said:

been using this script for a couple days now I like its great havnt have an issue, the only thing tho when i check pick up bird nest and powerchop the bot drop bird nests as well and it would be nice to have progressif level option where I cut my trees to get 61 theres all 3 type of trees close to each other thanks great work :)

I am aware of the bird nest bug. It will be patched soon.

Thanks!

Share this post


Link to post
Share on other sites
27 minutes ago, EasyMoneyCx said:

good shit bro i also tryed to fish shrimp at lumby with universal fisher, nothing happened you might want to check on this and for some reason my bots doesnt relog after a break i use looking glass, auto relog on OSB is not check so i am not to sure whats the problem.

Thanks,Have a nice day!

I think the re-log problem is a client bug. Also, please post the bug report on the script's thread.

Thanks!

Share this post


Link to post
Share on other sites
34 minutes ago, Diverting said:

Approaching the two hour mark, of cutting yews in camelot.  So far the only thing error I noticed was that even though I had a rune axe equipped it kept trying to find another axe in the bank. It even went as  far as withdrawing a steel axe to go cut some trees. 

Will patch this bug on the next release.

Thanks for the report!

Share this post


Link to post
Share on other sites
  • [16:03:00] Selected: drop oak
  • [16:03:00] java.lang.NullPointerException
  • [16:03:00] at org.tribot.api2007.types.RSObject.getModel(oi:496)
  • [16:03:00] at org.tribot.api.DynamicClicking.clickRSObject(ks:359)
  • [16:03:00] at org.tribot.api.DynamicClicking.clickRSObject(ks:231)
  • [16:03:00] at scripts.universalwoodcutter.d.e.J(Woodcutting.java:54)
  • [16:03:00] at scripts.universalwoodcutter.d.e.B(Woodcutting.java:34)
  • [16:03:00] at scripts.universalwoodcutter.UniversalWoodcutter.B(UniversalWoodcutter.java:58)
  • [16:03:00] at scripts.universalwoodcutter.UniversalWoodcutter.run(UniversalWoodcutter.java:49)
  • [16:03:00] at java.lang.Thread.run(Thread.java:745)
  • [16:03:01] Script Ended: Universal Woodcutter.
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
55 minutes ago, Duhstin said:
  • [16:03:00] Selected: drop oak
  • [16:03:00] java.lang.NullPointerException
  • [16:03:00] at org.tribot.api2007.types.RSObject.getModel(oi:496)
  • [16:03:00] at org.tribot.api.DynamicClicking.clickRSObject(ks:359)
  • [16:03:00] at org.tribot.api.DynamicClicking.clickRSObject(ks:231)
  • [16:03:00] at scripts.universalwoodcutter.d.e.J(Woodcutting.java:54)
  • [16:03:00] at scripts.universalwoodcutter.d.e.B(Woodcutting.java:34)
  • [16:03:00] at scripts.universalwoodcutter.UniversalWoodcutter.B(UniversalWoodcutter.java:58)
  • [16:03:00] at scripts.universalwoodcutter.UniversalWoodcutter.run(UniversalWoodcutter.java:49)
  • [16:03:00] at java.lang.Thread.run(Thread.java:745)
  • [16:03:01] Script Ended: Universal Woodcutter.

The code that generated the NPE is not contained within the script. I think this is a client bug.

Is this error recursive or it only happened once?

Thanks!

Share this post


Link to post
Share on other sites
9 hours ago, TristanWPA said:

Great script!

Beautiful visual guidance with the grid and paint ..   Just some feedback, the profit and xp counters are not working for me. Not a big deal, just thought I would let you know.

Thanks!

 

Will take a look at the counters.

Thanks!

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, user555 said:

I made a new account and when I start the script west of lumbridge, my charakter just walks to draynor bank, opens it and stays like this forever.

Do you have an axe visible in your inventory or bank?  .. This happened to me when my axe was already equipped prior to starting the script.. Worked great when I removed the axe from my hand and restarted with the axe in my inventory! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...