Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

TRiLeZ

TRiBot Release 9.400_0

Recommended Posts

2 minutes ago, theholyone said:

Instead of trying to replicate this consistently which I honestly don't think it's even possible now because of how random it is, finding a temporary patch that will fix the problem for now seems like a more logical choice.

 Ideal situation IMO would be to leave the client as is for the people who for some reason don't trigger the bug while leaving a separate beta version of tribot for those of us who are desperate for any strand of hope.

  

 

I agree with you 

Share this post


Link to post
Share on other sites
9 hours ago, Einstein said:

As long as software will be written by humans, bugs will remain a fact of life.

Re-writing code from the ground up is almost never a viable solution. The developers are aware of the gravity of the problem, and the bug will be patched as soon as they manage to find a way to consistently replicate it.

 

When a bug is difficult or impossible to track down, rewriting small parts of code can be an easier and quicker solution.

Judging by forum posts, some users with custom built break/login handlers aren't experiencing these issues.

Edited by contemporary

Share this post


Link to post
Share on other sites
42 minutes ago, contemporary said:

When a bug is difficult or impossible to track down, rewriting small parts of code can be an easier and quicker solution.

Judging by forum posts, some users with custom built break/login handlers aren't experiencing these issues.

I made my own login handler and it was still broken. Even tried using colours to detect if logged out. Can you link me some of these posts?

Edited by joe biden

Share this post


Link to post
Share on other sites

Would very much love it if we could get a confirmation on whether a separate beta version of the client is possible while we wait until this issue can be successfully recreated consistently.

( Separate not as in Developer release, because that doesn't support the built in client starter afaik )

I am not a programmer, but from my POV, if someone is out looking for a consistent way to replicate a bug, there should theoretically be a solution or a temp fix for problem already, and they are just trying to find a way to make it a perm fix.

@Fluffee

P.S this wouldn't of hurt so much if there wasn't a huge 700 - 1000k membership sale going on... ?

Edited by theholyone

Share this post


Link to post
Share on other sites

and the same no any respond for any fix or announce , yesterday i used a custom breaks for one script the break is work fine for the first 2 line but i don't know what happend next the client i go run for ever without stop .. the problem still exist even with custom breaks .

Share this post


Link to post
Share on other sites
On 8/2/2018 at 11:48 PM, contemporary said:

It might not trigger every break, but it's a major bug that happens often enough to disrupt botting significantly. Without babysitting, it's impossible to run multiple bots with breaks.

Let us know if we can help with providing additional information or testing, this bug really needs to be addressed seriously and squashed.

You can actually! See the information at the bottom of the post.

On 8/3/2018 at 8:29 AM, theholyone said:

Instead of trying to replicate this consistently which I honestly don't think it's even possible now because of how random it is, finding a temporary patch that will fix the problem for now seems like a more logical choice.

Ideal situation IMO would be to leave the client as is for the people who for some reason don't trigger the bug while leaving a separate beta version of tribot for those of us who are desperate for any strand of hope.

also it's been 14 days not 20 lol

Client starter is also broken, does not load correct worlds whether you put 301 or 1 as selected world, didn't realize this til now ?

I actually misspoke about the consistent replication, well actually I misunderstood. Todd is looking for a consistent way to replicate the bug, but that's only because he hasn't been able to replicate it at all. He's currently running over 15 accounts non stop on various break profiles, trying to get the bug to occur, and he's been doing this for days. He still hasn't seen the bug, which is why there hasn't been a fix.

I believe his new plan is to manually look through every line of code that was changed in the last update to see if there is anything obviously wrong, but I'm unsure how long that will take, as it depends on how much was changed with the last update

On 8/3/2018 at 5:36 PM, contemporary said:

When a bug is difficult or impossible to track down, rewriting small parts of code can be an easier and quicker solution.

Judging by forum posts, some users with custom built break/login handlers aren't experiencing these issues.

Todd isn't big on this idea. I would guess that the login bot/break handler, is more complicated than we think and rewriting it from the ground up could be a much bigger project.

On 8/4/2018 at 10:57 PM, theholyone said:

Would very much love it if we could get a confirmation on whether a separate beta version of the client is possible while we wait until this issue can be successfully recreated consistently.

( Separate not as in Developer release, because that doesn't support the built in client starter afaik )

I am not a programmer, but from my POV, if someone is out looking for a consistent way to replicate a bug, there should theoretically be a solution or a temp fix for problem already, and they are just trying to find a way to make it a perm fix.

@Fluffee

P.S this wouldn't of hurt so much if there wasn't a huge 700 - 1000k membership sale going on... ?

See above, I was wrong about the consistent way, that's my mistake. Sorry about that.

As we're still having issues replicating the bug. if anyone reading this is someone who experiences the bug frequently, Todd strongly encourages you to run the developmental release of TRiBot. While the dev release won't fix the bug with the login, it does print a massive amount of debug information which Todd can use to diagnose the problem.

To run the Developmental Release tick the box in the TRiBot Loader labeled Developmental Release. Then, when you experience the bug, send the entire bot and client debug, either to myself or Todd. Hopefully then Todd can get a fix soon!

  • Like 2

Share this post


Link to post
Share on other sites
15 hours ago, Fluffee said:

 

What are the steps to get info? I've got some accounts stuck

Clients are not using the built in break handler, the timer I have set for my breaks is still ticking

Stack trace:
The bugs kicking in during the login method
https://imgur.com/a/IO8FVKc

 

Client Debug:

  • xxxxxxx
  • [19:02:01] Login bot started.
Edited by theholyone

Share this post


Link to post
Share on other sites
10 hours ago, theholyone said:

What are the steps to get info? I've got some accounts stuck

Clients are not using the built in break handler, the timer I have set for my breaks is still ticking

Stack trace:
The bugs kicking in during the login method
https://imgur.com/a/IO8FVKc

 

Client Debug:

  • xxxxxxx
  • [19:02:01] Login bot started.

Make sure to use the dev release.

Todd:

"I'm gonna create a DEV release of tribot that spams debug info for the login bot"

"Okay the dev release is now out. If you commonly get the login bot getting stuck. please use this version and report back the bot debug and the client debug
(once it gets stuck)"

  • Like 1

Share this post


Link to post
Share on other sites

Seeing as how it's been a whole month now, doesn't seem like this issue will ever get resolved.

RIP afking botting, and to apparently few that are experiencing, better go set some alarms on your phone to go off every hour or two :)

lmao another great example of bot getting stuck right after muling..

(For those wondering, look at running time and look at time until "next break" lol, after muling it was immediately stuck so it never went for break)

kyb6Dcm.png

Edited by theholyone

Share this post


Link to post
Share on other sites
On 8/20/2018 at 3:48 AM, theholyone said:

Seeing as how it's been a whole month now, doesn't seem like this issue will ever get resolved.

RIP afking botting, and to apparently few that are experiencing, better go set some alarms on your phone to go off every hour or two :)

lmao another great example of bot getting stuck right after muling..

(For those wondering, look at running time and look at time until "next break" lol, after muling it was immediately stuck so it never went for break)

kyb6Dcm.png

Yup getting tiresome having to check the bot every few hours. Not to talk about how annoying it is to find the bot was doing nothing for 10 hours.

@TRiLeZ @Todd @Fluffee Guys we really need to see something here... it seems like there is no progress and it's really a major bug for some of us. I'm already using another botting client due to this bug and I'm probably not the only one. I've submitted 2 bug reports using the dev release but most of the times there is nothing in the bot/client debug when the bug occurs.

Anything else that we can do to help you figure this out? any idea what could cause that? any solution that you have in mind on our end?

  • Sad 1

Share this post


Link to post
Share on other sites
6 hours ago, NinjadGuy said:

Yup getting tiresome having to check the bot every few hours. Not to talk about how annoying it is to find the bot was doing nothing for 10 hours.

@TRiLeZ @Todd @Fluffee Guys we really need to see something here... it seems like there is no progress and it's really a major bug for some of us. I'm already using another botting client due to this bug and I'm probably not the only one. I've submitted 2 bug reports using the dev release but most of the times there is nothing in the bot/client debug when the bug occurs.

Anything else that we can do to help you figure this out? any idea what could cause that? any solution that you have in mind on our end?

Same issue, ripping my hair out.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By TRiLeZ
      This release will:
      Add LG support for Runelite Fix NPCChat issues (Thanks @JoeDezzy1) Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout) (Thanks @wastedbro) Slightly adjust the rotation via keys to be more accurate (Thanks @wastedbro) Add the ability for asynchronous camera movement via keys (Thanks @wastedbro) Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode (Thanks @wastedbro) Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel (Thanks @wastedbro) Increase the likelihood of using the mouse for camera movements (Thanks @wastedbro) Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo) (Thanks @wastedbro) Edit: Fix NPEs in Camera API (Thanks @wastedbro) Edit: Fix Login API where it wouldn't detect many messages (Thanks @JoeDezzy1) Edit: Add "Print Break Handler Stack Trace" feature Upcoming updates:
      Improved CLI support Much more Note: If you are using LG, please restart both the RS client and TRiBot
    • By TRiLeZ
      This update (9.312_3) will:
      Fix GE inventory item positioning bug Fix broken object hooks Release 9.312_5 will:
      Fix newly introduced bank inventory item positioning bug Remove some item area offsets to prevent detection of a narrowed down clicking area Fix LG object hooks
    • By TRiLeZ
      This release will:
      Fix some ClosedChannelException bug Fix bug in RSObject#getAllTiles Add game tab support for "Kourend Favour"
    • By TRiLeZ
      This release will:
      Fix Settings UI placement bug Fix game object location bug Fix small layout bug making the client shift up and down Fix client crashing bug where loading the client with a small display area will cause the client to crash Fix annoying Linux bug relating to painting events and peers Fix settings saving bug where settings are saved to disk more often than they should Fix RSInterface#isBeingDrawn bug affecting a limited amount of people Drop Java 1.7 bytecode version for 1.8 Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date). This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support. Edit: Release 9.312_1 will:
      Fix LG GZIP error Fix Client Starter for Linux ?
    • By TRiLeZ
      This release will:
      Fix resizable mode detection Fix logout with resizable mode Deprecate some Options API methods Options#isDataOrbsOn Options#isMouseCameraOn Options#isRemoveRoofsOn Options#setDataOrbs Options#setMouseCamera Options#setQuickPrayersOn Options#setRemoveRoofs Options#setRunOn Add many Options API methods A lot of methods have been added (too many to list). See: Options Fix broken Options API methods Add Interfaces API methods Interfaces#get(int, int, int) Interfaces#isInterfaceSubstantiated Fix RSInterface#isBeingDisplayed
    • By TRiLeZ
      This release features:
      Replacement of Random (which uses a linear congruential formula) with SecureRandom with the RNG methods in the General API. This will prevent possible detection of bots through the flaw in the linear congruential formula. Fix resizable mode client crashing bug Add support for side panels in resizable mode Make better use of caching with minimap projection Add better detection of trade windows Add better viewport detection for resizable mode Fix broken hooks with today's OSRS client update
  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...