Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Jamie

[Premium] JAIOConstructor : ABC2 | Goldfarmer Friendly | Progressive Mode | 100+ Items [Mythical Capes / Dungeon Doors]

Recommended Posts

2 hours ago, Samkent said:

Using the Demon Butler. Also, when creating Oak Dungeon Doors, the Butler gets stuck behind the door and the script tries to talk to him

This has been reported to me on Discord as well. Please be patient while I work on a fix. For now, Larders will function perfectly. :) 

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, RaptureMe said:

For oak dungeon doors im noticing something really weird, somehow it went to the hotspot where no doors were an option. and it kept clicking on the hotspot to build a room. very bot like.

 

A bug is obviously bot like, well observed. It should have attempted to return downstairs prior to building the doors. 

Share this post


Link to post
Share on other sites

Hey great script there is just 1 issue that keeps occurring.

I'm using the Mythical Cape method with demon butler and sometimes when he comes back with the planks, the bot hasn't taken the Cape off the wall in time causing me to recieve a full inv of teak planks with no slot for the Cape. I've had to leave my house, drop a plank and re-enter to counter this. 

It's happening too often now for me to keep having to manually do this. Is it something I'm doing wrong or not? Thanks for any info.

Share this post


Link to post
Share on other sites
11 hours ago, holywell2 said:

Hey great script there is just 1 issue that keeps occurring.

I'm using the Mythical Cape method with demon butler and sometimes when he comes back with the planks, the bot hasn't taken the Cape off the wall in time causing me to recieve a full inv of teak planks with no slot for the Cape. I've had to leave my house, drop a plank and re-enter to counter this. 

It's happening too often now for me to keep having to manually do this. Is it something I'm doing wrong or not? Thanks for any info.

No, Mythical Capes have been added as an 'extra', but there is no additional support for them. I can't see a reason as to why it would take the bot 7 seconds to remove the cape though.

Share this post


Link to post
Share on other sites

Could you add a double check or something to make sure you're in building mode after teleporting to house? Noticed multiple times gets stuck after teleporting to house and not enabling building move, starts moving again after I enable building mode manually. Also the room editor screen sometimes gets stuck and bot doesn't close it and spazzes out.

Share this post


Link to post
Share on other sites
4 hours ago, SparkySin said:

Could you add a double check or something to make sure you're in building mode after teleporting to house? Noticed multiple times gets stuck after teleporting to house and not enabling building move, starts moving again after I enable building mode manually. Also the room editor screen sometimes gets stuck and bot doesn't close it and spazzes out.

Can you try and get a debug when it does it? It checks a varbit for building mode, so a double check would do nothing. It's likely getting deadlocked but looking at the code I'm not sure why. Same for when it gets stuck on the editor.

Share this post


Link to post
Share on other sites
1 hour ago, Jackasia said:

Demon butler gets trapped behind door and bot keeps clicking him instead of removing the door to help itself....

 

Screenshot 2019-05-05 at 20.37.50.png

Noted, what's the best action from here? Make the bot stand behind the door, or just open the door to talk to the butler?

Share this post


Link to post
Share on other sites
2 hours ago, HeyImJamie said:

Noted, what's the best action from here? Make the bot stand behind the door, or just open the door to talk to the butler?

" Remove door " would be the best action and speak to the butler again so he goes to bank. Standing behind the door would make this problem appear again since he wil come from the front and perhaps the door will be built again and he will have no way to interact. 

Edited by Jackasia

Share this post


Link to post
Share on other sites
46 minutes ago, Jackasia said:

" Remove door " would be the best action and speak to the butler again so he goes to bank. Standing behind the door would make this problem appear again since he wil come from the front and perhaps the door will be built again and he will have no way to interact. 

I can make it remove the object before banking, but this would then apply to every method. Will it not affect xp rates?

Share this post


Link to post
Share on other sites
20 minutes ago, HeyImJamie said:

I can make it remove the object before banking, but this would then apply to every method. Will it not affect xp rates?

A failsafe would be a better implementation. Like if the bot presses talk to Butler and no interaction takes place in 3 seconds then remove object. Making the bot remove object before banking would work but it would mess up exp rates unnecessarily because the butler doesn't get trapped every time. 5% chance or something.

Share this post


Link to post
Share on other sites
Just now, Jackasia said:

A failsafe would be a better implementation. Like if the bot presses talk to Butler and no interaction takes place in 3 seconds then remove object. Making the bot remove object before banking would work but it would mess up exp rates unnecessarily because the butler doesn't get trapped every time. 5% chance or something.

I'll add in opening the door.

Share this post


Link to post
Share on other sites

Update 07/05/2019:

- Added a fix for Butler getting stuck behind the door when creating Oak doors.

If anyone has anything they'd like added to this script, let me know :) I finish University in 2 weeks and have a month off until I start my full time job, so I'm hoping I can get some bits written!

Happy botting ❤️

Share this post


Link to post
Share on other sites
Just now, jrcoteboy said:

it is not summoning butler to get more planks, it is just stopping script.

If the script is stopping, it'll be printing an error message. Read what it says and take a look at the first page, there's some instructions as you may have set it up wrong. Any further issues, or if you can't get it to work, just send me a message :)

 

Share this post


Link to post
Share on other sites
Guest

Hey, is there anyway to make it so the bot only draws 20 instead of 24 planks for when doing oak dungeon doors? Would save a bit of time bc of the extra butler clicks

Nevermind, just saw the tip to use regular butler. Didn't even think of that

Thanks for the script though, I can't sit here and click the exact same thing a thousand times an hour

Edited by Diabolic End

Share this post


Link to post
Share on other sites

Hi! I have been using your bot to make Oak Larders and it works flawlessly. Now when I switch to Teak planks and try to make Teak Larders I get the error message that a CSS stylesheet could not be loaded...

The exact error message is:

[22:55:43] May 19, 2019 10:55:43 PM com.sun.javafx.css.StyleManager loadStylesheetUnPrivileged
INFO: Could not find stylesheet: https://pastebin.com/css/ConsCSS.css

Thanks in advance!

Edit: I have been trying to use other Larders but I get the same error message on every object I try to make the bot use.
Seems like it wants to load something that has been removed from pastebin?

Edited by maartenyh

Share this post


Link to post
Share on other sites
6 hours ago, maartenyh said:

Hi! I have been using your bot to make Oak Larders and it works flawlessly. Now when I switch to Teak planks and try to make Teak Larders I get the error message that a CSS stylesheet could not be loaded...

The exact error message is:

[22:55:43] May 19, 2019 10:55:43 PM com.sun.javafx.css.StyleManager loadStylesheetUnPrivileged
INFO: Could not find stylesheet: https://pastebin.com/css/ConsCSS.css

Thanks in advance!

Edit: I have been trying to use other Larders but I get the same error message on every object I try to make the bot use.
Seems like it wants to load something that has been removed from pastebin?

I think I’ve replied to you in PM but that’s not an error / the error causing your problems. The CSS loads fine or your GUI wouldn’t load. Have you set the script up as per the front page?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...