Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Netami's AIO Combat - Kills Any Monsters! - ABC2 - Custom Progression - Cannon Support - Alching - Banking - Ironman Mode - Custom Looting - Spec Attacks


Recommended Posts

  • Replies 177
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Welcome to the thread for Netami's AIO Combat full release! Netami's AIO Combat is a new and revolutionary AIO Combat script designed to be easy to use yet feature rich. My script includes the followi

Awesome I'm heading home now so I'll test soon 

I've just pushed an update to fix these errors in debug, please give this a try and let me know

Posted Images

@Netami hey man sweet script!  bought it the other day and will be using it on a few of my alt accounts! - a couple of suggestions for additions in the future. Support for the Soul Bearer so we can send the ensouled heads to the bank (maybe also support to then use the heads on the dark altar to get prayer xp? would be pretty sick), maybe also herb sack, seedbox and rune pouch support? (i know these probs wouldn't be the easiest but would be awesome additions)

Link to post
Share on other sites

The script does not stop while being in a menu after pressing stop script in a tribot window. :)

The is no way to delete a certain item from the gear menu.

Starting a script from a login screen it forces it go straight to the break, because it shows 4k+ hours of a run time.

Edited by reanox
Link to post
Share on other sites
15 minutes ago, reanox said:

The script does not stop while being in a menu after pressing stop script in a tribot window. :)

The is no way to delete a certain item from the gear menu.

Starting a script from a login screen it forces it go straight to the break, because it shows 4k+ hours of a run time.

I'm aware of not being able to stop the script while in GUI; why would you want to remove an item from gear menu?

I don't control the break handler, this sounds more like a tribot bug

Link to post
Share on other sites
Just now, Netami said:

I'm aware of not being able to stop the script while in GUI; why would you want to remove an item from gear menu?

I don't control the break handler, this sounds more like a tribot bug

I want to change a cape. There is a purple cape in the setting. I want a black one. How should I change it? Pressing add gear just adds a current gear on top of everything.

Link to post
Share on other sites
1 hour ago, reanox said:

I want to change a cape. There is a purple cape in the setting. I want a black one. How should I change it? Pressing add gear just adds a current gear on top of everything.

I'll do a quick edit to make it clear the gear when you press the button again

EDIT: Updated

Edited by Netami
  • Thanks 1
Link to post
Share on other sites

Just purchased, looking forward to trying this out. 

 

 

@Netami edit: Hey was wondering if there are any differences, as far as anti-ban and such, compared to other more popular auto fighters?

 

I wanted to mix it up after being banned from another more popular combat script. 

Edited by 714
  • Like 1
Link to post
Share on other sites
45 minutes ago, 714 said:

Just purchased, looking forward to trying this out. 

 

 

@Netami edit: Hey was wondering if there are any differences, as far as anti-ban and such, compared to other more popular auto fighters?

 

I wanted to mix it up after being banned from another more popular combat script. 

This script mostly uses standard ABC2 Antiban, but I have done my best to make it as humanlike as possible besides that. I've had good success so far myself in testing, please let me know if you find any bugs or possible improvements (Quickest way to reach me is discord at Netami#0001).

Link to post
Share on other sites
8 minutes ago, Netami said:

This script mostly uses standard ABC2 Antiban, but I have done my best to make it as humanlike as possible besides that. I've had good success so far myself in testing, please let me know if you find any bugs or possible improvements (Quickest way to reach me is discord at Netami#0001).

I let my account run out of arrows for a few hits, so i'm assuming the bot does not log out when out of arrows or runes? That would be a nice feature if you haven't already added it in. 

That and if you haven't already, log out when out of food. Maybe it's in the GUI and I didn't notice. 

But it looks good, ran it for 40 minutes and got 1 - 17 range. Any progress reports 1hr + and i'll post them here and any other small issues I notice. 

Thanks man

Link to post
Share on other sites
1 minute ago, 714 said:

I let my account run out of arrows for a few hits, so i'm assuming the bot does not log out when out of arrows or runes? That would be a nice feature if you haven't already added it in. 

That and if you haven't already, log out when out of food. Maybe it's in the GUI and I didn't notice. 

But it looks good, ran it for 40 minutes and got 1 - 17 range. Any progress reports 1hr + and i'll post them here and any other small issues I notice. 

Thanks man

If you have the chatbox game messages for when you run out of ammo/runes that would be really helpful, currently the script will end if out of food and none in bank.

Link to post
Share on other sites
3 hours ago, Netami said:

 

I don't control the break handler, this sounds more like a tribot bug

It'm pretty sure it's a scripts bug. I will send you a more proper bug report later. :)

It didn't seem like the bot is using a run option during the combats. Is it? Maybe I just overlooked it but the run 100% stayed for a pretty long time.  ?

Link to post
Share on other sites
4 minutes ago, reanox said:

It'm pretty sure it's a scripts bug. I will send you a more proper bug report later. :)

It didn't seem like the bot is using a run option during the combats. Is it? Maybe I just overlooked it but the run 100% stayed for a pretty long time.  ?

I really don't think it's the script, the break handler executes when it detects itself over the time till execution and pauses the main script thread. The only thing I've implemented for breaking is going to the bank when it's time for a break. I'll double check on the run

Link to post
Share on other sites

Hi Netami,

Couple of issues, when using cannon only (safe spotting) bot cannot "repair cannon" (click cannon to repair) which in turn causes bot to discontinue using it, which in turn causes client to log out due to no action. 

Also can't seem to pre load a set up script as won't let me click start. 

It otherwise seems to work flawlessly. 

 

Link to post
Share on other sites

Subs1rJ.png

Runtime is very high after starting a script with a LG. This forces the script going straight to the break after starting it.

Loading a new profile duplicates target and progression tasks on the current profile.

Progression tasks are being deleted and SAVED to the file if the current task is complete.

 

Please fix these 3 bugs. :)

Edited by reanox
Link to post
Share on other sites
9 hours ago, trentnz said:

Hi Netami,

Couple of issues, when using cannon only (safe spotting) bot cannot "repair cannon" (click cannon to repair) which in turn causes bot to discontinue using it, which in turn causes client to log out due to no action. 

Also can't seem to pre load a set up script as won't let me click start. 

It otherwise seems to work flawlessly. 

 

Hey, is there anything in the debug when it tries to repair cannon and does it attempt to move camera to the cannon?

For loading profiles if start cannon be pressed you're probably missing a critical field, there should also be a bot debug that will tell me whats wrong.

3 hours ago, reanox said:

Subs1rJ.png

Runtime is very high after starting a script with a LG. This forces the script going straight to the break after starting it.

Loading a new profile duplicates target and progression tasks on the current profile.

Progression tasks are being deleted and SAVED to the file if the current task is complete.

 

Please fix these 3 bugs. :)

The runtime value on paint is from the API's getRunningTime() method which is likely what the break handler also uses; I can fix it on my paint separately but chances are the breaks will still execute. I'll ask other scripters to see if anyone is aware of that issue.

I'm not sure what you mean by the last issue, they're being deleted from the config file when they're complete? The only place I write to the file is when "Save" is clicked in the GUI.

Link to post
Share on other sites
8 minutes ago, Netami said:

I'm not sure what you mean by the last issue, they're being deleted from the config file when they're complete? The only place I write to the file is when "Save" is clicked in the GUI.

Yes. They're being deleted from the config file when they're complete.

For example task No. 1 is train attack 1 to 5. The task No. 2 is train strength 20 to 22.

Save the config.

Current stats are Attack: 10 Strength: 21.

Start the script. The script will start training from task number 2. Everything seems to be good.

After loading the same config on another account  task No. 1 will be gone and only No. 2 will be visible.

Link to post
Share on other sites
  • Our picks

    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 37 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 10 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...