Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Netami

Netami's AIO Combat - Kills Any Monsters! - ABC2 - Custom Progression - Cannon Support - Alching - Banking - Ironman Mode - Custom Looting - Spec Attacks

Recommended Posts

18 minutes ago, reanox said:

Yes. They're being deleted from the config file when they're complete.

For example task No. 1 is train attack 1 to 5. The task No. 2 is train strength 20 to 22.

Save the config.

Current stats are Attack: 10 Strength: 21.

Start the script. The script will start training from task number 2. Everything seems to be good.

After loading the same config on another account  task No. 1 will be gone and only No. 2 will be visible.

Interesting, I'll see if I can replicate this, thanks

Share this post


Link to post
Share on other sites
15 hours ago, Netami said:

Hey, is there anything in the debug when it tries to repair cannon and does it attempt to move camera to the cannon?

For loading profiles if start cannon be pressed you're probably missing a critical field, there should also be a bot debug that will tell me whats wrong.

The runtime value on paint is from the API's getRunningTime() method which is likely what the break handler also uses; I can fix it on my paint separately but chances are the breaks will still execute. I'll ask other scripters to see if anyone is aware of that issue.

I'm not sure what you mean by the last issue, they're being deleted from the config file when they're complete? The only place I write to the file is when "Save" is clicked in the GUI.

Hey Netami,

Script sits idle until account logs out, doesn't seem to recognize cannon needs to be repaired.

have attached logs for info.

cannon.PNG

Share this post


Link to post
Share on other sites
24 minutes ago, trentnz said:

Hey Netami,

Script sits idle until account logs out, doesn't seem to recognize cannon needs to be repaired.

have attached logs for info.

cannon.PNG

Oh I just realised it thinks it's out of ammo. There's definitely ammo and the cannon needed repairing ( I ran the script again to get it to do it again) 

Share this post


Link to post
Share on other sites
14 hours ago, trentnz said:

Oh I just realised it thinks it's out of ammo. There's definitely ammo and the cannon needed repairing ( I ran the script again to get it to do it again) 

I've made some small tweaks to cannon usage, though it's tough to say for sure if this will fix it as I don't currently have an account with cannon access.

EDIT: Uploading a new version for cannon now, I didn't know cannon name changes when it breaks!

@reanox Still working on the profile issue as well

Edited by Netami
  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, Netami said:

I've made some small tweaks to cannon usage, though it's tough to say for sure if this will fix it as I don't currently have an account with cannon access.

EDIT: Uploading a new version for cannon now, I didn't know cannon name changes when it breaks!

@reanox Still working on the profile issue as well

Awesome I'm heading home now so I'll test soon 

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, trentnz said:

Working great now cannon wise. 

One more thing I've noticed. 

When set to a safe spot, client attacks monsters outside of set radius so player ends up running out of safe spot to attack monsters too far away. 

I'll check this out, thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Does not open doors. also if you start at training area, it just goes to bank and logs out for me. Could you make so it can open doors. Right now it looks so botlike.

No good antibans. no mouse off screen. no spacebar to ''click to continue'' when you level up, it clicks instead or just completely ignore it maybe better. Needs AFK'ing and mouse off screen so it randomizes next click, and not always takes the closest npc.  hovers over food and npc most of the time. 

and during my session it randomly used amulet of glory and then started walking back to training area. like what the fuck lol.

 

I only recommend to use this bot for MAXIMUM 1 hour, even that is too much maybe. Just warning yall that are a bit inexperienced do not run this for a long time.

Share this post


Link to post
Share on other sites
23 minutes ago, totes said:

Does not open doors. also if you start at training area, it just goes to bank and logs out for me. Could you make so it can open doors. Right now it looks so botlike.

 No good antibans. no mouse off screen. no spacebar to ''click to continue'' when you level up, it clicks instead or just completely ignore it maybe better. Needs AFK'ing and mouse off screen so it randomizes next click, and not always takes the closest npc.  hovers over food and npc most of the time. 

and during my session it randomly used amulet of glory and then started walking back to training area. like what the fuck lol.

 

I only recommend to use this bot for MAXIMUM 1 hour, even that is too much maybe. Just warning yall that are a bit inexperienced do not run this for a long time.

It does open doors, this script uses Dax's Webwalker for navigation and tribot's as a backup. This script implements nearly all aspects of ABC2, just because you personally don't think it looks 100% like a human doesn't mean Antiban isn't there. I'm sorry you aren't pleased with the script but you aren't very informed on how it operates either.

Share this post


Link to post
Share on other sites

 

1 minute ago, Netami said:

It does open doors, this script uses Dax's Webwalker for navigation and tribot's as a backup. This script implements nearly all aspects of ABC2, just because you personally don't think it looks 100% like a human doesn't mean Antiban isn't there. I'm sorry you aren't pleased with the script but you aren't very informed on how it operates either.

It didn't open for me, maybe just that specific spot. And yeah whats so humanlike of just attacking the npc over and over it literally didn't do anything else without opening the door instead just waits for npc to respawn. The thing that got me was it used amulet of glory to teleport and then was running back to training spot? like what? explain that if you know so much :/. Anyways just my opinion. goodluck anyways, wish it goes well really.

Just had to say how it went for me, obviously if it did open the door, and if it didn't run to bank immediately when starting script and logging out, and using glory to teleport and the running back to training spot, i would give it more of a chance but just too many errors in 10 mins which means it cant be trusted if not overlooked while using it.

Share this post


Link to post
Share on other sites
1 minute ago, totes said:

 

It didn't open for me, maybe just that specific spot. And yeah whats so humanlike of just attacking the npc over and over it literally didn't do anything else without opening the door instead just waits for npc to respawn. The thing that got me was it used amulet of glory to teleport and then was running back to training spot? like what? explain that if you know so much :/. Anyways just my opinion. goodluck anyways, wish it goes well really.

Just had to say how it went for me, obviously if it did open the door, and if it didn't run to bank immediately when starting script and logging out, and using glory to teleport and the running back to training spot, i would give it more of a chance but just too many errors in 10 mins which means it cant be trusted if not overlooked while using it.

The debug provides a reason when script ends, without this I can't tell you why the script ended. If you care to share what spot you're using for the door not working I could always look. I can't tell you why daxwalker wanted to use a glory charge to walk back to the spot without knowing your spot and setup.

Share this post


Link to post
Share on other sites
2 minutes ago, SlarkenTV said:

@Netami Only suggestion I have, maybe I overlooked it. But on an ironman account, it keeps looking for supersets, and I don't see an option to disable that. Even with drink potions not selected it still withdraws supersets/super potions.

I'll check it out, thanks

Share this post


Link to post
Share on other sites

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...