Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Netami

Netami's AIO Combat - Kills Any Monsters! - ABC2 - Custom Progression - Cannon Support - Alching - Banking - Ironman Mode - Custom Looting - Spec Attacks

Recommended Posts

On 12/31/2018 at 3:57 PM, SlarkenTV said:

@Netami Only suggestion I have, maybe I overlooked it. But on an ironman account, it keeps looking for supersets, and I don't see an option to disable that. Even with drink potions not selected it still withdraws supersets/super potions.

This should be fixed now, sorry for the delay

Share this post


Link to post
Share on other sites

Feedback -

GUI clean and easy to setup. Had same problem as a other user, the bot used 2 glory charges randomly and actually got lost on the way back. Had prayer off and to use super combats, maybe it ran out of super combats. Find the mouse movement a bit mechanical and does not offer much anti ban (mouse pickup, mouse off screen, random movement like after drinking potion dose). Other than that great script for the price.

Share this post


Link to post
Share on other sites
1 hour ago, Reko said:

Feedback -

GUI clean and easy to setup. Had same problem as a other user, the bot used 2 glory charges randomly and actually got lost on the way back. Had prayer off and to use super combats, maybe it ran out of super combats. Find the mouse movement a bit mechanical and does not offer much anti ban (mouse pickup, mouse off screen, random movement like after drinking potion dose). Other than that great script for the price.

Thanks for the feedback, the script uses the same mouse movements as all other scripts on TRiBot and standard ABC2 timed actions for antiban. Unfortunately I've run into some similar issues with dax's walker recently and will likely be including an option to use TRiBot's built in walker instead.

Share this post


Link to post
Share on other sites
22 minutes ago, Netami said:

Thanks for the feedback, the script uses the same mouse movements as all other scripts on TRiBot and standard ABC2 timed actions for antiban. Unfortunately I've run into some similar issues with dax's walker recently and will likely be including an option to use TRiBot's built in walker instead.

No prob so you think the bot teleporting away randomly was due to the web walker?

Share this post


Link to post
Share on other sites

@@Netami hello

i bought this script when it was freshly released. GUI was buggy and would fail most of times to run.

Same thing now...

I cannot select spell / attack index. does not open the bar.

Does not add task too. 

Not even sure what does it stand for - items to equip. when it equips them? what items? is it need to be added by name or by id?

https://i.gyazo.com/1bf933ac10ed2637cd46d990e4cfa2a8.mp4

 

Here is another problem. I click Start - but nothing happens. I mean, i tied to leave GUI as default as possible, but it fails.

https://i.gyazo.com/fff34e4a665dfc0a3ef97cc8b2ffd0f8.mp4

 

After i cannot run the script - i close the GUI, i press stop script, but nothing happens. Script does not stop ever. I have to pretty much kill the client to be able use it again...

Not even sure why there is no ranged potions support if there is safe-spot option?

 

P.S. I run this on Linux server.

 

Edited by guywithlsd

Share this post


Link to post
Share on other sites

would be nice if there was an additional option for super sets to drink at a faster rate. like "fast, medium and slow" since it waits too long to drink another dose right now.

 

also would be dope if you added something that logs you out after 5 minutes of no exp gains. 

 

otherwise its been working good so far!

Share this post


Link to post
Share on other sites
5 hours ago, guywithlsd said:

@@Netami hello

i bought this script when it was freshly released. GUI was buggy and would fail most of times to run.

Same thing now...

I cannot select spell / attack index. does not open the bar.

Does not add task too. 

Not even sure what does it stand for - items to equip. when it equips them? what items? is it need to be added by name or by id?

https://i.gyazo.com/1bf933ac10ed2637cd46d990e4cfa2a8.mp4

 

Here is another problem. I click Start - but nothing happens. I mean, i tied to leave GUI as default as possible, but it fails.

https://i.gyazo.com/fff34e4a665dfc0a3ef97cc8b2ffd0f8.mp4

 

After i cannot run the script - i close the GUI, i press stop script, but nothing happens. Script does not stop ever. I have to pretty much kill the client to be able use it again...

Not even sure why there is no ranged potions support if there is safe-spot option?

 

P.S. I run this on Linux server.

 

I'll fix the progression/spell box dropping down, and for items to equip it uses names, I'll add that in the text as well. If the script does not start when you press start then there is a error in the debugs that I'll need to be able to help you

 

5 hours ago, beake said:

would be nice if there was an additional option for super sets to drink at a faster rate. like "fast, medium and slow" since it waits too long to drink another dose right now.

 

also would be dope if you added something that logs you out after 5 minutes of no exp gains. 

 

otherwise its been working good so far!

I might add some variance to potion drinking speed but it waits until its lost a certain amount of it's boost to drink again. I'm hesitant to add too many options as it will further cloud the GUI

  • thonking 1

Share this post


Link to post
Share on other sites
20 hours ago, Netami said:

I'm not 100% sure without seeing it happen if it was trying to bank or return to the fighting area

Alright kool just for note when it happened, I had multiple free inventory spots and at least 6+ food left

Share this post


Link to post
Share on other sites

@Netami

In my testing I've noticed that if you have a non-attackable NPC within your fight area, it will sometimes get stuck in a loop trying to attack that target, even though the NPC is not on your list of NPCs to kill. Once it mistakenly selects this target, it keeps trying to hover/right click it to find the 'attack' option but since there is none it gets stuck.

Share this post


Link to post
Share on other sites
13 minutes ago, Adventure_Time said:

@Netami

In my testing I've noticed that if you have a non-attackable NPC within your fight area, it will sometimes get stuck in a loop trying to attack that target, even though the NPC is not on your list of NPCs to kill. Once it mistakenly selects this target, it keeps trying to hover/right click it to find the 'attack' option but since there is none it gets stuck.

The script will only attack NPCs matching those IDs from the GUI, however I will filter the results to have an Attack option to be able to select

  • thonking 1

Share this post


Link to post
Share on other sites

@Netami hi. so script (just like many others) fails to comeback from break sometimes. The problem is client related, that is not fixed for 6 months i guess. how stupid right..? 

Anyways, if you could go to any of the devs / trilez, and report this, it would be great. I have done this few times, im sure other have reported this too.. maybe they will listen for scripter more then they listen to regular guys.

image.png.ae7d1b847865305320aa585cbd3d97af.png

 

Ppl talking how to fix it or what could cause it @Laniax i ping you here dude, cuz if you remember, i asked for a refund because of this problem. maybe you can see anything useful in those chats that could help solve it.

Spoiler

image.png.beb262fad239aa1dfdb939ae82155737.png

image.png.2237dd1e40538d49b07dcac22a03e0db.png

 

Edited by guywithlsd

Share this post


Link to post
Share on other sites
12 hours ago, Netami said:

The script will only attack NPCs matching those IDs from the GUI, however I will filter the results to have an Attack option to be able to select

Yeah, I'm not sure exactly how it happened, but multiple accounts ended up in a conversation with a non-attackable NPC, hovering over it as if it was stuck in a loop trying to find the attack menu option. The NPC wasn't selected in the GUI, and it wouldn't specifically target it. I think if it  happened to misclick it the bug would occur. The non-attackable, non-selected NPC had it's tile highlighted as the target

Share this post


Link to post
Share on other sites

hi @Netami thanks for the awesome script. Could you pls add Bones to peaches tablet support? It's very usefull when you don't want to banking (its not that easy to banking in some areas and thus reducing XP/h), script would collect bones and use one Bones to peaches tablet when inventory is full. So the food is "Peach". This way it won't need banking for food.

Thanks in advance.

Share this post


Link to post
Share on other sites
On 1/4/2019 at 3:41 AM, Adventure_Time said:

@Netami

In my testing I've noticed that if you have a non-attackable NPC within your fight area, it will sometimes get stuck in a loop trying to attack that target, even though the NPC is not on your list of NPCs to kill. Once it mistakenly selects this target, it keeps trying to hover/right click it to find the 'attack' option but since there is none it gets stuck.

this happened to me at trolls, despite it not being on my list of attackable npcs and just out of the range of attackable targets, it would still try to attack one of the thrower trolls

Share this post


Link to post
Share on other sites
11 hours ago, guywithlsd said:

@Netami hey, script use a lot of ram. at least for me, this looks a bit too much for just walking to bank or killing NPC's (?)

image.png.0a36709691330ee338d14c53b99ebca4.png

image.png

I don't do a lot of adding to collections or loading files or anything else, not sure where I could change anything to change this.

Share this post


Link to post
Share on other sites

After further running it, get this error.

 

  • [21:53:49] Script Started: Netami's AIO Combat.
  • [21:54:52] java.lang.NullPointerException
  • [21:54:52] at scripts.combat.a.h.i(IdleActions.java:143)
  • [21:54:52] at scripts.combat.CombatAIO.D(CombatAIO.java:400)
  • [21:54:52] at scripts.combat.CombatAIO.run(CombatAIO.java:72)
  • [21:54:52] at java.lang.Thread.run(Thread.java:748)
  • [21:54:52] Signature data sent: true
  • [21:54:52] Script Ended: Netami's AIO Combat.

Share this post


Link to post
Share on other sites
1 hour ago, SlarkenTV said:

After further running it, get this error.

 

  • [21:53:49] Script Started: Netami's AIO Combat.
  • [21:54:52] java.lang.NullPointerException
  • [21:54:52] at scripts.combat.a.h.i(IdleActions.java:143)
  • [21:54:52] at scripts.combat.CombatAIO.D(CombatAIO.java:400)
  • [21:54:52] at scripts.combat.CombatAIO.run(CombatAIO.java:72)
  • [21:54:52] at java.lang.Thread.run(Thread.java:748)
  • [21:54:52] Signature data sent: true
  • [21:54:52] Script Ended: Netami's AIO Combat.

It looks like this is related to using special attacks, what spec weapon did you have in the GUI?

Share this post


Link to post
Share on other sites

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...