Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Netami

Netami's AIO Combat - Kills Any Monsters! - ABC2 - Custom Progression - Cannon Support - Alching - Banking - Ironman Mode - Custom Looting - Spec Attacks

Recommended Posts

hey, enjoying the script so far but theres definitely some tweaking needed. it seriously needs to chill out when it has aggro on monsters. it will run around trying to attack ones in combat and running from one to another, until it finds a fight. i watched him try 6 times before finally engaging in combat. should try and find an option. also i come back to being on random sides of gates and not sure how i get there and stuck. should add a 5 minute failsafe because its been reoccuring 

Share this post


Link to post
Share on other sites

Was using Whip spec, ended up getting it settled.

Although running into a banking error at Gnome Stronghold.

 

  • [11:08:58] java.lang.reflect.UndeclaredThrowableException
  • [11:08:58] at com.sun.proxy.$Proxy0.B(Unknown Source)
  • [11:08:58] at org.tribot.api2007.Objects.Yo(wn:143)
  • [11:08:58] at org.tribot.api2007.Objects.getAllIn(wn:49)
  • [11:08:58] at org.tribot.api2007.Objects.getAll(wn:923)
  • [11:08:58] at org.tribot.api2007.Objects.getAll(wn:680)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.kn(dk:794)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.VM(dk:304)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.oo(dk:273)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.Gn(dk:400)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.findPath(dk:528)
  • [11:08:58] at org.tribot.api2007.Banking.isInBank(hd:416)
  • [11:08:58] at scripts.combat.CombatAIO.D(CombatAIO.java:447)
  • [11:08:58] at scripts.combat.CombatAIO.run(CombatAIO.java:70)
  • [11:08:58] at java.lang.Thread.run(Thread.java:748)
  • [11:08:58] Caused by: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: java.net.SocketTimeoutException: Read timed out
  • [11:08:58] at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:236)
  • [11:08:58] at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:161)
  • [11:08:58] at com.sun.jmx.remote.internal.PRef.invoke(Unknown Source)
  • [11:08:58] at javax.management.remote.rmi.RMIConnectionImpl_Stub.invoke(Unknown Source)
  • [11:08:58] at javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.invoke(RMIConnector.java:1020)
  • [11:08:58] at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:298)
  • [11:08:58] ... 14 more
  • [11:08:58] Caused by: java.net.SocketTimeoutException: Read timed out
  • [11:08:58] at java.net.SocketInputStream.socketRead0(Native Method)
  • [11:08:58] at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
  • [11:08:58] at java.net.SocketInputStream.read(SocketInputStream.java:171)
  • [11:08:58] at java.net.SocketInputStream.read(SocketInputStream.java:141)
  • [11:08:58] at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
  • [11:08:58] at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
  • [11:08:58] at java.io.DataInputStream.readByte(DataInputStream.java:265)
  • [11:08:58] at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:222)
  • [11:08:58] ... 19 more
  • [11:08:58] Signature data sent: true
  • [11:09:01] Script Ended: Netami's AIO Combat.

Share this post


Link to post
Share on other sites
26 minutes ago, SlarkenTV said:

Was using Whip spec, ended up getting it settled.

Although running into a banking error at Gnome Stronghold.

 

  • [11:08:58] java.lang.reflect.UndeclaredThrowableException
  • [11:08:58] at com.sun.proxy.$Proxy0.B(Unknown Source)
  • [11:08:58] at org.tribot.api2007.Objects.Yo(wn:143)
  • [11:08:58] at org.tribot.api2007.Objects.getAllIn(wn:49)
  • [11:08:58] at org.tribot.api2007.Objects.getAll(wn:923)
  • [11:08:58] at org.tribot.api2007.Objects.getAll(wn:680)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.kn(dk:794)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.VM(dk:304)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.oo(dk:273)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.Gn(dk:400)
  • [11:08:58] at org.tribot.api2007.util.DPathNavigator.findPath(dk:528)
  • [11:08:58] at org.tribot.api2007.Banking.isInBank(hd:416)
  • [11:08:58] at scripts.combat.CombatAIO.D(CombatAIO.java:447)
  • [11:08:58] at scripts.combat.CombatAIO.run(CombatAIO.java:70)
  • [11:08:58] at java.lang.Thread.run(Thread.java:748)
  • [11:08:58] Caused by: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: java.net.SocketTimeoutException: Read timed out
  • [11:08:58] at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:236)
  • [11:08:58] at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:161)
  • [11:08:58] at com.sun.jmx.remote.internal.PRef.invoke(Unknown Source)
  • [11:08:58] at javax.management.remote.rmi.RMIConnectionImpl_Stub.invoke(Unknown Source)
  • [11:08:58] at javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.invoke(RMIConnector.java:1020)
  • [11:08:58] at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:298)
  • [11:08:58] ... 14 more
  • [11:08:58] Caused by: java.net.SocketTimeoutException: Read timed out
  • [11:08:58] at java.net.SocketInputStream.socketRead0(Native Method)
  • [11:08:58] at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
  • [11:08:58] at java.net.SocketInputStream.read(SocketInputStream.java:171)
  • [11:08:58] at java.net.SocketInputStream.read(SocketInputStream.java:141)
  • [11:08:58] at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
  • [11:08:58] at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
  • [11:08:58] at java.io.DataInputStream.readByte(DataInputStream.java:265)
  • [11:08:58] at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:222)
  • [11:08:58] ... 19 more
  • [11:08:58] Signature data sent: true
  • [11:09:01] Script Ended: Netami's AIO Combat.

This error is not script related but looks more like a connection issue

Share this post


Link to post
Share on other sites
4 hours ago, Netami said:

Ranged potion support can be added soon, been busy with start of semester but things are starting to settle back in.

well, ranging potions is really *a must* thing to have in my opinion.
ALSO - bug report here - Even if i select Stop script when out of food, it would still walk to bank for more. and i kill npc's where dax webwalker does not cover so it stuck in bank saying "walking to safespot"

 

EDIT - GUI becomes unresponsive when you run second TAB in client. 

So for example, if u run script in 1st tab GUI will scan for NPC's around. But if u run script in 2nd TAB that was opened after 1st one loaded, NPC scanning does not work, and if you click refresh nothing happens.

Edited by guywithlsd

Share this post


Link to post
Share on other sites
4 hours ago, playzero said:

Hey just bought the script, is there any way you can choose when to pot ? I would rather use it every 6-7 minutes instead of 10-11.

.

There is not currently any adjustment on potion timing.

4 hours ago, guywithlsd said:

well, ranging potions is really *a must* thing to have in my opinion.
ALSO - bug report here - Even if i select Stop script when out of food, it would still walk to bank for more. and i kill npc's where dax webwalker does not cover so it stuck in bank saying "walking to safespot"

 

EDIT - GUI becomes unresponsive when you run second TAB in client. 

So for example, if u run script in 1st tab GUI will scan for NPC's around. But if u run script in 2nd TAB that was opened after 1st one loaded, NPC scanning does not work, and if you click refresh nothing happens.

I do not recommend you to use tabs with any script at TRiBot for this same issue, the way TRiBot is built with a static API causes issues.

Share this post


Link to post
Share on other sites
6 hours ago, Netami said:

There is not currently any adjustment on potion timing.

I do not recommend you to use tabs with any script at TRiBot for this same issue, the way TRiBot is built with a static API causes issues.

this was fixed months ago and it was confirmed then using tabs is SAFE and working now. I have been using tabs for month at least and never had any problems.

Tonight happened 2 thing. 

1st - bots goes to bank for break. This is not right in my opinion - i offered to add option in GUI where you select a Tile and it goes there to break - would allow us to us bot in area where DaxWebWalker does not cover. Cuz now, my bot went to bank and stuck there for 8 hours standing and saying "walking to safespot". Pretty much same problem like with food that was mentioned above.

 

Second - idk what happened, account was standing in a zone i selected and had everything it needed to continue killing NPC's. But it crashed.

image.png.13f5bba4a3213476f394ece22c67435b.png

image.png.b9be4a5243c23121af219f59e7105b38.png

Share this post


Link to post
Share on other sites

This script is having problems. When I start it, it frequently quits and says "Trying to bank but no banking. Parameters not met" and ends the script. Thats actually not true, I don't want food so I have no food input (there is no option for 0 food). I have 3 super att/str and the rest prayer potions. 

 

What am I doing wrong? I even tried letting it bank. It teleported to edge bank and just sat there doing nothing and I turned it off after 3 minutes. 

Share this post


Link to post
Share on other sites
3 hours ago, beake said:

This script is having problems. When I start it, it frequently quits and says "Trying to bank but no banking. Parameters not met" and ends the script. Thats actually not true, I don't want food so I have no food input (there is no option for 0 food). I have 3 super att/str and the rest prayer potions. 

 

What am I doing wrong? I even tried letting it bank. It teleported to edge bank and just sat there doing nothing and I turned it off after 3 minutes. 

I'll be working on an option to not use any food soon but it's going to require some logic rewrites so it's not a simple fix.I'll check

12 hours ago, guywithlsd said:

this was fixed months ago and it was confirmed then using tabs is SAFE and working now. I have been using tabs for month at least and never had any problems.

Tonight happened 2 thing. 

1st - bots goes to bank for break. This is not right in my opinion - i offered to add option in GUI where you select a Tile and it goes there to break - would allow us to us bot in area where DaxWebWalker does not cover. Cuz now, my bot went to bank and stuck there for 8 hours standing and saying "walking to safespot". Pretty much same problem like with food that was mentioned above.

 

Second - idk what happened, account was standing in a zone i selected and had everything it needed to continue killing NPC's. But it crashed.

image.png.13f5bba4a3213476f394ece22c67435b.png

image.png.b9be4a5243c23121af219f59e7105b38.png

I'll check into this error tonight, I have no plans to make any major changes to support tabs.

Share this post


Link to post
Share on other sites
2 hours ago, sl_kelevra said:

Not sure what I'm doing wrong here but training on cows; it was working perfectly last night, burying bones and banking hides, but this morning running with the same settings, it's just collecting bones and banking them.

 

netamisAIO.PNG

RSBuddy API was down earlier today so that may be why.

Share this post


Link to post
Share on other sites

@Netami

Whenever a random event pops up the script will keep hovering over it until it dissapears. 

I have dismissing randoms unticked in TRiBot settings. Any other script I use doesn't seem to have this issue. Is it possible for you to look into that? 

Also support for ranging potions would be neat.

Share this post


Link to post
Share on other sites
5 hours ago, Flax said:

@Netami

Whenever a random event pops up the script will keep hovering over it until it dissapears. 

I have dismissing randoms unticked in TRiBot settings. Any other script I use doesn't seem to have this issue. Is it possible for you to look into that? 

Also support for ranging potions would be neat.

If the random dismisser is activating I don't have any control over that, I'm also not using any custom code for randoms at all.

Share this post


Link to post
Share on other sites
48 minutes ago, RaptureMe said:

The canon refilling looks very bot like, is there any reason is wont get closer to running out rather then refilling everylike 4-10 cannonballs?

The cannonball refilling works on a timer as Jagex removed the game setting for cannonballs left; if I make the time longer then people use in a very crowded location will go empty too often.

Share this post


Link to post
Share on other sites

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 9 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...