Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Netami

Netami's AIO Combat - Kills Any Monsters! - ABC2 - Custom Progression - Cannon Support - Alching - Banking - Ironman Mode - Custom Looting - Spec Attacks

Recommended Posts

9 hours ago, Osrsplaya said:

Cant the script reload the cannon when its lower than 20 ammo (8-15) would be nice, its reloading at like 28 and its rather stupid imo lol

The cannon loaded is on a randomized timer, it's set to be more frequent since people at dagganoths or other high cannonball areas would run of ammo frequently if it was too slow.

  • Like 1

Share this post


Link to post
Share on other sites
Guest

Saw is was updated may 3rd, did you add range pots? Very interested in purchasing a couple auths if it supports ranged pots

Share this post


Link to post
Share on other sites
55 minutes ago, lecanadien said:

Saw is was updated may 3rd, did you add range pots? Very interested in purchasing a couple auths if it supports ranged pots

That update did not add ranging potion support, but it has now been added to the script. Please note the update is still pending however, it appears the TRiBot repo compiler is down again but the update will be automatically approved once the compiler has been reset by TRiLeZ.

Share this post


Link to post
Share on other sites
On 12/30/2018 at 4:24 PM, Netami said:

It does open doors, this script uses Dax's Webwalker for navigation and tribot's as a backup. This script implements nearly all aspects of ABC2, just because you personally don't think it looks 100% like a human doesn't mean Antiban isn't there. I'm sorry you aren't pleased with the script but you aren't very informed on how it operates either. 

   Hi, just wanted to say that I'm also seeing problems with the bot not opening doors.   I'm no script writer, so yea I don't know why it isn't doing what it's supposed to do. Then again, I'm also no mechanic...but I can tell when my car won't run.  =P        Right now it will not target enemies even if they are in the specified tile range if there is a closed door in the way.     If there is something I can do on my end to figure out why it's acting this way please let me know.    

Share this post


Link to post
Share on other sites
1 minute ago, vorpalblade said:

   Hi, just wanted to say that I'm also seeing problems with the bot not opening doors.   I'm no script writer, so yea I don't know why it isn't doing what it's supposed to do. Then again, I'm also no mechanic...but I can tell when my car won't run.  =P        Right now it will not target enemies even if they are in the specified tile range if there is a closed door in the way.     If there is something I can do on my end to figure out why it's acting this way please let me know.    

This is by design, the script will not attempt to navigate through doors to monsters in the immediate non-reachable area. What area are you trying to use this in?

Share this post


Link to post
Share on other sites
1 minute ago, Netami said:

This is by design, the script will not attempt to navigate through doors to monsters in the immediate non-reachable area. What area are you trying to use this in?

  I'm at the wizard tower, there are 3 doors in the area separating 4 different wizards that spawn.  My character will only attack the one in the same room as him.  If I manually open the doors, he will start attacking the others too, but the doors close again after a while.

Share this post


Link to post
Share on other sites
2 hours ago, moeal1 said:

It would be nice if you add a feature where it doesn't let your health go down below a certain point, I've came close to death a few times due to this.

Not a bad suggestion, out of curiosity is this for low hitpoints level accounts?

Share this post


Link to post
Share on other sites
3 hours ago, t3hub3rz said:

how come the script doesnt move the mouse off the screen, after every click it just stays at the same position it clicked until it moves to the next point.

Moving cursor off screen is in the script following ABC2 implementation; whether or not the ABC2 system chooses to execute these tasks is entirely up to itself and the character profile.

  • Like 1

Share this post


Link to post
Share on other sites

Is it normal for the bot to not move at all after clicks? It literally does not move so after it clicks it just stays in the same spot as the click, this doesnt seem very human like. humans dont take their hand off the mouse when they click and if they do it would move a bit right?

Share this post


Link to post
Share on other sites
12 minutes ago, t3hub3rz said:

Is it normal for the bot to not move at all after clicks? It literally does not move so after it clicks it just stays in the same spot as the click, this doesnt seem very human like. humans dont take their hand off the mouse when they click and if they do it would move a bit right?

What seems human or non-human various widely from person to person; you'll find most scripts on the platform will follow this same pattern unless an ABC2 action kicks in.

Share this post


Link to post
Share on other sites
22 hours ago, sl_kelevra said:

what's the proper syntax for launching with a settings profile from CLI?

This script does not support using arguments at the moment

16 hours ago, barbie said:

Can we fix the break handler? The script stops if we don't use banking... Would like it to just go AFK on the spot and let the game log us out (without forcing logout)

I can change this today yes

  • Like 1

Share this post


Link to post
Share on other sites

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...