Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

God

Gods Runecrafter [Resize, LG Support] [ABC2, ABCL10] [Progression][Restocking][Up to 1M/hr+]

Recommended Posts

Hey mate, New to the script.

Fews things im noticing as im babysitting it currently.

It attempts to world hop when it see's a pker, Perhaps emergency tele first? As if it gets hit before it world hops just sits and dies even when not teleblocked (I just tele manually) if it sees a pker it could simply hit a house tab and be safe.

Also it doesnt seem to check inventory space when attempting to restore HP, Inventory had 2 slots empty, Kept trying to take 3 food out over and over until manually fixed.

At one point a pouch was full from a previous world hop and it sat attempting to fill the same pouch until i emptied it manually to reset it.

Another thing with the PK detection, If it sees a pker it Immediately  starts a "Antiban" and has had me just sitting afk in the wildy, if i then walk to mage and tp manually it attempts to world hop.

There is times it decides to AntiBan at the mage in the wildy, Im not entirely sure how or why i assume its because someone tele's the second before my toon reach's him

If it notices a Pker the moment it tps into the abyss it attempts to world hop inside the abyss which is practically impossible :D


Seems that if i wear a glory whilst using tele to home, It doesnt seem to stall when it see's a pker instantly glory's away, It Does unequip the uncharged glory however doesnt re-equip a charged glory.




Seems to get into the abyss and do all other fine, Just the survivability and tele'ing issues i think could use a hand :)

Edited by Arnlook

Share this post


Link to post
Share on other sites
13 hours ago, Arnlook said:

Hey mate, New to the script.

Fews things im noticing as im babysitting it currently.

It attempts to world hop when it see's a pker, Perhaps emergency tele first? As if it gets hit before it world hops just sits and dies even when not teleblocked (I just tele manually) if it sees a pker it could simply hit a house tab and be safe.

Also it doesnt seem to check inventory space when attempting to restore HP, Inventory had 2 slots empty, Kept trying to take 3 food out over and over until manually fixed.

At one point a pouch was full from a previous world hop and it sat attempting to fill the same pouch until i emptied it manually to reset it.

Another thing with the PK detection, If it sees a pker it Immediately  starts a "Antiban" and has had me just sitting afk in the wildy, if i then walk to mage and tp manually it attempts to world hop.

There is times it decides to AntiBan at the mage in the wildy, Im not entirely sure how or why i assume its because someone tele's the second before my toon reach's him

If it notices a Pker the moment it tps into the abyss it attempts to world hop inside the abyss which is practically impossible :D


Seems that if i wear a glory whilst using tele to home, It doesnt seem to stall when it see's a pker instantly glory's away, It Does unequip the uncharged glory however doesnt re-equip a charged glory.




Seems to get into the abyss and do all other fine, Just the survivability and tele'ing issues i think could use a hand :)

I can't update the script atm due to the repo issues otherwise no one will be able to load the script :( 

So basically all of those things you listed are stemming from anti-pk? 

What are you settings? banking/teleport method

Edited by godspower33

Share this post


Link to post
Share on other sites
9 hours ago, godspower33 said:

I can't update the script atm due to the repo issues otherwise no one will be able to load the script :( 

So basically all of those things you listed are stemming from anti-pk? 

What are you settings? banking/teleport method

Teleport method is house glory , After watching it for awhile and swapping glorys when it loses all charges it runs perfectly fine and i havent died since.

It has some banking issues regarding tabs aswell, It always withdraws 2 teletabs and when it tp's to house it hits the second tab then realises its in the house and continues normally.

When it see's a pker it instantly uses worn glory, But wont hit a house tab :) so thats what was causing the issues, If it could replace the worn glory it would be sick

Share this post


Link to post
Share on other sites

@godspower33 great little script this. Running into an issue where when using clan wars tele + house glory together the script will tele to house and then proceed to use duelling to teleport to castlewars and run south. Also once the script is in the house after using tab it will try to click any remaining tabs in the inventory multiple times before finding and using mounted glory. LG x64

Edit: the multiple teletab clicking tends to occur if the script hasn't realised that the house has loaded yet. Maybe a longer delay before clicking again, or the ability to customise how long the script waits before clicking. 

Also the delay between clicking pouches could be reduced or made customisable, it's a little bit long as it stands

Edit2: I'd suck a fat one for ZMI support too ❤️ 

Edited by Charvie

Share this post


Link to post
Share on other sites
4 hours ago, Arnlook said:

Teleport method is house glory , After watching it for awhile and swapping glorys when it loses all charges it runs perfectly fine and i havent died since.

It has some banking issues regarding tabs aswell, It always withdraws 2 teletabs and when it tp's to house it hits the second tab then realises its in the house and continues normally.

When it see's a pker it instantly uses worn glory, But wont hit a house tab :) so thats what was causing the issues, If it could replace the worn glory it would be sick

Ah okay, yeah I can have that fixed up as soon as the repository is fully functional. The anti-pk must be trying to use a glory but realizes it doesn't have one since you're using house tabs so it doesn't tab out but it will once I can update the script.

1 hour ago, Charvie said:

@godspower33 great little script this. Running into an issue where when using clan wars tele + house glory together the script will tele to house and then proceed to use duelling to teleport to castlewars and run south. Also once the script is in the house after using tab it will try to click any remaining tabs in the inventory multiple times before finding and using mounted glory. LG x64

Edit: the multiple teletab clicking tends to occur if the script hasn't realised that the house has loaded yet. Maybe a longer delay before clicking again, or the ability to customise how long the script waits before clicking. 

Also the delay between clicking pouches could be reduced or made customisable, it's a little bit long as it stands

Edit2: I'd suck a fat one for ZMI support too ❤️ 

Thanks haha, I don't think I'm gonna add ZMI support just yet, Encoded is supposed to have that in his script but I might just turn this into an AIO RC script and support practically everything. 

For the first issue, when is that happening? Is it teleporting to house from the altar then to castle wars? Or what is the process of events leading to that

I could add some customization for the pouch delays in a update, atm its just based off some abc2.

Share this post


Link to post
Share on other sites

Something else i've noticed is with the world hopping its hopping 1 world down or up which is actually pretty bad considering Pkers hop world by world I'm unsure whether you control any part of the world hopping but going down 1 world each time it see's a pker isnt the best :D

Do you think faster emptying of pouchs could be used?

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Arnlook said:

Something else i've noticed is with the world hopping its hopping 1 world down or up which is actually pretty bad considering Pkers hop world by world I'm unsure whether you control any part of the world hopping but going down 1 world each time it see's a pker isnt the best :D

Do you think faster emptying of pouchs could be used?

It is supposed to hop to random world, maybe it just got unlucky. 

Yes I can look into adding emptying pouches faster, at the moment it is how it is coded due to necessity to track the ess accurately.

Share this post


Link to post
Share on other sites
2 hours ago, godspower33 said:

It is supposed to hop to random world, maybe it just got unlucky. 

Yes I can look into adding emptying pouches faster, at the moment it is how it is coded due to necessity to track the ess accurately.

The anti-pk also seems to have issues regarding not realising its in the abyss and attempting to world hop :D
Which is causing majority of deaths :)

Edited by Arnlook

Share this post


Link to post
Share on other sites
8 hours ago, Arnlook said:

The anti-pk also seems to have issues regarding not realising its in the abyss and attempting to world hop :D
Which is causing majority of deaths :)

Alright, I will push fixes for that and the above issue regarding house tabs too later today.

  • Like 1

Share this post


Link to post
Share on other sites
On 2/24/2019 at 5:12 PM, godspower33 said:

Thanks haha, I don't think I'm gonna add ZMI support just yet, Encoded is supposed to have that in his script but I might just turn this into an AIO RC script and support practically everything. 

For the first issue, when is that happening? Is it teleporting to house from the altar then to castle wars? Or what is the process of events leading to that

I could add some customization for the pouch delays in a update, atm its just based off some abc2.

Yeah that would be amazing :)

It's Teleporting to house from the altar, looking around for a sec for the mounted glory then teleporting to castlewars and running towards the observatory. 

Delays would be sweet too :)

Share this post


Link to post
Share on other sites

Ok a few things.

 

Firstly, I'm 91 RC using all 4 pouches. It fills all 4 pouches, but at the altar it will withdraw from all 4 at once and clikc on altar (so theres some left in the giant pouch since it clicks it last for some reason) and then won't proceed to remove the rest of the giant pouches essence. I get 94 runes a run compared to what should be 108 a run because of this.

Secondly, it's not repairing the pouch. If I have a broken one it'll simply run into the essence, get into the middle ring and go to the altar - doesn't head towards the mage to fix it. I've restarted the script now so I'll see if it works this next break though. 

I'm using the simple glory tele to edge method, regular nature runes through abyss, stamina pots and food (but not held in inventory).

CHeers. 

edit: It even recognises the giant pouch has ess left in it (prog says Giant Pouch: -1 or whatever, instead of 0 like the rest), but still teleports to the bank anyways.

Edited by hehegurl

Share this post


Link to post
Share on other sites
5 minutes ago, hehegurl said:

Ok a few things.

 

Firstly, I'm 91 RC using all 4 pouches. It fills all 4 pouches, but at the altar it will withdraw from all 4 at once and clikc on altar (so theres some left in the giant pouch since it clicks it last for some reason) and then won't proceed to remove the rest of the giant pouches essence. I get 94 runes a run compared to what should be 108 a run because of this.

Secondly, it's not repairing the pouch. If I have a broken one it'll simply run into the essence, get into the middle ring and go to the altar - doesn't head towards the mage to fix it. I've restarted the script now so I'll see if it works this next break though. 

I'm using the simple glory tele to edge method, regular nature runes through abyss, stamina pots and food (but not held in inventory).

CHeers. 

edit: It even recognises the giant pouch has ess left in it (prog says Giant Pouch: -1 or whatever, instead of 0 like the rest), but still teleports to the bank anyways.

Do you have discord? When I wrote the script, I didn't use giant pouch so I might've not grabbed the correct id for the damaged giant pouch also I'll push out a fix for the not using all ess before banking

Share this post


Link to post
Share on other sites

just a few notes, I've just started using the trial. a few things i noticed, if you start the script with pouches already full it will just sit at the bank and do nothing.

- It had no issue going to repair my pouch, but after doing so, just sits at the dark mage until i forced it to go into the nature rift.

- because it repaired a pouch my total nats crafted that run was less than the usual 42 (3 pouches) so it sat there continuously trying to empty the pouches expected more ess to be there..

just a few things I've noticed so far, keep up the good work!

EDIT** another hour down and ran into the exact same issue when fixing the pouch. both times i've had to stop the script, finish the run, go back to the bank and start it up again.

Edited by Nodderz

Share this post


Link to post
Share on other sites
1 hour ago, Nodderz said:

just a few notes, I've just started using the trial. a few things i noticed, if you start the script with pouches already full it will just sit at the bank and do nothing.

- It had no issue going to repair my pouch, but after doing so, just sits at the dark mage until i forced it to go into the nature rift.

- because it repaired a pouch my total nats crafted that run was less than the usual 42 (3 pouches) so it sat there continuously trying to empty the pouches expected more ess to be there..

just a few things I've noticed so far, keep up the good work!

EDIT** another hour down and ran into the exact same issue when fixing the pouch. both times i've had to stop the script, finish the run, go back to the bank and start it up again.

Are these issues happening when using all four pouches or which pouches are you using?

Share this post


Link to post
Share on other sites
33 minutes ago, godspower33 said:

Are these issues happening when using all four pouches or which pouches are you using?

im under 75 RC so im using the first 3 pouches. it has no issues until this point, at which the whole script needs to be stopped.

Share this post


Link to post
Share on other sites

ok I've just finished the full 4 hour trial.

Firstly, For a new script you've done very well for yourself mate. I ran the script on and off for the full 4 hours and did a mix of nature and cosmics runes. the only issue I came across was the one i mentioned above about the pouches repair. that being said, Its a new script so I knew it would have to be used whilst im at the computer baby sitting. and roughly once an hour, after It repaired the pouch, i just finished that run and restarted the script.

I will definitely be keeping an eye on this and will have zero hesitation buying and using this script in the future after this small bug is sorted.

Thanks!

Share this post


Link to post
Share on other sites
2 hours ago, Nodderz said:

ok I've just finished the full 4 hour trial.

Firstly, For a new script you've done very well for yourself mate. I ran the script on and off for the full 4 hours and did a mix of nature and cosmics runes. the only issue I came across was the one i mentioned above about the pouches repair. that being said, Its a new script so I knew it would have to be used whilst im at the computer baby sitting. and roughly once an hour, after It repaired the pouch, i just finished that run and restarted the script.

I will definitely be keeping an eye on this and will have zero hesitation buying and using this script in the future after this small bug is sorted.

Thanks!

Thanks for the review :) I'll take a look and see whats causing the bug, not sure why it popped up all a sudden. It never had the issue before

  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/26/2019 at 11:16 AM, godspower33 said:

Thanks for the review :) I'll take a look and see whats causing the bug, not sure why it popped up all a sudden. It never had the issue before

Thought i'd check after the trial restarted to see if anything changed, It has not, however a bit of insight to the issue, it will constantly try to empty the pouch that has just been fixed because when its decayed it can't hold the same amount, the script thinks there still more ess to come out of the pouch, and instead of porting it keep trying to empty the pouch

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...