Jump to content

OneClickRegicide [Premium]


Recommended Posts

  • Replies 150
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This script will complete the quests Plague City, Biohazard, Underground Pass, and Regicide.  The script originally functioned only via script arguments.  There is now a GUI if no arguments are p

Underground pass hasn't been saving the grid paths for you, had a mistake in my file/path generator ? That fix among with a few others will be uploaded shortly. Fixes: Saving grid path

one thing i notice is that it withdraws exact amt of money it plans to spend from bank at start, maybe it would look more human if it clicked withdraw all and deposited leftovers at the end?

 

also after purchasing all the items it was afk stuck on depositing all, idk how long it was afk there but i came back like 12 minutes later

 

also when it withdraws best gear for acc to do quests in and it trains crafting to lvl 10 it doesn't deposit the items used to train crafting to level 10 before banking for gear and equiping it. So while it has 27 slots filled with leather chaps and bodies for training crafting it withdraws one piece of gear at a time and equips it and repeats, instead of banking all the crafting stuff and equipping all the gear in one go.

Edited by afinalblow
Link to post
Share on other sites

Various updates today:

  • Should deposit inventory before equipping gear if junk/crafting materials are detected
  • Setup functionality to specify the amount of GP to withdraw for Grand Exchange activities, and configured the default to be -1 ("All-but-one"). This option will become available with the GUI.
  • Issues getting stuck in leaf deadfall traps
  • Fixes for misconfigured .tribot folder that doesn't allow the grid path to be saved.
Edited by FALSkills
  • Like 1
Link to post
Share on other sites
1 hour ago, Coca Cola said:

I very rarely post on this forum nowadays, but god damn I just have to say well done. How many times did you have to complete each quest to gather the VarBits and other data? So intrigued. 

I record quests using OBS with trackers running, and then review the footage when writing the scripts.  I still tested this script hundreds of times before releasing, as there are a lot of moving parts.

  • Like 1
Link to post
Share on other sites
7 hours ago, Anarch said:

having an issue on one of my accounts, stuck on (withdrawing quest items) at ardy bank, starting plague city. all the quest items are in my inventory

I'm happy to take a look if you want to let me log into the account.  You can contact me on discord, FALSkills#1985 or private message me on here.

 

Edit: maybe you don't have stamina potions and have them enabled? Not sure without looking.  If you enable purchaseItems, it will buy all required items.

Edited by FALSkills
Link to post
Share on other sites
3 hours ago, FALSkills said:

I'm happy to take a look if you want to let me log into the account.  You can contact me on discord, FALSkills#1985 or private message me on here.

 

Edit: maybe you don't have stamina potions and have them enabled? Not sure without looking.  If you enable purchaseItems, it will buy all required items.

It was a problem with the staminas; It originally went to the GE and bought everything but stams (I probably had insufficient funds) and then it teleported to ardy got stuck on the ardy bank, so i manually bough the staminas and its working fine now

Thank you for the quick response :)

Edited by Anarch
Link to post
Share on other sites
3 hours ago, dovasla said:

Screenshot_95.png


No arguments used

Bank would open, error would happen, script stop (at GE, no quests done)

I just uploaded a fix that should remedy that issue, it is likely due to the script not finding any arrows of any type in your bank.  Not sure why that happened or why the script exited the purchase items code without purchasing anything.  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Our picks

    • What to expect from TRiBot moving forward.
        • Thanks
        • Like
      • 10 replies
    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 39 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 13 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...