Jump to content

OneClickRegicide [Premium]


Recommended Posts

  • Replies 150
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This script will complete the quests Plague City, Biohazard, Underground Pass, and Regicide.  The script originally functioned only via script arguments.  There is now a GUI if no arguments are p

Underground pass hasn't been saving the grid paths for you, had a mistake in my file/path generator ? That fix among with a few others will be uploaded shortly. Fixes: Saving grid path

On 6/14/2019 at 8:25 AM, kushad said:

beautiful script, only thing i can think of what id do different is using the west ardy tele tabs in the purchase list, it makes it faster to get into there

Thank you! That option will be available in the future. I hope to have major updates released by next weekend.

Link to post
Share on other sites

I am pushing back major updates, as they are not complete.  There is an argument for west ardougne teleport now, although I have not tested it.

Try adding the argument:
"useWestArdougneTeleport" separated by semi-colon from other arguments.  This should add it to both the purchase and supply lists.

Edited by FALSkills
  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...
On 6/30/2019 at 12:26 AM, kushad said:

Just pushed an update for that, thanks.

The next script update will include the GUI, and some new features such as custom equipment setups, profile saving/loading, and more.

I expect to have the update out no later than Friday, as I need to test some of the features in depth. 

You will of course be able to skip the GUI via all currently available arguments. The GUI will open if no arguments are present.

Link to post
Share on other sites
On 7/2/2019 at 3:53 PM, FALSkills said:

Just pushed an update for that, thanks.

The next script update will include the GUI, and some new features such as custom equipment setups, profile saving/loading, and more.

I expect to have the update out no later than Friday, as I need to test some of the features in depth. 

You will of course be able to skip the GUI via all currently available arguments. The GUI will open if no arguments are present.

I'm waiting for this release so I can purchase! Look promising friend, great work and despite the lack of activity on this thread i'm sure you have plenty of lurking eagerly waiting as well! 

Link to post
Share on other sites
On 7/8/2019 at 9:17 PM, kushad said:

https://gyazo.com/b69d6377ff472be65f84dd8a6eb87571
 

anyway we can follow the big spider probably save on some food 

@FALSkills

It's supposed to - but clearly isn't. I have modified some of the values to trigger the code to "move closer" to the spider and will test it locally before pushing those changes.

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...

GUI has finally been released!  Apologies for the delay, it was a combination of needing to test things and my own laziness.

There is only one new argument, which is a method to load profile via arg.  All other arguments still work.  The new argument is listed on the first page, but it is profile:Profile_Name_To_Load

Providing even a single argument will skip the GUI altogether.

Link to post
Share on other sites
2 hours ago, Anarch said:

i used to have this script run flawlessly but after the gui it seems buggy at times

I pushed some updates today which should hopefully resolve the issue. It was related to having the amount "0" for food_count, which should fill remaining inventory with food, but instead was behaving improperly.  If you continue to experience issues please contact me on via private message or on discord and I will help resolve them.

Link to post
Share on other sites

I am working on this now, sorry I was out of town for a couple days :(
 

Today's RS update seems to have added several new chat options and also adds a requirement of wearing Gas mask during Biohazard, so I am working on those issues now.  I will have a new version up ASAP.

 

Today's update also broke the object hooks for several of the integral quest objects for the questline, so I am working on bandaid fixes until tribot can fix the object hooks.

Edited by FALSkills
Link to post
Share on other sites
45 minutes ago, FALSkills said:

Just as an additional note, every quest seems to have had significant changes from today's update so I will be working/testing a bunch today to get all of these sorted.  I also will be ensuring that gui/equipment issues have been resolved.

Is there any chance we will be reimbursed some time after fixes have been implemented?

Link to post
Share on other sites
1 minute ago, dtrippp said:

Is there any chance we will be reimbursed some time after fixes have been implemented?

That's not possible for me to do, nor would I consider it as I'm going to have to put in 6+ hours to update this script today.  Every quest has had significant game-sided changes, and I am going to be spending pretty much the entire day working on it.  

Examples:

  • many of the quest object hooks are now broken so i have to implement work arounds to click them
  • new or different chat options in every quest
  • making fire arrows was completely changed
  • it is no longer possible to skip traps via walking 1 tile before them and walking 1 tile after them
  • ugp quest settings were completely changed, so i have to re-work the state finder

and i'm only 1/10th the way through UGP

  • Like 1
Link to post
Share on other sites

Locally, I have finished updating Biohazard, Underground Pass, and Regicide. I was able to reproduce and fix the Equipment issues as well.  I have to take a break for a bit, but I need to do the following still before updating the repo version:

  • Run Plague City to find any changes (all of my accs already had it done so I will run it on a fresh acc)
  • Run the whole questline on both magic and ranged modes to double check for any issues, and to try to pinpoint the issue where arrows were not being brought on ranged mode.

I hope to have the updates posted within 6-8 hours.

Edited by FALSkills
  • Thanks 1
Link to post
Share on other sites
6 hours ago, FALSkills said:

Updates are live. Please report any issues and I will work on them ASAP.

Thanks for your patience.

Thanks for picking this up so quick man, appriciate it!

 

It seems not to work for me tho.. I started the quest manually because i don't have 56 agility. Tried the argument and a self made GUI setup and both getting these errors after buying all supplies.

  • [13:46:44] Downloading script 'OneClickRegicide'.
  • [13:46:50] Script Started: OneClickRegicide.
  • [13:47:33] Setting up global walk condition.
  • [13:47:33] Disabled all randoms.
  • [13:47:36] Unable to continue questing due to skill reqs or user preferences.
  • [13:47:36] Script Ended: OneClickRegicide.
Edited by Koisryn
Link to post
Share on other sites
6 hours ago, Koisryn said:

Thanks for picking this up so quick man, appriciate it!

 

It seems not to work for me tho.. I started the quest manually because i don't have 56 agility. Tried the argument and a self made GUI setup and both getting these errors after buying all supplies.

  • [13:46:44] Downloading script 'OneClickRegicide'.
  • [13:46:50] Script Started: OneClickRegicide.
  • [13:47:33] Setting up global walk condition.
  • [13:47:33] Disabled all randoms.
  • [13:47:36] Unable to continue questing due to skill reqs or user preferences.
  • [13:47:36] Script Ended: OneClickRegicide.

It looks like you either unchecked the box for Underground Pass, or you don't have 25 ranged which is required to for Underground Pass.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Our picks

    • What to expect from TRiBot moving forward.
        • Thanks
        • Like
      • 10 replies
    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 39 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 13 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...