Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Jamie

[Premium] JNMZStarter - Automated NMZ Account Creation [CLI Support | 30+ Tasks | 20+ Quests | 10+ Skills | Advanced User Customisation]

Recommended Posts

Animal magnetism - script gets stuck whilst collecting ectotokens. Went down to the basement and filled buckets with slime but just idles there. Had to manually collect bones and return to the ectofunctus for script to start up again 

Share this post


Link to post
Share on other sites
21 minutes ago, potpots said:

Animal magnetism - script gets stuck whilst collecting ectotokens. Went down to the basement and filled buckets with slime but just idles there. Had to manually collect bones and return to the ectofunctus for script to start up again 

If it happens again can you please fill out a report in the following format so I can pinpoint the issue:

Issue: 
Stack Traces: (Pastebin link) 
Screenshot:

I'll try and recreate the issue locally in the mean time.

Share this post


Link to post
Share on other sites

Errors -
* Note, im running it from start to finish without changing any sequences. 
Sea slug
Trying to talk to Kennith, walks inside then clicks outside when it can click npc from location.
[19:20:06] [Debug] Failed to generate path to: (2766, 3291, 1)
[19:20:07] [Debug] Failed to generate path to: (2765, 3286, 1)
[19:20:13] [Debug] Failed to generate path to: (2765, 3291, 1)
If you manually click it works fine. I think its about 4 times this occurs.

Tree Gnome Village
Talking to tracker gnome 2,
It keeps going around in a loop and wont go inside to talk to the npc

 

As i keep using this i will post the small bugs i come across, there was a few more but nothing major. Good job on fixing the dwarf cannon one so quick.

Share this post


Link to post
Share on other sites
2 hours ago, gabrielspecter said:

Thanks for the update. Any chance you can add world-hopping after getting killed at Wildy Altar when leveling Prayer?

My accounts got camped out because it just kept running back on the same world.

Yeah I'm looking into it, just need to decide a way to handle it. :) Will hopefully be within the next few updates.

Share this post


Link to post
Share on other sites
1 hour ago, JCY said:

Script got stuck (on sea slug) talking to the boy in the shack and just kept going in and out (wish I had screenshot) It just repeated for hours. 

I'll run an account through shortly and get back to you. 

Share this post


Link to post
Share on other sites

Errors

Fight arena: Once it has collected armour from the chest it stays in room and doesnt go to the prison side of fight arena.

Mountain Daughter: At start fails to withdraw "Gloves", it take out every other item except the gloves; you can manually withdraw and close bank to continue script.

 

Also the above errors i mentioned before are still apparent. 

Share this post


Link to post
Share on other sites
Posted (edited)

Could you implement a kill switch? I keep seeing my accounts get stuck on random parts (this time in lummy bank after dying doing dragon bones) and they just loop guaranteeing a ban. Would be nice if the script could terminate if it looped the same action X times. 2nd account out of 6 to get stuck at some random part and loop forever. 

edit: another account stuck here

spacer.png

Edited by JCY

Share this post


Link to post
Share on other sites
2 hours ago, JCY said:

Could you implement a kill switch? I keep seeing my accounts get stuck on random parts (this time in lummy bank after dying doing dragon bones) and they just loop guaranteeing a ban. Would be nice if the script could terminate if it looped the same action X times. 2nd account out of 6 to get stuck at some random part and loop forever. 

edit: another account stuck here

spacer.png

Have you been interfering with the script at all? Your account was stuck during Prayer because it had 4 items in it's inventory which would only happen if protect item was selected. My script doesn't enable protect item, so it's something that would've have to of been done manually. I shall try and increase the amount of failsafes.

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, HeyImJamie said:

Have you been interfering with the script at all? Your account was stuck during Prayer because it had 4 items in it's inventory which would only happen if protect item was selected. My script doesn't enable protect item, so it's something that would've have to of been done manually. I shall try and increase the amount of failsafes.

Weird, happened again and the first time I was asleep, probably something else?

 

3rd account same bug, all had 3 dbones and the wildy amulet 

4th account same bug (saw it this time) It died and had 3 bones, withdrew amulet from bank and just sat there saying "withdrawing bones" 

Also after being killed does the bot hop? Since it got stuck I manually withdrew the bones but then it tele'd straight back and died again xD

Edited by JCY

Share this post


Link to post
Share on other sites
2 hours ago, JCY said:

Weird, happened again and the first time I was asleep, probably something else?

 

3rd account same bug, all had 3 dbones and the wildy amulet 

4th account same bug (saw it this time) It died and had 3 bones, withdrew amulet from bank and just sat there saying "withdrawing bones" 

Also after being killed does the bot hop? Since it got stuck I manually withdrew the bones but then it tele'd straight back and died again xD

Weird. I'm sure I pushed a fix for this the other day but I may have got mixed up. I'm heading off for today as it's late, I'll take a look in the morning.

Share this post


Link to post
Share on other sites
Just now, pattylight1 said:

Hey, a couple quests have disappeared  from the script. (dragon slayer, holy grail). 

Any guess what might have happened? thanks!

They should never have been / were never a part of this script. You can access the beta for JBotStarter - GDK Edition here: https://tribot.org/repository/script/id/3522

@JCY I've pushed an attempted fix for Prayer. Let me know how it goes. :) I'll be looking at adding worldhopping on death soon.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, HeyImJamie said:

They should never have been / were never a part of this script. You can access the beta for JBotStarter - GDK Edition here: https://tribot.org/repository/script/id/3522

@JCY I've pushed an attempted fix for Prayer. Let me know how it goes. :) I'll be looking at adding worldhopping on death soon.

Cool :D PM'd you another bug (had player info) during grand tree

 

Same bug on another account, I did 1 dialogue manually but the next and the next... don't work either :D 

Edited by JCY

Share this post


Link to post
Share on other sites

Update 18/05/2020:
- Added worldhopping on death for Prayer. This needs to be enabled in Advanced Preferences -> Prayer -> Worldhopping (All Editions).
- Fixed the dialogue issues on Grand Tree caused by last update (All Editions).
- Attempted a fix at the Statistic Tracker returning weird values.
- Added Client of Kourend (GDK Ed).
- Added Pirate's Treasure (GDK Ed).

@gabrielspecter I couldn't recreate the double withdrawing issue. If it happens to pop up again, could you get a gif and a debug?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...