Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

ltztakechi

java problems pls help

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By DizFunk
      Hi guys, I just started attempting to script. I bought VIP so I could write my own scripts. I've been having the hardest time setting up my eclipse to work with TRIBot. So far I have set up my eclipse to compile with JDK/JRE 8, TRIBot is being launched with JDK 8. Everything seems to be setup correctly, however I get this odd error message in my bot debug logs. I've attached a photo of the logs. 
      Here is what my class file looks like: 
      package scripts;
      import org.tribot.script.Script;
      import org.tribot.script.ScriptManifest;
      @ScriptManifest (authors = { "DizFunk" }, category = "Test", name = "Test")
      public class Test extends Script {
          @Override
          public void run() {
              println("Hello World!1");
          }
      }
       If anyone knows whats going on here it would be a big help

    • By schenkelenkel
      Getting this error, client won't start.

    • By voidk5
      Hey guys, I'm facing some problems with my Debian 8 VPS, currently I'm not able to install Java 8, I was using this as reference https://tecadmin.net/install-java-8-on-debian/ but as it says "IMPORTANT: Java 8 is no longer available to download publically. You can use below link to install Java 11."  Java 8 can't be downloaded anymore, so I tried to use Java 11, but TRiBot doesn't work with it. 
      Anyone can have with this? 
      I'll give more info if required.
       
       
    • Guest
      By Guest
      Hello, i am new here. 
      I need help. I can't login at all.
      As you can see the picture

      I can't fill the right captca because i can't resize the windows. Only small window like that xD.
      And second. When i try login my account. The result is...

      So what's the problem it is? What's solution? 
       
      Thank You.
    • Guest
      By Guest
      Hello, firstly i'd like to say that running a bot on mac is 1000x more difficult than running a bot on a windows. I've downloaded Tribot and have jdk-11.0.1.
      I keep getting an error which I've linked below. Please help as I've been trying to run a bot on this macbook forever. It seems impossible.
      Thanks,
      Medieval 

    • By syhler
      I'm trying to add a JSON library by adding every java file from https://github.com/stleary/JSON-java to my project. But it keeps giving me the error
      java.lang.NoClassDefFoundError: scripts/JSONObject Which makes sense because it fails to load the JSONObject. But why?
       Error Loading Local Script: JSONObject! I have tried to make a package inside the scripts package called "org.json" without any luck, I have also tried to put the files directly into scripts package.(Check picture for reference)

      I don't think the run method has anything to do with it, but it looks like this
      @Override public void run() { println("Hey Test"); JSONObject json = null; try { json = JsonParser.readJsonFromUrl("url"); } catch (IOException e) { e.printStackTrace(); } assert json != null; println(json.toString()); } JsonParser.readJsonFromUrl Comes from a class which is taken from StackOverflow - https://stackoverflow.com/questions/4308554/simplest-way-to-read-json-from-a-url-in-java- 
      And looks something like that
      public class JsonParser{ private static String readAll(Reader rd) throws IOException { StringBuilder sb = new StringBuilder(); int cp; while ((cp = rd.read()) != -1) { sb.append((char) cp); } return sb.toString(); } public static JSONObject readJsonFromUrl(String url) throws IOException, JSONException { InputStream is = new URL(url).openStream(); try { BufferedReader rd = new BufferedReader(new InputStreamReader(is, Charset.forName("UTF-8"))); String jsonText = readAll(rd); JSONObject json = new JSONObject(jsonText); return json; } finally { is.close(); } } } Yes, I do have VIP (at least for 2 days) and I'm using IntelliJ Idea. To set my project up I have used the guide from here.
      Thank you for your time  
       
    • Guest
      By Guest
      I've nearly got TRiBot running on an Ubuntu machine but have run into an error with the loader.  When I run the loader for the first time and it populates the dependencies folder, the file togl.dll get's downloaded instead of libTOGL.so which TRiBot.jar eventually looks for.  Error looks like this:
      Loading TOGL Loading: /home/<user>/.tribot/dependancies/libTOGL.so Exception in thread "AWT-EventQueue-1" java.lang.UnsatisfiedLinkError: Can't load library /home/<user>/.tribot/dependancies/ibTOGL.so Inside my dependencies folder there's a file called togl.dll.  The bug report forum says I need to post here before I can post there.
    • By Jigglepurf
      So i try to start triBot and it says "Files loaded triBot will now start" and then the window closes and Nothing else happens. Am i doing something wrong?
    • By sgt p0wned
      hey guys, im getting an error
      [23:20:56] TRiBot Release 9.307_0 loaded. (1.8.0_102:C:\Program Files (x86)\Java\jre1.8.0_102)
      [23:20:56] Loading human mouse movement data.
      [23:20:57] Successfully loaded human mouse data.
      [23:21:09] Exception in thread "0"
      [23:21:09] java.lang.ArrayIndexOutOfBoundsException: 1
      [23:21:09]     at java.util.ArrayList.elementData(Unknown Source)
      [23:21:09]     at java.util.ArrayList.get(Unknown Source)
      [23:21:09]     at obf.nh.kH(bd:304)
      [23:21:09]     at obf.nh.yg(bd:75)
      [23:21:09]     at obf.Ql.LK(bh:523)
      [23:21:09]     at obf.RK.Da(ao:27)
      [23:21:09]     at obf.xk.m(wm:562)
      [23:21:09]     at obf.xk.<init>(wm:161)
      [23:21:09]     at obf.Ql.<init>(bh:162)
      [23:21:09]     at obf.RK.<init>(ao:192)
      [23:21:09]     at obf.vJ.<init>(gg:113)
      [23:21:09]     at obf.EG.run(af:738)
      [23:21:09]     at java.lang.Thread.run(Unknown Source)
      [23:21:09] Exception in thread "-1"
      [23:21:09] java.lang.ArrayIndexOutOfBoundsException: 1
      [23:21:09]     at java.util.ArrayList.elementData(Unknown Source)
      [23:21:09]     at java.util.ArrayList.get(Unknown Source)
      [23:21:09]     at obf.nh.kH(bd:304)
      [23:21:09]     at obf.nh.yg(bd:75)
      [23:21:09]     at obf.Ql.LK(bh:523)
      [23:21:09]     at obf.RK.Da(ao:27)
      [23:21:09]     at obf.xk.m(wm:562)
      [23:21:09]     at obf.xk.<init>(wm:161)
      [23:21:09]     at obf.Ql.<init>(bh:162)
      [23:21:09]     at obf.RK.<init>(ao:192)
      [23:21:09]     at obf.vJ.<init>(gg:113)
      [23:21:09]     at obf.EG.run(af:738)
      [23:21:09]     at java.lang.Thread.run(Unknown Source)
       
      Is there a known fix?
      FOUND A FIX.. I'm Blind..
      A username and password helps.. forgot i just deleted .tri file.
      My bad..
  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...