Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Encoded

Auto Crafter Pro

Recommended Posts

12 minutes ago, Failed4life said:

Suggestions

-Arg support

-Travel to Edge Furnace, Lumbridge Bank, or closest bank depending on crafting method (e.g Spinning -> Travel to Lumbridge bank, or Jewlery -> Travel to Edgeville Bank)

-Larger Instance packages

?

- Has support to use last saved tasks via arguments

- Already does this I believe. The code is there, but I haven't tested it fully.

- 15 for $15 is as low as I am going, if you want more instances you can buy the package multiple times

Edited by Encoded

Share this post


Link to post
Share on other sites
On 8/10/2019 at 3:04 PM, Encoded said:

I've developed software that records me playing the game legitimately and then outputs data that I use in the development of my scripts to replicate my game play in an effort to be as human-like as possible.

Stuff like this is why you are one of my favorite scripters here at Tribot. 

I've been using your scripts on and off for months at a time and have never been banned once (I use LG and good practices). When this script was free I was able to get to 85 crafting and I pretty much stopped there, but I'm sure I could of gotten to 99. I'm glad to hear this got premium because it really deserves it. Will be buying when I need crafting exp again :D. 

 

P.S to others: His auto tithe farm is really nice got me to level 90 just don't abuse ;p.

Edited by Shane9000100

Share this post


Link to post
Share on other sites

Great script so far as usual. There is something i run into when i lag a bit. And for some reason the bot will click on an already made air staff and will afk until it ends script due to no EXP gains. I am guessing at the time it made the last air staff, the client lagged and so it clicked the air orb and the battlestaff just as it makes it making it break. A failsafe could be clicking the inventory or the bank twice or something to deselect the battlestaff.

Share this post


Link to post
Share on other sites
7 minutes ago, Encoded said:

What does the debug say?

Appreciate you getting back to me.

  • [12:22:59] at scripts.api.fa.E(Banking.java:340)
  • [12:22:59] at scripts.crafter.x.k.o.b(Bank.java:93)
  • [12:22:59] at scripts.crafter.x.k.o.F(Bank.java:56)
  • [12:22:59] at scripts.crafter.x.k.o.E(Bank.java:43)
  • [12:22:59] at scripts.api.script.TaskScript.run(TaskScript.java:100)
  • [12:22:59] at java.lang.Thread.run(Thread.java:748)
  • [12:22:59] Script Ended: Auto Crafter Pro.

Is what it comes back with during banking and ends. 

Share this post


Link to post
Share on other sites

hi i am currently getting errors when i try and make black dhide bodies, getting this error (jsut purchased script so first time setting up)

 

 

  • [09:24:54] java.lang.ArrayIndexOutOfBoundsException: 4767748
  • [09:24:54] at scripts.api.fa.E(Banking.java:340)
  • [09:24:54] at scripts.crafter.x.k.o.b(Bank.java:93)
  • [09:24:54] at scripts.crafter.x.k.o.F(Bank.java:56)
  • [09:24:54] at scripts.crafter.x.k.o.E(Bank.java:43)
  • [09:24:54] at scripts.api.script.TaskScript.run(TaskScript.java:100)

can you help guide me or tel lme what i need to do to fix this? than kyou!

Share this post


Link to post
Share on other sites
On 9/28/2019 at 1:28 AM, yungnoodles said:

Appreciate you getting back to me.

  • [12:22:59] at scripts.api.fa.E(Banking.java:340)
  • [12:22:59] at scripts.crafter.x.k.o.b(Bank.java:93)
  • [12:22:59] at scripts.crafter.x.k.o.F(Bank.java:56)
  • [12:22:59] at scripts.crafter.x.k.o.E(Bank.java:43)
  • [12:22:59] at scripts.api.script.TaskScript.run(TaskScript.java:100)
  • [12:22:59] at java.lang.Thread.run(Thread.java:748)
  • [12:22:59] Script Ended: Auto Crafter Pro.

Is what it comes back with during banking and ends. 

 

8 hours ago, ewalb said:

hi i am currently getting errors when i try and make black dhide bodies, getting this error (jsut purchased script so first time setting up)

 

 

  • [09:24:54] java.lang.ArrayIndexOutOfBoundsException: 4767748
  • [09:24:54] at scripts.api.fa.E(Banking.java:340)
  • [09:24:54] at scripts.crafter.x.k.o.b(Bank.java:93)
  • [09:24:54] at scripts.crafter.x.k.o.F(Bank.java:56)
  • [09:24:54] at scripts.crafter.x.k.o.E(Bank.java:43)
  • [09:24:54] at scripts.api.script.TaskScript.run(TaskScript.java:100)

can you help guide me or tel lme what i need to do to fix this? than kyou!

Fixed

Share this post


Link to post
Share on other sites

something that desperately needs to change is that when making jewellery in edgeville each time it goes to withdraw supplies, it left clicks the "withdraw quantity" option which is super suspect each time. it should be on by default

 

hopefully its a quick fix :)

 

big fan of your scripts, i really enjoyed tithe, wintertodt and fishing.

Edited by beake

Share this post


Link to post
Share on other sites
2 hours ago, beake said:

something that desperately needs to change is that when making jewellery in edgeville each time it goes to withdraw supplies, it left clicks the "withdraw quantity" option which is super suspect each time. it should be on by default

 

hopefully its a quick fix :)

 

big fan of your scripts, i really enjoyed tithe, wintertodt and fishing.

Try deleting your hooks.dat
The game setting that is associated with what option is selected is returning weird values for some reason but whenever I go to test it works fine for me.

Share this post


Link to post
Share on other sites

i've deleted my hooks.dat and the jagex cache and the same problem persists. everytime it goes to withdraw the gold it first clicks on the left click "quantity" and then proceeds to withdraw. 

 

going to wait till this is fixed because 10 hours of gold bars is suspicious as hell to do that everytime since i dont think anyone would ever do that normally 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...