Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

DISCONTINUED - EzQuester v1


Recommended Posts

  • Replies 317
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Script discontinued.   

Please use the requested bug report format. It thinks you are missing an item but I can't figure out which item without checking the report format.  Try also using the "purchase" argument to get it to

Thank you for working on this,while it may be leaving 😭 I'll always remember how much time you saved my main 😭 if i ever meet you I'll buy u a beer 😭 have a good one 

Posted Images

3 hours ago, Archhh said:

all the actions seem very delayed, is there a way to make them respond faster?

Are you using an argument to modify the time between actions? That may be why. Default is 100-200ms between actions which is very quick. 

Otherwise, you are going to need to be much more specific if you want any help.  Like which specific actions in the script are delayed for you. You can also try deleting the jagex cache if all scripts are behaving abnormally for you.  Following the bug report format in the first post will help greatly too.

Link to post
Share on other sites
48 minutes ago, FALSkills said:

Are you using an argument to modify the time between actions? That may be why. Default is 100-200ms between actions which is very quick. 

Otherwise, you are going to need to be much more specific if you want any help.  Like which specific actions in the script are delayed for you. You can also try deleting the jagex cache if all scripts are behaving abnormally for you.  Following the bug report format in the first post will help greatly too.

No I haven't used an argument to modify the time between actions, is this considered a bug? it just seems like it takes awhile to buy GE items etc.

What Would be the argument to increase the reaction time?

Edited by Archhh
Link to post
Share on other sites
18 hours ago, Archhh said:

No I haven't used an argument to modify the time between actions, is this considered a bug? it just seems like it takes awhile to buy GE items etc.

What Would be the argument to increase the reaction time?

"minsleep:X" - sets the minimum sleep between actions to X. default 100 (ms)
"maxsleep:X" - sets the maximum sleep between actions to X. default 200 (ms)

if you are on LG, GE purchasing is just going to take a while. no avoiding it really due to the fact that it's heavily using interfaces, which take longer to load on LG.

I will probably look at optimizing it in the future as it's fairly old code.

Link to post
Share on other sites
38 minutes ago, FALSkills said:

"minsleep:X" - sets the minimum sleep between actions to X. default 100 (ms)
"maxsleep:X" - sets the maximum sleep between actions to X. default 200 (ms)

if you are on LG, GE purchasing is just going to take a while. no avoiding it really due to the fact that it's heavily using interfaces, which take longer to load on LG.

I will probably look at optimizing it in the future as it's fairly old code.

Thanks for the response and yes I'm on LG - appreciate help and amazing script thus far.

  • Like 1
Link to post
Share on other sites
46 minutes ago, cass2186 said:

Noticed on several accounts click "I'm looking for a quest" when talking to veos for x marks the spot. Runs fine after I manually do it

 

I will need the full message to fix it including punctuation.  I will try to grab it later.  I am guessing that this is an additional quest option when Client of Kourend quest is not complete, but not sure.

Link to post
Share on other sites
47 minutes ago, FALSkills said:

I will need the full message to fix it including punctuation.  I will try to grab it later.  I am guessing that this is an additional quest option when Client of Kourend quest is not complete, but not sure.

If I run another account through it I'll get it. It is when Client of Kourend is not complete.

Link to post
Share on other sites
18 hours ago, FALSkills said:

I will need the full message to fix it including punctuation.  I will try to grab it later.  I am guessing that this is an additional quest option when Client of Kourend quest is not complete, but not sure.

The line it doesn't get is

"I'm looking for a quest."

 

Spelt exactly like that with the period in there.

Link to post
Share on other sites
6 hours ago, ruthless1994 said:

it would be nice if  you add "read ardougne teleport scroll" after plague city completion :)

I will add this very shortly, and thought that it was already designed to do so.. 😡

2 hours ago, Horns said:

How easy to set up is this one?

is it easy and reliable?

It's not easy if you are unfamiliar with tribot or using arguments for programs.

I think it's quite reliable myself, but I am certainly biased.

Link to post
Share on other sites

Today i'm testing out EzQuester... so far I loaded it up with arguments and its going to town buying all the items.. I ran it yesterday and it did awesome BTW. One thing that comes to mind for me right out the gate is that I set it up to do several quests, and it pulls out the exact calculated amount of GP to buy the required items for all those quests. While it seems to be working great and all... it doesn't seem very human-like to me to grab out 53218 gp from a stack to buy a list of items. xD in the big picture, I'm not sure how much that would ever even matter.. I will keep you posted how it runs though, so far so good.

Link to post
Share on other sites
7 hours ago, High Order said:

Today i'm testing out EzQuester... so far I loaded it up with arguments and its going to town buying all the items.. I ran it yesterday and it did awesome BTW. One thing that comes to mind for me right out the gate is that I set it up to do several quests, and it pulls out the exact calculated amount of GP to buy the required items for all those quests. While it seems to be working great and all... it doesn't seem very human-like to me to grab out 53218 gp from a stack to buy a list of items. xD in the big picture, I'm not sure how much that would ever even matter.. I will keep you posted how it runs though, so far so good.

I don't really see how or why that would ever affect ban rates.  It is a fairly randomly generated number associated with the required GP to purchase all items, with a baseline multiplier to ensure that it has more than adequate gold considering market fluctuations.  Sure, I could round up to the nearest thousand or ten thousand, but then you would be creating the exact same "pattern" that you are proposing exists. Some people spam digits to withdraw, some people fill in clean numbers, some people don't even know that you can type "k" or "m" into enter amount menus.

Edited by FALSkills
  • Like 1
Link to post
Share on other sites
3 minutes ago, FALSkills said:

I don't really see how or why that would ever affect ban rates.  It is a fairly randomly generated number associated with the required GP to purchase all items, with a baseline multiplier to ensure that it has more than adequate gold considering market fluctuations.  Sure, I could round up to the nearest thousand or ten thousand, but then you would be creating the exact same "pattern" that you are proposing exists. Some people spam digits to withdraw, some people fill in clean numbers, some people don't even know that you can type "k" or "m" into enter amount menus.

I didn't know if it would matter for anything or not, ran about 16 quests today in one argument with very little attention needed, it got stuck a couple times on tears of guthix, but that's really about it.. had some trouble crossing the jumping stones, and then probably a special case, but my account already had the lamp made into sapphire lense and it seemed to throw it off track.. I'm super pleased with the script so far

Link to post
Share on other sites

Noticed a small bug with Priest in peril quest. It takes 15 essence + food on the 2nd trip to the temple. It turns in those 15, but then when going to the bank it isn't registering that it already turned in those 15, so when it sees 35 in the bank, it thinks it is 15 short and goes to the GE to buy more.

It's easy enough to start with extra essence to avoid it, but figured it was worth mentioning

Link to post
Share on other sites
On 11/17/2019 at 10:17 AM, Adventure_Time said:

Noticed a small bug with Priest in peril quest. It takes 15 essence + food on the 2nd trip to the temple. It turns in those 15, but then when going to the bank it isn't registering that it already turned in those 15, so when it sees 35 in the bank, it thinks it is 15 short and goes to the GE to buy more.

It's easy enough to start with extra essence to avoid it, but figured it was worth mentioning

Should be fixed in this release, thanks

Link to post
Share on other sites

Used this script on several accounts and here are common problems that you should be aware of : Client of kourend- at start of the quest talking to Veos doesnt choose option to travel 
Plague city- doesnt read scroll at the end of quest so if you have biohazard quest selected it automatically buys ardy tabs but dont use them when you going from guidor house to elena, so it walks from varrock to ardougne, so if youre low hp lvl you die at wolfs in taverley
Biohazard - at the end at guidors house opens/close doors for hours be aware of it 

On 11/17/2019 at 5:17 PM, Adventure_Time said:

Noticed a small bug with Priest in peril quest. It takes 15 essence + food on the 2nd trip to the temple. It turns in those 15, but then when going to the bank it isn't registering that it already turned in those 15, so when it sees 35 in the bank, it thinks it is 15 short and goes to the GE to buy more.

It's easy enough to start with extra essence to avoid it, but figured it was worth mentioning

this one too 

Digsite - after 3rd test stuck- doesnt grab spicemen jar, so you cant find ancient talisman 

Link to post
Share on other sites
18 hours ago, ruthless1994 said:

Used this script on several accounts and here are common problems that you should be aware of
Client of kourend- at start of the quest talking to Veos doesnt choose option to travel 
Plague city- doesnt read scroll at the end of quest so if you have biohazard quest selected it automatically buys ardy tabs but dont use them when you going from guidor house to elena, so it walks from varrock to ardougne, so if youre low hp lvl you die at wolfs in taverley
Biohazard - at the end at guidors house opens/close doors for hours be aware of it 

this one too 

Digsite - after 3rd test stuck- doesnt grab spicemen jar, so you cant find ancient talisman 

There is a bug report format in the first post.  That is how you report issues to me so that I can fix them.  Giving little bits of information is very often unhelpful.

Now let's go through each "report":
 

Quote

Client of kourend- at start of the quest talking to Veos doesnt choose option to travel 

Please provide the chat option that isn't being used and I can take a look at it.  This quest has unique chat options based upon other completed quests.  I will happily add it if you can give me the information required.

Quote

Plague city- doesnt read scroll at the end of quest so if you have biohazard quest selected it automatically buys ardy tabs but dont use them when you going from guidor house to elena, so it walks

This will be added in the next update.

Quote

Biohazard - at the end at guidors house opens/close doors for hours be aware of it 

This has been fixed and will be in the next update.

Quote

Digsite - after 3rd test stuck- doesnt grab spicemen jar, so you cant find ancient talisman 

The script cannot start looking for the ancient talisman unless it has the specimen jar in the code. Please provide a bug report using the proper bug report format.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Our picks

    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 37 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 10 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...