Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

FALSkills

DISCONTINUED - EzQuester v1

Recommended Posts

Bot just loops at GE trying to buy items until it fails and stops script.

Arguments: purchase;dragonslayer;plaguecity;junglepotion;biohazard;clientofkourend;merlins;treegnomevillage;mousespeed:200;minsleep:250;maxsleep:500

 

Edited by thrice98

Share this post


Link to post
Share on other sites
7 hours ago, thrice98 said:

Bot just loops at GE trying to buy items until it fails and stops script.

Can you please edit your post and put the debug in a spoiler? That is why the bug report format on the first post requests it as a text file or link.  Please submit all future bug reports using that format.

The issue is most likely fixed, please try it again.

Share this post


Link to post
Share on other sites
4 hours ago, FALSkills said:

Can you please edit your post and put the debug in a spoiler? That is why the bug report format on the first post requests it as a text file or link.  Please submit all future bug reports using that format.

The issue is most likely fixed, please try it again.

Still doing it. I'll post the debug again tomorrow.

Share this post


Link to post
Share on other sites
1 hour ago, totes said:

Also, if you don't have enough coins, it bugs out. withdraws coins, opens ge, realizes not enough coins, opens bank, deposits coins, withdraws coins and repeat..

It should do that a few times before exiting the script due to failing too many tasks in a row.  I don't plan on changing that behavior.

Share this post


Link to post
Share on other sites
27 minutes ago, totes said:

Does it buy items for same price all the time? or is it randomized? Right now it seems like it keeps buying the same item for the same price everytime it needs it. creates a pattern?

It depends on the item. Some items are purchased at fixed prices, others are purchased based upon their GE values.  All items will buy at increased prices, regardless if they are fixed or GE based, if the OSBuddy price is higher.

If you have any additional questions like this, feel free to join my discord. 

Share this post


Link to post
Share on other sites
Posted (edited)

Very good script! Has worked almost flawlessly. My only pet peeves I noticed, is I set a weapon for the Adamant scimitar (which I already had equipped), yet it went and bought another on the GE! Also the teleporting is very clever, but has room for improvement. Even though I have the mage level and runes in my bank or inven, it refuses to use them and just keeps buying tele tabs on GE and using those instead...


The script or walker looked to have bugged out on The Knight's Sword. Which I believe is not exactly 'this script' is it its own module? When stood at the ladder before going down to the Ice Warriors, the script was holding for run energy and then just doing nothing when it was ready to go. But the script mentioned failure on the Walker's end. But if I just manually moved on myself down the ladders and moved in the cave, it picked itself up and generated a path and started itself up again.

Edit: Also for combat when using magic in quests, by default it seems to go for Fire Strike - anyway it can be coded to read magic level, and use say Fire Bolt if 37+ etc?

Edit2: Another thought, it's coded to be able to use Stamina pots - any reason it can't utilise Super energy pots too? (much cheaper)

Edited by Aerosparx

Share this post


Link to post
Share on other sites
21 hours ago, Aerosparx said:

Even though I have the mage level and runes in my bank or inven, it refuses to use them and just keeps buying tele tabs on GE and using those instead...

Depends on how the individual scripts were coded. Some allow customization, some don't.  For future quest releases and planned future updates, these options are customizable.

21 hours ago, Aerosparx said:

My only pet peeves I noticed, is I set a weapon for the Adamant scimitar (which I already had equipped), yet it went and bought another on the GE! 

Added equipment check to Priest in Peril purchase workflow.  All other quests which purchased the weapon already had the check.

21 hours ago, Aerosparx said:

The script or walker looked to have bugged out on The Knight's Sword. Which I believe is not exactly 'this script' is it its own module? When stood at the ladder before going down to the Ice Warriors, the script was holding for run energy and then just doing nothing when it was ready to go. 

It was waiting for run energy. Please provide a bug report using the bug report format on the first post if you think there is an issue.

21 hours ago, Aerosparx said:

Edit: Also for combat when using magic in quests, by default it seems to go for Fire Strike - anyway it can be coded to read magic level, and use say Fire Bolt if 37+ etc?

Combat configurations are not customizable yet.

21 hours ago, Aerosparx said:

Edit2: Another thought, it's coded to be able to use Stamina pots - any reason it can't utilise Super energy pots too? (much cheaper)

Stamina pots are 3x more efficient than Super energy potions and less than 3x the cost, according to tests by a random redditor. Super energies would also require consuming additional inventory spaces for the same distances.  I don't plan on adding support for them.

Share this post


Link to post
Share on other sites
2 hours ago, troopafox22 said:

What is the proper "weaponname:x" for something like abyssal whip? I am writing weaponname:AbyssalWhip but it doesnt work. Is an underscore necessary?

weaponname:Abyssal whip
Note that it only works on a few, specific quests, namely: Holy Grail, Priest in Peril, Dragon Slayer
I've been working on building out the ability to specific weapon/spell/etc for all quests but I still have a lot more work to do!

Share this post


Link to post
Share on other sites

Hi I try start the script and the logo pops up then closes any thoughts? I am new but would love to purchase this. Im unsure how to configure?

  • [16:44:44] Downloading script 'EzQuester v1'.
  • [16:44:48] Script Started: EzQuester v1.
  • [16:44:49] Setting up global walk condition.
  • [16:44:49] Script not configured. Requires script arguments. View list of arguments here: https://pastebin.com/T4jf9hYL
  • [16:44:49] java.lang.NullPointerException
  • [16:44:49] at scripts.ezquesters.ezquester.EzQuester.C(EzQuester.java:309)
  • [16:44:49] at scripts.ezquesters.ezquester.EzQuester.run(EzQuester.java:197)
  • [16:44:49] at java.lang.Thread.run(Thread.java:748)
  • [16:44:49] Script Ended: EzQuester v1.

Share this post


Link to post
Share on other sites
5 hours ago, owen25 said:

Hi I try start the script and the logo pops up then closes any thoughts? I am new but would love to purchase this. Im unsure how to configure?

  • [16:44:44] Downloading script 'EzQuester v1'.
  • [16:44:48] Script Started: EzQuester v1.
  • [16:44:49] Setting up global walk condition.
  • [16:44:49] Script not configured. Requires script arguments. View list of arguments here: https://pastebin.com/T4jf9hYL
  • [16:44:49] java.lang.NullPointerException
  • [16:44:49] at scripts.ezquesters.ezquester.EzQuester.C(EzQuester.java:309)
  • [16:44:49] at scripts.ezquesters.ezquester.EzQuester.run(EzQuester.java:197)
  • [16:44:49] at java.lang.Thread.run(Thread.java:748)
  • [16:44:49] Script Ended: EzQuester v1.

Hi, please read the first post on this thread. It should have all of the information you need, including the list of arguments and how to use arguments.

Share this post


Link to post
Share on other sites

I believe due to the overnight update, this specific script is broken with banking (and probably many other scripts that rely on banking). It appears they made some pretty big changes in game to banking (being able to equip items direct from bank etc). When i run the script, it fails to pull gold out of the bank or even determine stock on items.

Client Debug:

https://pastebin.com/CzGd8ECM

Bot Debug:

https://pastebin.com/Z2TzWfhe

 

The arguments in the pastebin. I tried a self made argument and the argument builder in your post, both having issues. Also tried on a different computer, same issue. To also add, tried with the packaged Open JDK and jdk102, no change.

 

Share this post


Link to post
Share on other sites
1 hour ago, osrsgf001 said:

I believe due to the overnight update, this specific script is broken with banking (and probably many other scripts that rely on banking). It appears they made some pretty big changes in game to banking (being able to equip items direct from bank etc). When i run the script, it fails to pull gold out of the bank or even determine stock on items.

Client Debug:

https://pastebin.com/CzGd8ECM

Bot Debug:

https://pastebin.com/Z2TzWfhe

 

The arguments in the pastebin. I tried a self made argument and the argument builder in your post, both having issues. Also tried on a different computer, same issue. To also add, tried with the packaged Open JDK and jdk102, no change.

 

Looks like a bug due to the rs client update

https://gitlab.com/groups/trilez-software/-/issues

Share this post


Link to post
Share on other sites

Hello,
I've noticed a bug with the Vampire Slayer quest.
After acquiring the stake, the bot banks it and then won't recognise that it has done this part of the quest, it will get stuck in a continuous loop for hours of walking and talking to the guy in the pub and back to the bank again etc.

Share this post


Link to post
Share on other sites
On 1/13/2020 at 4:40 PM, dodgedave said:

Hello,
I've noticed a bug with the Vampire Slayer quest.
After acquiring the stake, the bot banks it and then won't recognise that it has done this part of the quest, it will get stuck in a continuous loop for hours of walking and talking to the guy in the pub and back to the bank again etc.

Should be fixed.

On 1/12/2020 at 3:54 PM, Anarch said:

Suggestion: An option to just start Dragonslayer upto the point of unlocking antidragon shield

I'll look into adding that.

Share this post


Link to post
Share on other sites

@FALSkills

At priest in peril it won't use a custom weapon, it keeps trying to use a adamant scimitar.

My arguments:

purchase;usedueling;useglory;usecombatbrace;stamina;staminapurchasecount:10;Staminacount:1;animalmagnetism;priestinperil;disableidler;mousespeed:160;Magic shortbow (i);

(made by the argument builder from the original post)

 

Share this post


Link to post
Share on other sites
6 hours ago, Flax said:

@FALSkills

At priest in peril it won't use a custom weapon, it keeps trying to use a adamant scimitar.

My arguments:

purchase;usedueling;useglory;usecombatbrace;stamina;staminapurchasecount:10;Staminacount:1;animalmagnetism;priestinperil;disableidler;mousespeed:160;Magic shortbow (i);

(made by the argument builder from the original post)

 

"weaponname:Magic shortbow (i)"

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...