Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Beg

BEG Poh Planks

Recommended Posts

title.png.c80bf168c47557f6fa2bec0796abfd4c.png

rbSM1kr.png

BEWARE: At the current version, this script is meant to be run on a PvP world.
                  To mitigate deaths, I advise you to move your player-owned house to a remote location.
                  Use at your own risk. 

Turns logs into planks at the player-owned house by sending your Demon Butler to the sawmil. Banks at lumbridge or camelot PvP bank chests.
Potentially millions of gp per hour with the right prices.

Features:
- Support to all plank types (Regular/Oak/Teak/Mahogany)
- Support to Lumbridge/Camelot PvP chest banks
- Death recovery
- Mouse movement anticipation for higher efficiency
- Anti-pk features such as setting private status to offline, teleporting away from outside the house asap, and avoid being lured to the risk zones
- Basic muling

Level Requirements:
- 50 Construction
- 40 Magic (Lumbridge Bank) / 45 Magic (Camelot Bank)

Item Requirements:
- Dust battlestaff / Mystic dust staff / Staff of air / Air battlestaff
- Coins
- Regular / Oak / Teak / Mahogany logs
- Law runes
- Earth runes if using Staff of air or Air battlestaff

Other Requirements:
- Own a player-owned house
- Have a Demon Butler hired
- Have a dining room with a bell

How to use:
- Equip the Staff of air / Dust battlestaff / Mystic dust staff
- Go to either camelot or lumbridge PvP bank chest safe area
- Start the script 
  Muling
  - Use the allowed mule to manually trade your accounts. Trade over more logs, laws and coins and you'll recieve the remaining logs, laws, coins, and all the planks made.

Settings:
To get the most efficiency, you'd want the butler to teleport to you right away everytime you call him.
The poh configuration i found out work best are this 3 only rooms:
  - northwest of portal: 1 bedroom with doors facing north and east

  - north of portal: 1 dining room with doors facing east, north and west
  - northeast of portal: 1 bedroom with doors facing north and west

Arguments:
- world
- bank
- plank
- mule
E.g. (exact worlds change every 2 weeks)
        world=324, bank=lumbridge, plank=regular
        world=324, bank=camelot, plank=oak, mule=zezima
        world=343, bank=lumbridge, plank=teak
        world=392, bank=camelot, plank=mahogany

Proggies: (Its from an older paint version)

 

screenshot.png.45d99cd7deb6968b4581f658b4e28cc6.png

 

Edited by Beg

Share this post


Link to post
Share on other sites
4 hours ago, rs06botHein said:

Sweet! Does it have any antiban?

Theres not many situations where ABC2 can be applied. But it uses ABC2 idle methods (move mouse out screen, move camera, etc) when waiting for teleports to complete.
Also, i optimized the script for speed by using threads to anticipate some actions such as mouse movements (just like any regular player would). Thats how it can achieve close to 7k planks/h.

Edited by Beg
  • Like 1

Share this post


Link to post
Share on other sites

Hi there! I've tried using both locations with staff of air, neither worked for me. IT wouldn't withdraw Earth Runes and when they were in the inventory they deposited them. At Lumbridge it withdraws everything properly but then continues to bank and try to withdraw more logs and then goes wonky and clicks and flings the mouse everywhere. Hope that helps!

Share this post


Link to post
Share on other sites
On 11/29/2019 at 4:05 AM, ArrowZinger said:

Hi there! I've tried using both locations with staff of air, neither worked for me. IT wouldn't withdraw Earth Runes and when they were in the inventory they deposited them. At Lumbridge it withdraws everything properly but then continues to bank and try to withdraw more logs and then goes wonky and clicks and flings the mouse everywhere. Hope that helps!

Thats very odd, was your tribot version updated to the last osrs update?

Share this post


Link to post
Share on other sites
21 hours ago, lb123 said:

Hey, I have been having some issues running the bot today. Everytime i try to start the bot it immediately ends the script.

 

8 hours ago, Sidesteppin12 said:

This script doesn't work anymore. Can you please fix it? All it says is "script started" "script ended" it instantly ends once u start it... wtf

Can you try now pls?

Share this post


Link to post
Share on other sites

Okay, i got the bot working. For some reason the theme on the tribot client was conflicting with the bot and not allowing me to select a pvp world nor what planks to make. 

 

The bot is working now, however I have to babysit it, because after calling the servant the bot has issues navigating back to the spellbook.

Share this post


Link to post
Share on other sites
8 hours ago, lb123 said:

Okay, i got the bot working. For some reason the theme on the tribot client was conflicting with the bot and not allowing me to select a pvp world nor what planks to make. 

 

The bot is working now, however I have to babysit it, because after calling the servant the bot has issues navigating back to the spellbook.

If you're having difficulties with interfaces:
- Start the script on a pvp world (all interfaces closed) so it can automatically detect the world (by detecting the pvp skull icon on bottom right)
- Start with at least 1 of the logs you wish to turn into planks, and no amount of the other log types. (with bank closed because it also picks up logs types from the bank)

The script was originally used for private purposes only, and it assumes some pre configurations.
About the spellbook issue, it uses f keys to open the spell book. Are the account keybinds the default ones? F6 should be the one used to open the spellbook. I might change this later to try to detect the correct f key to use.

Share this post


Link to post
Share on other sites
Posted (edited)
On 2/28/2020 at 5:57 PM, lb123 said:

Hey one last question about the script. I sat down and watched it run the 2000 planks that I had. It only withdrew 125 law runes and 900k and did not restock its gold nor law runes when it ran out. Is this supposed to happen?

No, it was supposed to get more from the bank. 
It only withdraws a maximum amount to prevent running around with too much gold. Because sometimes it can miss click the portal and get killed outside. By the way, if you haven't already, i suggest you move your poh to a remote location, where you are less likely to get killed. It teleports back inside asap if the script detects it's outside the house.

Are you absolutely sure you had more supplies in the bank? Laws, logs, coins (and maybe earth runes)? I've ran the script for thousand of hours, and never had that problem. Because it checks for supplies in the bank 25 times before actually assuming lack of supplies and stopping the script.

Edited by Beg

Share this post


Link to post
Share on other sites

ive been running the bot for about 5 hours now. works great as long as its set up as you stated already with the hotkeys. Only thing i noticed is that when the bot goes to teleport it always hovers over earth bolt before teleing. other than that, solid bot. im getting 4 other accs ready as well to run the bot both suicide and long term.

Share this post


Link to post
Share on other sites
On 3/18/2020 at 4:08 AM, dgreg said:

ive been running the bot for about 5 hours now. works great as long as its set up as you stated already with the hotkeys. Only thing i noticed is that when the bot goes to teleport it always hovers over earth bolt before teleing. other than that, solid bot. im getting 4 other accs ready as well to run the bot both suicide and long term.

Thanks for the feedback.
Currently, the script uses some fixed interface ids, and after some updates, the ids might change which can break the script's behaviour. It will be fixed in the next few minutes.

Share this post


Link to post
Share on other sites
5 hours ago, Beg said:

Thanks for the feedback.
Currently, the script uses some fixed interface ids, and after some updates, the ids might change which can break the script's behaviour. It will be fixed in the next few minutes.

sounds good, ill keep running the bot and will post some proggies in the next few days 

Share this post


Link to post
Share on other sites
Posted (edited)

could you help me, because i do not know if it is a failure of the bot or my computes, as it turns out that the bot works well but when you get to the house after giving the woods to the servant the bot when clicking on the camelot tp does no give it if what it stays on top of how do i do it? for the bot work well and followed all the specs and nothing

Edited by lukerino

Share this post


Link to post
Share on other sites

because when installing the bot it says that i am installing version 1.1 and when i start the bot in the client it says that it is version 1.0 and it does not mark time and how many plates and done it also does not give tp for camelot o lum as have already intended two forms

Share this post


Link to post
Share on other sites
23 hours ago, lukerino said:

could you help me, because i do not know if it is a failure of the bot or my computes, as it turns out that the bot works well but when you get to the house after giving the woods to the servant the bot when clicking on the camelot tp does no give it if what it stays on top of how do i do it? for the bot work well and followed all the specs and nothing

Do you mean the bot is not teleporting to camelot, after giving the logs to the servant?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   1 member

×
×
  • Create New...