Jump to content

[Open Source] TutTheIsland - Complete Tutorial Island Script


Recommended Posts

Hey guys!
 

New to the OSRS and botting community. I use to play this game a lot back in the day but haven't touched it in a very long time so pardon me if I don't get some stuff. I been very eager and excited to join the OSRS botting community and heard good things about tribot so I wanted to give it a go. I've developed my first script which is a tutorial island script. I've done some testing and was able to complete 5+ accounts without any problems.

All you have to do is select the script and choose the account you wish to have it complete tutorial island on and then just sit back and relax :)

I'm happy to share that this script is open-soruce and I will try my best to keep majority of my scripts open-sourced and free to the public. Any feedback on my code is greatly appreciated! Hope you all like it!

Github: https://github.com/ThatWebDevKid/RsBotScripts

Tribot Link: https://tribot.org/repository/script/id/3463

 

V1.1

- Addressed Bugs

- Refactor code to cache more and optimized a little more

Edited by ThatWebDevKid
  • Like 2
Link to post
Share on other sites

What do the gameState values from Game.getSetting() correspond to? What do the values mean? I added some logging to see the gameState as each Node executes and what value that the Traverser is receiving. Just from looking at the code and running it, it seems getting to Tutorial Island is a gameState of 1000? Where is this coming from? It seems totally arbitrary without any documentation.

E.g if I wanted to extend your script do do a task after tutorial island, how do I figure out the gameState values to trigger certain Traversals/Actions?

Edited by dzzl
Link to post
Share on other sites
On 4/20/2020 at 2:08 AM, dzzl said:

What do the gameState values from Game.getSetting() correspond to? What do the values mean? I added some logging to see the gameState as each Node executes and what value that the Traverser is receiving. Just from looking at the code and running it, it seems getting to Tutorial Island is a gameState of 1000? Where is this coming from? It seems totally arbitrary without any documentation.

E.g if I wanted to extend your script do do a task after tutorial island, how do I figure out the gameState values to trigger certain Traversals/Actions?

Hey! 

Sorry I was away for a while. Great question :)

Basically, Game.getSetting returns this number which represents the state of the state of the game at a certain point. The number returned changes at every stage of the tutorial island so that's how I know what code to run for every stage. Without it, it would be much harder and I would have to check for other things.

As for the 1000, I noticed that once I finish the tutorial island (the wizard teleports me to lumbridge), the gameState becomes 1000 so that's how I know I have finished the tutorial island and decide to break out of my running loop and log out the user. I really just figured this out through logging out what the gameState is once I teleport to lumbridge so it does seem quite random and out of place.

As for wanting to run code after my script finishes the tutorial island, I'm not sure what the best way to go about that is if I'm being honest. Maybe when the first running loop finishes (when gameState reaches 1000), you can start another running loop? I haven't done this before so I cannot give you the best advice. You may want to join the Tribot discord and ask there as scripters with more experience and knowledge may be able to assist you better.

Thanks for using my script! Hope it worked well without bugs. Appreciate the feedback!

 

Link to post
Share on other sites
  • 2 weeks later...

just wanted to give you a heads up that 3 out of 4 times on running it, the script gets stuck when the wizard asks you to click on the chicken with magic. it just kinda sits there and clicks the wind attack button. once i click the chicken for it, it continues correctly

 

 

Congrats on this release tho :)

Edited by osiris801
fix text color
Link to post
Share on other sites
  • 3 weeks later...

Great script when it decides to start! Sadly sometimes it will get stuck on the Login bot and then not proceed to do the area.

Only console feedback is login bot login -> succeeded. 😞 doesn't even type the initial name. Any chance you'd be able to look into this? Cheers!

Edit: bot debug shows the following

Screenshot 2020-05-22 at 17.06.00.png

Edited by Yorambo
Link to post
Share on other sites

Hell yeah bro, great script.

Sometimes it gets stuck doing random stuff though, if you get a chance maybe run like 5 accounts through and see if you catch anything, on one of my accounts it kept trying to walk out of the first initial gate even though the current task was to chop down a tree

regardless, very useful release as your first script, I bet you'll pump out some really solid scripts soon

Edited by machoflops
Link to post
Share on other sites
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Our picks

    • What to expect from TRiBot moving forward.
        • Thanks
        • Like
      • 10 replies
    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 39 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 13 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...