Jump to content
  • 0

Cant Get Looking Glass to Work


Question

Just got a new Windows 10 Home x64 Laptop. Going through my usual install method and finding that I cant get looking glass to work. I have followed a few "old" guides, because I cant find any that are more recent. I am installing Java SE Development Kit 8u251, I am choosing the x86 version since the only OSbuddy cross platform .jar  file is 32bit. Its worked fine in the past. I then open Osbuddy, and then Open Tribot. I leave it on the default Tribot Version of 10.24.1. I select the java version for Tribot to use to be the JDK and not the jre. I changed the Heap Size to 1024 MB and login. I minimize Osbuddy, then I click New Client(Looking Glass). The Screen goes to black and says " Waiting for a Runescape client.... currently waiting for a valid client. List of detected java applications below." and there is nothing Below. I also tried a backup method that used to work as well, which was to instead click New Client (Osbuddy) and then manually select the Osbuddy .jar file which would open up Osbuddy and Create a Looking Glass Tab that mirrored Osbuddy. This no longer happens either. Ive also deleted the Hooks and Caches using Naton's Java Executable. I have also defined the correct Paths in my Computers Environment Variables.

Im at a loss for what to do. Any help greatly appreciated

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
41 minutes ago, Fluffee said:

My guess is that it might be JDK 8u251, it shouldn't matter but it might. Here's a link to JDK 8u201 which you can try? Be sure to uninstall JDK 8u251 first though 🙂

https://javadl.oracle.com/webapps/download/AutoDL?BundleId=236872_42970487e3af4f5aa5bca3f542482c60

This link was for 64bit JDk which I tried. Updated Java Environmental variables. Didnt work. Found the 32bit version of JDK 8u201, installed and changed Java Environmental variables again. Same thing. The only thing that is different about this version of Java and JDK 8u251, is that with 201, I get this error in the log. Im not sure if this could be the cause. I wouldnt think so, but I dont know for sure.

 

  • [13:53:17] TRiBot 10.24.0 loaded. (1.8.0_201:C:\Program Files (x86)\Java\jdk1.8.0_201\jre)
  • [13:53:17] Loading human mouse movement data.
  • [13:53:18] Apr 29, 2020 1:53:18 PM java.util.prefs.WindowsPreferences WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
  • [13:53:18] Successfully loaded human mouse data.
  • [13:53:57] No RuneScape client was found.
  • [13:54:26] No RuneScape client was found.

While waiting for new advice or things to try, I have attempted two fixes. I tried to create the reg key that is causing the error. Didnt do anything. Also, tried to force java to run as Admin, which resulted in tribot failing to launch entirely. Reverted both changes. 

Edited by briareos2285
Updated with more info
Link to post
Share on other sites
  • 0
14 minutes ago, Fluffee said:

Try hooking to this version of OpenOSRS instead of OSBuddy https://bitbucket.org/openosrsjava8/launcher/downloads/

When I tried this, it responded the same as the others. Just a black screen saying waiting for java clients. Then I cleared the Hooks again and tried again. When I tried to hook it using looking glass I got this big error in the log:

  • [14:30:39] Exception in thread "AWT-EventQueue-1"
  • [14:30:39] java.lang.ArrayIndexOutOfBoundsException: 0
  • [14:30:39] at javax.swing.plaf.basic.BasicTabbedPaneUI.tabForCoordinate(BasicTabbedPaneUI.java:1506)
  • [14:30:39] at javax.swing.plaf.basic.BasicTabbedPaneUI.setRolloverTab(BasicTabbedPaneUI.java:575)
  • [14:30:39] at javax.swing.plaf.basic.BasicTabbedPaneUI.access$2100(BasicTabbedPaneUI.java:54)
  • [14:30:39] at javax.swing.plaf.basic.BasicTabbedPaneUI$Handler.mouseEntered(BasicTabbedPaneUI.java:3629)
  • [14:30:39] at java.awt.AWTEventMulticaster.mouseEntered(AWTEventMulticaster.java:300)
  • [14:30:39] at java.awt.Component.processMouseEvent(Component.java:6548)
  • [14:30:39] at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
  • [14:30:39] at java.awt.Component.processEvent(Component.java:6304)
  • [14:30:39] at java.awt.Container.processEvent(Container.java:2239)
  • [14:30:39] at java.awt.Component.dispatchEventImpl(Component.java:4889)
  • [14:30:39] at java.awt.Container.dispatchEventImpl(Container.java:2297)
  • [14:30:39] at java.awt.Component.dispatchEvent(Component.java:4711)
  • [14:30:39] at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904)
  • [14:30:39] at java.awt.LightweightDispatcher.retargetMouseEnterExit(Container.java:4686)
  • [14:30:39] at java.awt.LightweightDispatcher.trackMouseEnterExit(Container.java:4664)
  • [14:30:39] at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4515)
  • [14:30:39] at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4476)
  • [14:30:39] at java.awt.Container.dispatchEventImpl(Container.java:2283)
  • [14:30:39] at java.awt.Window.dispatchEventImpl(Window.java:2746)
  • [14:30:39] at java.awt.Component.dispatchEvent(Component.java:4711)
  • [14:30:39] at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
  • [14:30:39] at java.awt.EventQueue.access$500(EventQueue.java:97)
  • [14:30:39] at java.awt.EventQueue$3.run(EventQueue.java:709)
  • [14:30:39] at java.awt.EventQueue$3.run(EventQueue.java:703)
  • [14:30:39] at java.security.AccessController.doPrivileged(Native Method)
  • [14:30:39] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
  • [14:30:39] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
  • [14:30:39] at java.awt.EventQueue$4.run(EventQueue.java:733)
  • [14:30:39] at java.awt.EventQueue$4.run(EventQueue.java:731)
  • [14:30:39] at java.security.AccessController.doPrivileged(Native Method)
  • [14:30:39] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
  • [14:30:39] at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
  • [14:30:39] at obf.vd.Ei(fg:308)
  • [14:30:39] at obf.vd.dispatchEvent(fg:35)
  • [14:30:39] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
  • [14:30:39] at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
  • [14:30:39] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
  • [14:30:39] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
  • [14:30:39] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
  • [14:30:39] at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
  • [14:31:10] No RuneScape client was found.

 

Edited by briareos2285
more info
Link to post
Share on other sites
  • 0

For anyone else struggling to get Looking Glass to Work. Try Fluffee's Fix that worked immmediately for me. Uninstall all your other java JDKs and regular java installs. Download Java JDK 8u102. Install. Delete your Hooks again. Run Tribot. Choose the new JDK. Open Osbuddy, wait til it loads up to the login screen. Then Click Looking Glass.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Fluffee
      Fluffee's Server Setup 3.0
      As some of you may know, I released an automated server setup script a little over a year ago. Albeit that script worked well, I was never fully satisfied with it, as I found it to be kind of messy to use. As a result, I rewrote the script, and restructured it, to add more, and stronger support for the different versions of Debian, the different versions of CentOS and the different versions of Ubuntu. However, with so many different Operating Systems being supported, and many different server providers having different setups, it's hard for me to test every possible scenario on my own. Which is why I've been privately handing this script out, and am now publicly looking for help.

      What does the script do?
      Similar to my previous setup script, this script changes the SSH port and creates a new user for connecting and using the server and disables root SSH connections; it installs the latest version of TightVNC Server (1.3.10) and sets that up with the desired port and password. It installs JDK 102 (32 or 64 bit depending on the OS), and installs TRiBot and OSBuddy and sets up the appropriate .jar file associations.
      What operating systems does it support?
      - CentOS (6.x, 7.x, 8.x) (32 and 64 bit)
      - Debian (7.x, 8.x, 9.x, 10.x) (32 and 64 bit)
      - Ubuntu (12.x, 14.x.16.x, 18.x, 20.x) (32 and 64 bit)
      Does it work?
      As far as I know, yes it does in fact work, and it works well if I might add. However, given that I can't test every possible setup, there is the potential for differences and issues
      How do I run the script?
      Login as root to a fresh VPS/dedi running one of the supported operating systems. From there run the commands listed below and follow the onscreen instructions. For those who would like to see the script's code, it can be found on my bitbucket here. The commands to run are as follows:
      (curl -kO https://bitbucket.org/teamfluffee/fluffees-server-setup/raw/master/fluffees-server-setup.sh || wget --no-check-cert https://bitbucket.org/teamfluffee/fluffees-server-setup/raw/master/fluffees-server-setup.sh) && chmod +x fluffees-server-setup.sh && bash fluffees-server-setup.sh -v Version History
       
    • By lau1992
      Hi!
      I was playing around with a VM as it is easier to manage multiple instances for me personally on my local machine (I do not use proxies, but use a vpn). But I can't get LG to work... On my local machine everything runs smooth, but on the VM it always says "looking for OSRS client" (you know the message). I have the same configuration as on my local machine.
      Is there a configuration property to be set on VM level or something? 
      All suggestions are welcome!
      --------Specs of the VM:
      - Clean install with VMware Workstation 15 Player running Windows 7 Ultimate (also tested with Windows 10 with VirtualBox)
      - Java JDK 8u251
      - OSBuddy.jar
      - Tribot loader 4.0.4

    • By ah12ims1
      as the title suggests, it works, but my issue is that for me it only works with OSbuddy. 
      this is what i have installed for java  
       
      however when i try and open the runelite (or open osrs) jar file i get this error 
      so, i inquired about what i should do to get RL or OPRS working, i installed JDK 11 (also 13 after to check if there was any diff, but none).
      this lead to RL working, but then my Tribot loader AND my OSB wouldnt load.
      my tribot loader didnt even give an error, it just didnt open, and my OSB gave this error 
       
      can someone please help me out, i just want to use tribot looking glass witrh runelite instead of OSB
    • By TRiLeZ
      This update includes:
      Fix OSBuddy LG input bug Fix updater exception Added error loading profile message to login-bot (Thanks @Todd) Prevent auto-relog from being typed in the client (Thanks @Todd) Comment out a pause in the clicking method (Thanks @Todd) Fix Prayer API (Thanks @Todd) To compensate VIP-E users for the downtime, all current VIP-E users (as of the time of extension) will be given an extension of 2 weeks. The extension will be applied sometime between 24 to 48 hours from now.
      A fix for RuneLite support is still in the works.
    • By FuryScape
      Hi
       
      I've been using Tribot for a few years now and recently when trying to hook my looking glass to my runelite client it just kept telling me it was the wrong version somehow (didn't install or uninstall anything) so I decided to uninstall the reinstall JDK 8U102 86x.
      After doing so my runelite still wouldn't hook to the client so I decided to uninstall runelite and reinstill it instead of the cross platform version I installed the "Windows 32 bit version". 
      This worked for the client that launches instantly after the installment of runelite 32bit every client I open after will give me the message that it wont hook to my looking glass.
      If anyone knows how to solve this issue please help as I have loads of scripts and accounts that are just sitting right now.
       
      Kind regards
       
      Noa
       

    • By voidk5
      Hey guys, I'm facing some problems with my Debian 8 VPS, currently I'm not able to install Java 8, I was using this as reference https://tecadmin.net/install-java-8-on-debian/ but as it says "IMPORTANT: Java 8 is no longer available to download publically. You can use below link to install Java 11."  Java 8 can't be downloaded anymore, so I tried to use Java 11, but TRiBot doesn't work with it. 
      Anyone can have with this? 
      I'll give more info if required.
       
       
    • Guest
    • Guest
      By Guest
      could someone reply with all the steps to be able to use looking glass. i use to have a link to a forums with all the steps; however, it's saying i don't have permission to see it.
    • By pktilldeath
      When I try to use LG I get a message saying "Must run tribute using Java JDK in order to use Looking Glass". I just downloaded the most up to date version of java so I'm not sure why I'm getting this error message. I also have the oars client up in the background. Can someone please help me solve this so I can start botting a bit more safely?
       
      ( @iFluffee Maybe you can help me out for the 100th time? haha)
    • Guest
      By Guest
      I've setup a SOCKS5 proxy with tribot, and I want to bot on that IP address.
      Can I use the Looking Glass with the osbuddy client?
      I have noticed before using the looking glass feature, you have to wait for osbuddy to load to the login screen. Now I'm 100% sure while osbuddy is 'loading' its using my 'Main' IP address. Then I proceed to login with my bot user/pass and I suspect my main ip is linked with the bot account.

      So is there a way of using Looking Glass with a proxy? or do I have to use the build in Client supported by tribot?
       
       
  • Our picks

    • What to expect from TRiBot moving forward.
        • Thanks
        • Like
      • 10 replies
    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 39 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 13 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...