Jump to content

[Premium] JBotStarter - The Ultimate Account Creation Tool [CLI Support | 40+ Tasks | 30+ Quests | 10+ Skills | Advanced User Customisation]


Recommended Posts

  • Replies 333
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

JBotStarter is your one stop shop for fully automated RS Account Creation, the ultimate account creation tool. Ever wanted to farm Runescape but not had the time to make endless numbers of accoun

Hi Leroy, Yes the script should fully function on it's own. You've been really unlucky in the fact that all three quests (Monk's Friend, Pirate's Treasure and Druidic Ritual) you've run have been very

Update 01/06/2020: - Reimplemented ::toggleroofs on script start. This was accidentally removed a few updates ago when implementing my new failsafe framework. Monk's Friend - Script should

1 minute ago, burnsy1213 said:

@HeyImJamie how long do you think it's gonna take to fix it? cheers

https://gyazo.com/2bdeef89af2b3557b3671d39b892d8a7 also one of the errors

 

 

3 hours ago, HeyImJamie said:

Thanks for the comments guys. A fix will be coming this evening (UK time) for the chat failsafe causing the script to stop. I’ll be whitelisting certain messages - If you have a message you believe should be whitelisted, I.e. You cut some logs, can you message me with these messages. 
 

- Jamie

 

Link to post
Share on other sites

 

4 hours ago, skrillkilla said:

I guess its supposed to be fixed at some point. hes aware.

 

3 hours ago, skrillkilla said:

this is damn near unusable every time it receives any message more than 5 times its shuts down, not trying to be a jerk but i dont know if this was a problem on release or not but i wish i would of known about this before i purchased it. 😕

 

42 minutes ago, exerilith said:

I just bought it too, I get stuck on fishing, wc, prayer, and a quest so far. Did you test your own script?

I've posted above in regards to this. A fix is due to be released in the next ~5 minutes, I'm just testing it to ensure it's working. In future, should there be another similar issue, where did you look prior to commenting? I'd like to make sure everyone is aware of the issue and that's it's known, rather than having you all post the same thing. I'll post back when the update is pushed.

Link to post
Share on other sites

@exerilith @skrillkilla @ruddydeloos @burnsy1213

Apologies for the delay in getting this out. I've been at work.

Update 22/05/2020:

- Implemented a whitelist for certain game messages to stop the failsafe previously implemented activating unnessecarily. If your script stops and you believe it shouldn't, please let me know of the game message and I'll whitelist it.
- Attempted a fix at certain dialogues exiting prior to their completion.
 

Link to post
Share on other sites
3 minutes ago, HeyImJamie said:

After talking to Elena? It should try and walk to the stairs. Does the log say something along the lines of “Failed to find path: “?

I checked on the bot and it was in the jail cell with the door closed while it was trying to click on the stairs. Then it stopped because of the 5 message thing.

Link to post
Share on other sites
17 hours ago, HeyImJamie said:

Thanks for the comments guys. A fix will be coming this evening (UK time) for the chat failsafe causing the script to stop. I’ll be whitelisting certain messages - If you have a message you believe should be whitelisted, I.e. You cut some logs, can you message me with these messages. 
 

- Jamie

"You make a pair of leather gloves"

 

Edit: ALL LEATHER CRAFTING

Edited by tdog9908
Link to post
Share on other sites
8 hours ago, jiitz said:

Hey, I ran into this problem starting script:

Bot Debug: https://pastebin.com/FNZ6jf7q

Client Debug: https://pastebin.com/3K2S9CtV

 

It get stuck purchasing items from ge, types it in caps and loops. 

Very odd. Can you try restarting your client and seeing if that works. If it doesn’t, setting slayer equipment may sort it? I’m not sure how it’s getting the equipment slot over the string. I’ll take a look and get back to you!

7 hours ago, exerilith said:

Pirate's treasure bugged on a different account. Bot trys to put the rum in the banana box when it already did.

Did anything get printed in the debug saying something along the lines of “already been used”? It should recognise its messed up and continue. 

 

9 hours ago, exerilith said:

I checked on the bot and it was in the jail cell with the door closed while it was trying to click on the stairs. Then it stopped because of the 5 message thing.

I’ll make it open the door rather than trying to path it’s way out. 

Link to post
Share on other sites

Bot has a real banking problem.

80fe1a0be8f93c81a05268ca1f6f277a.png

2638ee9bb562d6081b191c2156c72ea2.png

 

I've noticed the following:

- Bot just opens and closes bank constantly.
- Always goes to the GE
- Buys the same items over and over
- Gets stuck in the GE trading interface when trying to open the bank
- If it fails to purchase an item, it will sometimes just wait, like hours, until it buys.

In addition, i've noticed slayer runs to the monsters, then teleports to GE, in a loop.
Slayer, basic chickens fail, if any chickens are outside of the gate, or inside of the door, bot fails.
Woodcutting with firemaking the logs on can glitch out trying to click inside gertudes house

An additional request would be basic slayer gear automatically identified and bought (starting with the basic iron the bot buys as a default equipment set). Otherwise it will just punch everything.

Basic quest item setup for priest in peril fails over and over, fixed this by manually depositing worn items

7bc0ce42f55474a155ee189c0ce9af03.png

 

expensive:

17fc440d84ef39cd9ece40c2caf532ed.png

Edited by LowieFTW
Link to post
Share on other sites

Hi again!
I have made good gains today and I am very pleased with the script!
Some notable improvements from my side that I noticed while watching:

- While starting Priest In Peril, he struggles with switching addy while you have a rune scimitar equiped.
- Starting Slayer Tasks are done without a weapon, although we have some in the bank
- Died during Jungle Potion as getting a Rogue's Purse takes quite some time and he doesn't manage to stay out of range of the Ogres. Would suggest to make him walk to the furthest one where no ogre can attack you.

 

Keep it up! :)

 

Link to post
Share on other sites

I'd just like to say, despite all of these small issues, this script is amazing.

I'm running 9 accounts on 6 hour intervals, only 1 bot has had a ban and that's probably because it got stuck somewhere and i wasn't watching it to intervene. Most have got 50QP, great base stats. 

When this script is 100% polished, this is going to be the go-to script for creating accounts. Keep up the good work!

Link to post
Share on other sites

ran it for 6 hrs yesterday its going better, today though while getting rdy for mountain daugher it just takes the items out and sits at the bank i tried teleing and having start in front o f the area it teleports to the ge buy a dueling ring deposits the items it just took out for the quest and then retakes them out and just stands there.

the debug just says withdrew items successfully 

and 

attempting to withdraw items attempt 1 thanks in advanced.

 

*update*it seems manually starting the quest made it work.

Edited by skrillkilla
Link to post
Share on other sites

Merlin's crystal doesn't speak to the lady about the Excalibur, just walks back and forth between the door.
Script doesn't support crawling hands, recognises them as banshees.
Bot gets stuck trying to drop the bucket for priest in peril due to its drop option being the first option.
Plague quest gets stuck inside cage.

Edited by LowieFTW
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Our picks

    • What to expect from TRiBot moving forward.
        • Thanks
        • Like
      • 10 replies
    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 39 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 13 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...