Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

TRiLeZ

Auth0 Login (Changes)

Recommended Posts

Posted (edited)

If you're still having issues, make sure the TRiBot Login says Email. If it does not say Email, download TRiBot again from this website (should be at the top or on the side of this page where it says Download). If you can not log into the forums, make sure you are using the Login (Auth0) button and are not trying to login with your display name.

image.png.6bd28b8080e28a3e6221a1067d09b79f.pngfirefox_IbpaHRAfYF.png

Edited by Encoded
  • Thanks 1

Share this post


Link to post
Share on other sites

Would it be at all possible to perhaps get the devs to hire someone to act as the community liason? Someone who can be more accountable than the devs to interact, communicate, and be the face of the community? I would be interested personally... I feel like this platform has so much potential and very little effort goes in on the communication side.

  • Like 2

Share this post


Link to post
Share on other sites
20小時前 , TRiLeZ 說:

Hello everyone,

Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

Important changes

  • When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials
    • Note: 2FA is still handled through your forums account (for the time being)

Changes for existing users

Important notes

  • Make sure to verify your email address upon creating a new Auth0 account
  • When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below

image.png.a28ac6835d296e611ca1a505ba1f27db.png

I have logged in to the Auth0 account and connected the tribot account, why can’t my tribot login interface be successfully logged in? Please point out my mistakes and help me run it normally, thank you

125.png

552.png

Share this post


Link to post
Share on other sites
18 minutes ago, dang7789597 said:

I have logged in to the Auth0 account and connected the tribot account, why can’t my tribot login interface be successfully logged in? Please point out my mistakes and help me run it normally, thank you

125.png

552.png

Use your email, not your display name.

Share this post


Link to post
Share on other sites
5 hours ago, 3298759219 said:

Can log in into forums using auth0 but, there is no way to log into client, ive already updated and trying to change password.
Please, fix this asap.

6666666666666666666666666666.png

You need to change pass on new login page auth.tribot.org , not on forums

Share this post


Link to post
Share on other sites
13小時前 , Encoded 說:

If you're still having issues, make sure the TRiBot Login says Email. If it does not say Email, download TRiBot again from this website (should be at the top or on the side of this page where it says Download). If you can not log into the forums, make sure you are using the Login (Auth0) button and are not trying to login with your display name.

image.png.6bd28b8080e28a3e6221a1067d09b79f.pngfirefox_IbpaHRAfYF.png

The client I am using now displays the nameMy operating system is 32-bit how to download new and support 32-bit
Client?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 8 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 13 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...