Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

TRiLeZ

Auth0 Login (Updates)

Recommended Posts

Hi everyone,

I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

What does this mean for me?

  • If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.
  • If you haven't logged in via our new login yet,
    • Try logging in with your forums email address and the last password you used
    • If you are unable to login, please use the "Forgot password" tool on the login page:
      image.png.a07e139f69045410d4e95f3037f64e87.pngimage.png.7d4fc1bfaa2b77b958a6bd9cbb72d726.png
      • Follow the instructions to reset your password
         
  • Like 1
  • thonking 1

Share this post


Link to post
Share on other sites
On 8/16/2020 at 2:25 AM, spawn2000 said:

can you fix your damn client please, im paying money for shit i can't use

What issue are you hitting when you try to login? Are you using your email address or your username?

 

1 hour ago, zoxie said:

THIS, honestly what a garbage ass decission to implent such dumb ass shit, i'm really tilted 

Are you hitting any issues with logging in? If so, is there anything I can help you with?

Share this post


Link to post
Share on other sites

I've noticed some users have been having troubles logging in because their email has not been verified. I've added a rule to automatically resend verification emails when users try to login with an unverified email.

Please send either myself or @Fluffee a message on Discord if you continue to experience problems logging in.

My Discord: TRiLeZ#8944
Fluffee's Discord: Fluffee#9509

Share this post


Link to post
Share on other sites
On 8/13/2020 at 4:02 PM, TRiLeZ said:

Hi everyone,

I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

What does this mean for me?

  • If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.
  • If you haven't logged in via our new login yet,
    • Try logging in with your forums email address and the last password you used
    • If you are unable to login, please use the "Forgot password" tool on the login page:
      image.png.a07e139f69045410d4e95f3037f64e87.pngimage.png.7d4fc1bfaa2b77b958a6bd9cbb72d726.png
      • Follow the instructions to reset your password
         

I've been using the client with no issues until today. I restarted my PC and my user and pass was not automatically in the client login anymore.. now when I enter it says it's invalid. My auth0 is connect and active in my profile settings. I tried using my e-mail ro login and also tried resetting my password but it told me I can't reset my password right now..? Any solutions?

Share this post


Link to post
Share on other sites
47 minutes ago, Anabolic_Bot said:

I've been using the client with no issues until today. I restarted my PC and my user and pass was not automatically in the client login anymore.. now when I enter it says it's invalid. My auth0 is connect and active in my profile settings. I tried using my e-mail ro login and also tried resetting my password but it told me I can't reset my password right now..? Any solutions?

I see you've successfully logged into the client using your email 38 minutes ago. Please let me know if you have further problems.

Share this post


Link to post
Share on other sites
On 8/23/2020 at 12:54 AM, Lolwhathax said:

....


Fixed

EDIT2: is there a way to change my current email attached to tribot to another one?

There isn't an easy method, but if you open a ticket on the helpdesk I should be able to do that for you 🙂

Share this post


Link to post
Share on other sites

been using Tribot since 2013 (?) i am not a frequent user nor player of runescape but sometimes ill get back to botting and or playing. However this new update you rolled out literally SUCKS. navigating around the page is a living hell.. Also lost my main account cannot login to it however i do (?) invalid password cannot recover. Had a f''''ing hell just creating this account. every time i try to register it would "work" to eventually not working. my user wasnt registered in any way. 

I managed to create an account by pressing on some external link like "do you want to post on forums login or create account" just pressing the regular login > create new account wouldn´t work. 

Considering how complicated and F''''ed up everything has become i am thinking of going to *another bot* or anything similar tribot seems more over complicated than ever and not really for the better.

Edited by Einstein
No advertising for other platforms please.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
      • 17 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
      • 10 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 17 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...