Jump to content
  • 0

trouble after start client


Question

Hi, I am running TriBot using Intellij. I am trying to start a client, however I get an error and I cannot seem to solve this.

This happens when clicking Start Client

 

Any suggestions?

Successfully loaded human mouse data.
Exception in thread "-1" java.lang.ExceptionInInitializerError
    at obf.bH.sL(wd:109)
    at obf.bH.<init>(wd:14)
    at obf.zG.<init>(pd:78)
    at obf.rh.<init>(dl:178)
    at obf.MG.<init>(jd:209)
    at obf.Ve.run(wf:131)
    at java.base/java.lang.Thread.run(Thread.java:831)
Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make field static final java.util.Random java.lang.Math$RandomNumberGeneratorHolder.randomNumberGenerator accessible: module java.base does not "opens java.lang" to unnamed module @462d5aee
    at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:357)
    at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:297)
    at java.base/java.lang.reflect.Field.checkCanSetAccessible(Field.java:177)
    at java.base/java.lang.reflect.Field.setAccessible(Field.java:171)
    at obf.yh.sm(fe:39)
    at obf.yh.<clinit>(fe:32)
    ... 7 more


Thank you

 

Resolved by setting up remote debugger and swapping to JDK 15 as JDK 16 is unsupported. 

 

Using Intellij click the configurations on top right and click edit configurations 

image.png.b565b91368a226d2249ddbfabb75aa48.png

 

Click the plus and add Remote JVM Debug

image.png.79a887139bafc8a1c726cd869c49295a.png

 

Check off Allow parallel run and copy the Command line arguments for remote JVM (see red box)

image.png.21ae81e138f723870664cc5f822e86c9.png

 

Go to main Tribot configuration and add the coppied text like so

image.png.b982623138edc8d39810c66ca4ca03c3.png

 

JDK 16 is not supported. JDK 15 worked fine for me.

 

Thank you @Fluffee for the support on discord.

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Our picks

    • Support for the gradle launcher is being dropped. Read more about the new launcher here.
        • Like
      • 1 reply
    • What to expect from TRiBot moving forward.
        • Thanks
        • Like
      • 11 replies
    • TRiBot 12 Release Candidate

      The TRiBot team has been hard at work creating the last major version of TRiBot before the TRiBot X release. We've noticed many problems with TRiBot 11 with a lot of users preferring TRiBot 10 over 11. We've heard you, so we took TRiBot 10, added the new features introduced with 11, introduced some other new things, and created TRiBot 12. So without further adieu, here's TRiBot 12.
        • Sad
        • Like
      • 40 replies
    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 13 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...