Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Usa

USA's Abyss Runecrafter [650K/HR+][ALL RUNES! 1-99][ABCL 10]

Recommended Posts

Can you put energy restore potion option back into the client? I like the stamina potion option was added but getting rid of the energy restore option has left me with 6k of those potions i cannot use :/ also the fact that one most of my accounts i don't want to use stamina potions. Thanks a lot because i love this script. I hope this is an easy fix <3

I would sell them. In terms of efficiency/use of potions, there is no point to use anything other than Stamina potions or not at all. You'd just be wasting your money.

 

Does this bot have lava support/ how well does it work?

This is for abyss runecrafting. Not sure what lava support is

Share this post


Link to post
Share on other sites

found 1 problem with the script. Sometimes, it clicks on the wilderness ditch twice because of lag, then, since it clicked twice, it ends up hopping over then hopping back. After that, it tries to run into the wilderness but cant because it is in the safe side of the ditch.

Edited by Mark

Share this post


Link to post
Share on other sites

what equipment would you recommend me wearing @ 99 def 99 hp? :)

 

 

found 1 problem with the script. Sometimes, it clicks on the wilderness ditch twice because of lag, then, since it clicked twice, it ends up hopping over then hopping back. After that, it tries to run into the wilderness but cant because it is in the safe side of the ditch.

 

 

is that all from this script? DAMN. How many hours do u bot a day lol

 

First of all.. It's possible to edit your post so you don't have to post three times in a row.

 

@99hp/def wear something that doesn't make u look like a bot and something that's common among rcers.

 

Wilderness glitch have happened to me too.

 

It's runs for as long as I want it to run except now because the House Teleport is broken, it just clicks magic tab and never teleports @Usa

 

 

And I've used this script for a looooooong time to achieve my RC.

Share this post


Link to post
Share on other sites

Thanks Zumzod.

 

@Usa, is there any way I can disable it from teleporting when it sees someone the same combat level as me in the wilderness? I've deleted every thing in the "avoid people in the wilderness wearing the following.." etc.

 

Earlier a guy the same level as me (120+) was literally running beside me, not even attacking, and the script teleported me and tried changing worlds

Edited by Mark

Share this post


Link to post
Share on other sites

Am I able to use the break handler with this script? Reason being is that im trying to evade the 6 hour force logout by jagex (if that still exists). Good news is that the script logs out every few hours because of a high leveled enemy that it tries to evade.

Share this post


Link to post
Share on other sites

Am I able to use the break handler with this script? Reason being is that im trying to evade the 6 hour force logout by jagex (if that still exists). Good news is that the script logs out every few hours because of a high leveled enemy that it tries to evade.

 

No there is no break handler which is really.. Lame. So all you can hope is that he implements something on his own.

Share this post


Link to post
Share on other sites

@Usa

 

Here are some improvements i'd like to suggest:

 

1. Make it so that it doesn't emergency teleport away when any person your combat level passes by. It literally emergency teleported me when a dude with full graceful ran near by. No threat, literally. This will improve xp and gp / hr. To test this, I also deleted all the default items you set for the "avoid people wearing" , cause it literally teleports too often. 

 

2. Adding a break feature. This would be really helpful considering many of us do want to use the break feature of tribot, but can't because doing so will have the possibility of stopping in the outer part of the abyss or in the wilderness. 

 

3. Could you make it so that it also drinks stamina potions 3? atm its only drinking my stamina potions (4). Haven't tested this out long enough though, so im not sure whether or not it will actually drink the lower doses.

 

This should put your script to good competition vs the others :D Other than that, overall great script.

Edited by Mark

Share this post


Link to post
Share on other sites

UPDATE: 

 

1 Hour proggie with stamina potions 

 

135 mouse speed

 

Take note that the profit made and profit per hour is inaccurate as I did not update the prices for runes, teleports, and pure essence in the GUI.

oadf29.png

Edited by Mark

Share this post


Link to post
Share on other sites

@Usa

 

Here are some improvements i'd like to suggest:

 

1. Make it so that it doesn't emergency teleport away when any person your combat level passes by. It literally emergency teleported me when a dude with full graceful ran near by. No threat, literally. This will improve xp and gp / hr. To test this, I also deleted all the default items you set for the "avoid people wearing" , cause it literally teleports too often. 

 

2. Adding a break feature. This would be really helpful considering many of us do want to use the break feature of tribot, but can't because doing so will have the possibility of stopping in the outer part of the abyss or in the wilderness. 

 

3. Could you make it so that it also drinks stamina potions 3? atm its only drinking my stamina potions (4). Haven't tested this out long enough though, so im not sure whether or not it will actually drink the lower doses.

 

This should put your script to good competition vs the others :D Other than that, overall great script.

 

1. It should only teleport away if they are in your combat range and are wearing one of the items in the "Avoid players wearing" box in the GUI

 

2. Possibly, sure.

 

3. It drinks all stamina potions (4) through (1) it just prioritizes by looking for the (4) first. It shouldn't make a difference which it drinks, as it only needs to sip one each trip to sustain the effects.

Share this post


Link to post
Share on other sites

1. It should only teleport away if they are in your combat range and are wearing one of the items in the "Avoid players wearing" box in the GUI

 

2. Possibly, sure.

 

3. It drinks all stamina potions (4) through (1) it just prioritizes by looking for the (4) first. It shouldn't make a difference which it drinks, as it only needs to sip one each trip to sustain the effects.

 

Appreciate the response. Hope to see the break improvement soon :D

Share this post


Link to post
Share on other sites

@Usa

 

 

Home teleport stopped working. Just sitting there watching the tab.

*correction that it's teleport to house*

 

 

Still the same error... Talked to Trilez and he said you don't even use the API so it's an error in your script. Would be nice if you could fix it soon since it's been 5days now that I can't bot...

Edited by Zumzod

Share this post


Link to post
Share on other sites

Only problem with the script right now :

 

Whenever the world lags, or I get dced from the game, the bot tries to log me in, but when it says "you're account is already logged in try again after 60 seconds", it just gives up and stands there. Can I suggest that you make it try clicking login again? Because all it needs to do is wait a few more seconds to successfully log in.. Same goes for when it says "error connecting to server". All it has to do is wait a few more seconds, click log in, then it will work. 

 

Thanks.

Edited by Mark

Share this post


Link to post
Share on other sites

Only problem with the script right now :

 

Whenever the world lags, or I get dced from the game, the bot tries to log me in, but when it says "you're account is already logged in try again after 60 seconds", it just gives up and stands there. Can I suggest that you make it try clicking login again? Because all it needs to do is wait a few more seconds to successfully log in.. Same goes for when it says "error connecting to server". All it has to do is wait a few more seconds, click log in, then it will work. 

 

Thanks.

 

The client handle logins not the script so post that in client bugs or something.

Share this post


Link to post
Share on other sites

I'm wondering why it randomly just stops clicking the rocks or whatever sometimes?

 

You'll find it doing it wherever, but if it does it in the outer ring abyss you're pretty much dead, even with a ring of life since my account is only 64 defence.

 

I've used this script since it very first came out, it used to be a problem but it seems I'm waking up every morning atm and getting pouches again =.=.... USA dude what's causing the complete shutdown? After a while it'll continue to function as usual as I've watched it in the inner ring, but if its on the outer and you dont intervene, it'll die...

 

DmC10sK.png

 

basically a pic of it doing fuk all for 1min+ after watching it, any ideas why?

Edited by Rhalala

Share this post


Link to post
Share on other sites

I'm wondering why it randomly just stops clicking the rocks or whatever sometimes?

 

You'll find it doing it wherever, but if it does it in the outer ring abyss you're pretty much dead, even with a ring of life since my account is only 64 defence.

 

I've used this script since it very first came out, it used to be a problem but it seems I'm waking up every morning atm and getting pouches again =.=.... USA dude what's causing the complete shutdown? After a while it'll continue to function as usual as I've watched it in the inner ring, but if its on the outer and you dont intervene, it'll die...

 

DmC10sK.png

 

basically a pic of it doing fuk all for 1min+ after watching it, any ideas why?

 

The only delay I could imagine there would be the ABCL sleep, although that value is set to true for combat so it shouldn't sleep for any significant time.

 

What was the "Status:" of the script at the time?

 


 

Updated to v16.6 to use the TRiBot API Magic class for teleporting.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Gradle is a build tool used to accelerate developer productivity.

      We recently setup a Maven repository (TRiBot Central) to make it easier for scripters to create scripts. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-central/-/packages

      Furthermore, we've released a simple Gradle project to make it easy to run TRiBot and develop scripts for it. Check it out here: https://gitlab.com/trilez-software/tribot/tribot-gradle-launcher

      The goals of TRiBot Central are to:

      Deliver updates to TRiBot faster


      Better organize TRiBot's dependencies (AKA dependancies)


      Make it easier to develop scripts for TRiBot


      Make it easier to use and run TRiBot


      Note: TRiBot won't be able to run scripts from within this project until TRiBot's next release.
        • Like
      • 9 replies
    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
        • thonking
        • Like
      • 15 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 81 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...